summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/python/files/python-2.3-readline.patch295
-rw-r--r--dev-lang/python/files/python-2.4-readline.patch309
-rw-r--r--dev-lang/python/python-2.3.5.ebuild12
-rw-r--r--dev-lang/python/python-2.4-r3.ebuild11
4 files changed, 621 insertions, 6 deletions
diff --git a/dev-lang/python/files/python-2.3-readline.patch b/dev-lang/python/files/python-2.3-readline.patch
new file mode 100644
index 000000000000..ef2de80394fd
--- /dev/null
+++ b/dev-lang/python/files/python-2.3-readline.patch
@@ -0,0 +1,295 @@
+Common subdirectories: Python-2.3.5/Demo and Python-2.3.5.new/Demo
+Common subdirectories: Python-2.3.5/Doc and Python-2.3.5.new/Doc
+Common subdirectories: Python-2.3.5/Grammar and Python-2.3.5.new/Grammar
+Common subdirectories: Python-2.3.5/Include and Python-2.3.5.new/Include
+Common subdirectories: Python-2.3.5/Lib and Python-2.3.5.new/Lib
+Common subdirectories: Python-2.3.5/Mac and Python-2.3.5.new/Mac
+Common subdirectories: Python-2.3.5/Misc and Python-2.3.5.new/Misc
+Common subdirectories: Python-2.3.5/Modules and Python-2.3.5.new/Modules
+Common subdirectories: Python-2.3.5/Objects and Python-2.3.5.new/Objects
+Common subdirectories: Python-2.3.5/PC and Python-2.3.5.new/PC
+Common subdirectories: Python-2.3.5/PCbuild and Python-2.3.5.new/PCbuild
+Common subdirectories: Python-2.3.5/Parser and Python-2.3.5.new/Parser
+Common subdirectories: Python-2.3.5/Python and Python-2.3.5.new/Python
+Common subdirectories: Python-2.3.5/RISCOS and Python-2.3.5.new/RISCOS
+Common subdirectories: Python-2.3.5/Tools and Python-2.3.5.new/Tools
+Only in Python-2.3.5.new: autom4te.cache
+diff -up Python-2.3.5/configure Python-2.3.5.new/configure
+--- Python-2.3.5/configure 2005-01-11 13:48:52.000000000 +0000
++++ Python-2.3.5.new/configure 2005-04-20 17:30:19.158158596 +0100
+@@ -1,5 +1,5 @@
+ #! /bin/sh
+-# From configure.in Revision: 1.427.4.16 .
++# From configure.in Revision: 1.427.4.17 .
+ # Guess values for system-dependent variables and create Makefiles.
+ # Generated by GNU Autoconf 2.59 for python 2.3.
+ #
+@@ -20039,6 +20039,217 @@ _ACEOF
+
+ fi
+
++# what library does readline need to be linked with
++READLINE_SHARED_LIBADD=""
++echo "$as_me:$LINENO: checking for tgetent in -lncurses" >&5
++echo $ECHO_N "checking for tgetent in -lncurses... $ECHO_C" >&6
++if test "${ac_cv_lib_ncurses_tgetent+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ ac_check_lib_save_LIBS=$LIBS
++LIBS="-lncurses $LIBS"
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++
++/* Override any gcc2 internal prototype to avoid an error. */
++#ifdef __cplusplus
++extern "C"
++#endif
++/* We use char because int might match the return type of a gcc2
++ builtin and then its argument prototype would still apply. */
++char tgetent ();
++int
++main ()
++{
++tgetent ();
++ ;
++ return 0;
++}
++_ACEOF
++rm -f conftest.$ac_objext conftest$ac_exeext
++if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
++ (eval $ac_link) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest$ac_exeext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++ ac_cv_lib_ncurses_tgetent=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ac_cv_lib_ncurses_tgetent=no
++fi
++rm -f conftest.err conftest.$ac_objext \
++ conftest$ac_exeext conftest.$ac_ext
++LIBS=$ac_check_lib_save_LIBS
++fi
++echo "$as_me:$LINENO: result: $ac_cv_lib_ncurses_tgetent" >&5
++echo "${ECHO_T}$ac_cv_lib_ncurses_tgetent" >&6
++if test $ac_cv_lib_ncurses_tgetent = yes; then
++ READLINE_SHARED_LIBADD="-lncurses"
++else
++ echo "$as_me:$LINENO: checking for tgetent in -lcurses" >&5
++echo $ECHO_N "checking for tgetent in -lcurses... $ECHO_C" >&6
++if test "${ac_cv_lib_curses_tgetent+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ ac_check_lib_save_LIBS=$LIBS
++LIBS="-lcurses $LIBS"
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++
++/* Override any gcc2 internal prototype to avoid an error. */
++#ifdef __cplusplus
++extern "C"
++#endif
++/* We use char because int might match the return type of a gcc2
++ builtin and then its argument prototype would still apply. */
++char tgetent ();
++int
++main ()
++{
++tgetent ();
++ ;
++ return 0;
++}
++_ACEOF
++rm -f conftest.$ac_objext conftest$ac_exeext
++if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
++ (eval $ac_link) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest$ac_exeext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++ ac_cv_lib_curses_tgetent=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ac_cv_lib_curses_tgetent=no
++fi
++rm -f conftest.err conftest.$ac_objext \
++ conftest$ac_exeext conftest.$ac_ext
++LIBS=$ac_check_lib_save_LIBS
++fi
++echo "$as_me:$LINENO: result: $ac_cv_lib_curses_tgetent" >&5
++echo "${ECHO_T}$ac_cv_lib_curses_tgetent" >&6
++if test $ac_cv_lib_curses_tgetent = yes; then
++ READLINE_SHARED_LIBADD="-lcurses"
++else
++ echo "$as_me:$LINENO: checking for tgetent in -ltermcap" >&5
++echo $ECHO_N "checking for tgetent in -ltermcap... $ECHO_C" >&6
++if test "${ac_cv_lib_termcap_tgetent+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ ac_check_lib_save_LIBS=$LIBS
++LIBS="-ltermcap $LIBS"
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++
++/* Override any gcc2 internal prototype to avoid an error. */
++#ifdef __cplusplus
++extern "C"
++#endif
++/* We use char because int might match the return type of a gcc2
++ builtin and then its argument prototype would still apply. */
++char tgetent ();
++int
++main ()
++{
++tgetent ();
++ ;
++ return 0;
++}
++_ACEOF
++rm -f conftest.$ac_objext conftest$ac_exeext
++if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
++ (eval $ac_link) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest$ac_exeext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++ ac_cv_lib_termcap_tgetent=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ac_cv_lib_termcap_tgetent=no
++fi
++rm -f conftest.err conftest.$ac_objext \
++ conftest$ac_exeext conftest.$ac_ext
++LIBS=$ac_check_lib_save_LIBS
++fi
++echo "$as_me:$LINENO: result: $ac_cv_lib_termcap_tgetent" >&5
++echo "${ECHO_T}$ac_cv_lib_termcap_tgetent" >&6
++if test $ac_cv_lib_termcap_tgetent = yes; then
++ READLINE_SHARED_LIBADD="-ltermcap"
++fi
++
++
++fi
++
++
++fi
++
++
+ # check for readline 2.2
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+@@ -20104,7 +20315,7 @@ if test "${ac_cv_lib_readline_rl_pre_inp
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lreadline -ltermcap $LIBS"
++LIBS="-lreadline $READLINE_SHARED_LIBADD $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -20178,7 +20389,7 @@ if test "${ac_cv_lib_readline_rl_complet
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lreadline -ltermcap $LIBS"
++LIBS="-lreadline $READLINE_SHARED_LIBADD $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+diff -up Python-2.3.5/configure.in Python-2.3.5.new/configure.in
+--- Python-2.3.5/configure.in 2005-01-11 13:49:00.000000000 +0000
++++ Python-2.3.5.new/configure.in 2005-04-20 17:30:13.836019150 +0100
+@@ -2840,6 +2840,14 @@ then
+ [Define this if you have flockfile(), getc_unlocked(), and funlockfile()])
+ fi
+
++# what library does readline need to be linked with
++READLINE_SHARED_LIBADD=""
++AC_CHECK_LIB(ncurses, tgetent, [READLINE_SHARED_LIBADD="-lncurses"],
++ AC_CHECK_LIB(curses, tgetent, [READLINE_SHARED_LIBADD="-lcurses"],
++ AC_CHECK_LIB(termcap, tgetent, [READLINE_SHARED_LIBADD="-ltermcap"])
++ )
++ )
++
+ # check for readline 2.2
+ AC_TRY_CPP([#include <readline/readline.h>],
+ have_readline=yes, have_readline=no)
+@@ -2854,12 +2862,12 @@ fi
+ # check for readline 4.0
+ AC_CHECK_LIB(readline, rl_pre_input_hook,
+ AC_DEFINE(HAVE_RL_PRE_INPUT_HOOK, 1,
+- [Define if you have readline 4.0]), , -ltermcap)
++ [Define if you have readline 4.0]), , $READLINE_SHARED_LIBADD)
+
+ # check for readline 4.2
+ AC_CHECK_LIB(readline, rl_completion_matches,
+ AC_DEFINE(HAVE_RL_COMPLETION_MATCHES, 1,
+- [Define if you have readline 4.2]), , -ltermcap)
++ [Define if you have readline 4.2]), , $READLINE_SHARED_LIBADD)
+
+ AC_MSG_CHECKING(for broken nice())
+ AC_CACHE_VAL(ac_cv_broken_nice, [
diff --git a/dev-lang/python/files/python-2.4-readline.patch b/dev-lang/python/files/python-2.4-readline.patch
new file mode 100644
index 000000000000..3dbeb8e02727
--- /dev/null
+++ b/dev-lang/python/files/python-2.4-readline.patch
@@ -0,0 +1,309 @@
+Common subdirectories: Python-2.4/Demo and Python-2.4.new/Demo
+Common subdirectories: Python-2.4/Doc and Python-2.4.new/Doc
+Common subdirectories: Python-2.4/Grammar and Python-2.4.new/Grammar
+Common subdirectories: Python-2.4/Include and Python-2.4.new/Include
+Common subdirectories: Python-2.4/Lib and Python-2.4.new/Lib
+Common subdirectories: Python-2.4/Mac and Python-2.4.new/Mac
+Common subdirectories: Python-2.4/Misc and Python-2.4.new/Misc
+Common subdirectories: Python-2.4/Modules and Python-2.4.new/Modules
+Common subdirectories: Python-2.4/Objects and Python-2.4.new/Objects
+Common subdirectories: Python-2.4/PC and Python-2.4.new/PC
+Common subdirectories: Python-2.4/PCbuild and Python-2.4.new/PCbuild
+Common subdirectories: Python-2.4/Parser and Python-2.4.new/Parser
+Common subdirectories: Python-2.4/Python and Python-2.4.new/Python
+Common subdirectories: Python-2.4/RISCOS and Python-2.4.new/RISCOS
+Common subdirectories: Python-2.4/Tools and Python-2.4.new/Tools
+Only in Python-2.4.new: autom4te.cache
+diff -up Python-2.4/configure Python-2.4.new/configure
+--- Python-2.4/configure 2004-11-07 01:24:12.000000000 +0000
++++ Python-2.4.new/configure 2005-04-20 17:35:32.380494843 +0100
+@@ -1,5 +1,5 @@
+ #! /bin/sh
+-# From configure.in Revision: 1.474 .
++# From configure.in Revision: 1.475 .
+ # Guess values for system-dependent variables and create Makefiles.
+ # Generated by GNU Autoconf 2.59 for python 2.4.
+ #
+@@ -19268,6 +19268,217 @@ _ACEOF
+
+ fi
+
++# what library does readline need to be linked with
++READLINE_SHARED_LIBADD=""
++echo "$as_me:$LINENO: checking for tgetent in -lncurses" >&5
++echo $ECHO_N "checking for tgetent in -lncurses... $ECHO_C" >&6
++if test "${ac_cv_lib_ncurses_tgetent+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ ac_check_lib_save_LIBS=$LIBS
++LIBS="-lncurses $LIBS"
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++
++/* Override any gcc2 internal prototype to avoid an error. */
++#ifdef __cplusplus
++extern "C"
++#endif
++/* We use char because int might match the return type of a gcc2
++ builtin and then its argument prototype would still apply. */
++char tgetent ();
++int
++main ()
++{
++tgetent ();
++ ;
++ return 0;
++}
++_ACEOF
++rm -f conftest.$ac_objext conftest$ac_exeext
++if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
++ (eval $ac_link) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest$ac_exeext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++ ac_cv_lib_ncurses_tgetent=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ac_cv_lib_ncurses_tgetent=no
++fi
++rm -f conftest.err conftest.$ac_objext \
++ conftest$ac_exeext conftest.$ac_ext
++LIBS=$ac_check_lib_save_LIBS
++fi
++echo "$as_me:$LINENO: result: $ac_cv_lib_ncurses_tgetent" >&5
++echo "${ECHO_T}$ac_cv_lib_ncurses_tgetent" >&6
++if test $ac_cv_lib_ncurses_tgetent = yes; then
++ READLINE_SHARED_LIBADD="-lncurses"
++else
++ echo "$as_me:$LINENO: checking for tgetent in -lcurses" >&5
++echo $ECHO_N "checking for tgetent in -lcurses... $ECHO_C" >&6
++if test "${ac_cv_lib_curses_tgetent+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ ac_check_lib_save_LIBS=$LIBS
++LIBS="-lcurses $LIBS"
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++
++/* Override any gcc2 internal prototype to avoid an error. */
++#ifdef __cplusplus
++extern "C"
++#endif
++/* We use char because int might match the return type of a gcc2
++ builtin and then its argument prototype would still apply. */
++char tgetent ();
++int
++main ()
++{
++tgetent ();
++ ;
++ return 0;
++}
++_ACEOF
++rm -f conftest.$ac_objext conftest$ac_exeext
++if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
++ (eval $ac_link) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest$ac_exeext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++ ac_cv_lib_curses_tgetent=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ac_cv_lib_curses_tgetent=no
++fi
++rm -f conftest.err conftest.$ac_objext \
++ conftest$ac_exeext conftest.$ac_ext
++LIBS=$ac_check_lib_save_LIBS
++fi
++echo "$as_me:$LINENO: result: $ac_cv_lib_curses_tgetent" >&5
++echo "${ECHO_T}$ac_cv_lib_curses_tgetent" >&6
++if test $ac_cv_lib_curses_tgetent = yes; then
++ READLINE_SHARED_LIBADD="-lcurses"
++else
++ echo "$as_me:$LINENO: checking for tgetent in -ltermcap" >&5
++echo $ECHO_N "checking for tgetent in -ltermcap... $ECHO_C" >&6
++if test "${ac_cv_lib_termcap_tgetent+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ ac_check_lib_save_LIBS=$LIBS
++LIBS="-ltermcap $LIBS"
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++
++/* Override any gcc2 internal prototype to avoid an error. */
++#ifdef __cplusplus
++extern "C"
++#endif
++/* We use char because int might match the return type of a gcc2
++ builtin and then its argument prototype would still apply. */
++char tgetent ();
++int
++main ()
++{
++tgetent ();
++ ;
++ return 0;
++}
++_ACEOF
++rm -f conftest.$ac_objext conftest$ac_exeext
++if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
++ (eval $ac_link) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest$ac_exeext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++ ac_cv_lib_termcap_tgetent=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ac_cv_lib_termcap_tgetent=no
++fi
++rm -f conftest.err conftest.$ac_objext \
++ conftest$ac_exeext conftest.$ac_ext
++LIBS=$ac_check_lib_save_LIBS
++fi
++echo "$as_me:$LINENO: result: $ac_cv_lib_termcap_tgetent" >&5
++echo "${ECHO_T}$ac_cv_lib_termcap_tgetent" >&6
++if test $ac_cv_lib_termcap_tgetent = yes; then
++ READLINE_SHARED_LIBADD="-ltermcap"
++fi
++
++
++fi
++
++
++fi
++
++
+ # check for readline 2.1
+ echo "$as_me:$LINENO: checking for rl_callback_handler_install in -lreadline" >&5
+ echo $ECHO_N "checking for rl_callback_handler_install in -lreadline... $ECHO_C" >&6
+@@ -19275,7 +19486,7 @@ if test "${ac_cv_lib_readline_rl_callbac
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lreadline -ltermcap $LIBS"
++LIBS="-lreadline $READLINE_SHARED_LIBADD $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -19407,7 +19618,7 @@ if test "${ac_cv_lib_readline_rl_pre_inp
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lreadline -ltermcap $LIBS"
++LIBS="-lreadline $READLINE_SHARED_LIBADD $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -19481,7 +19692,7 @@ if test "${ac_cv_lib_readline_rl_complet
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lreadline -ltermcap $LIBS"
++LIBS="-lreadline $READLINE_SHARED_LIBADD $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+diff -up Python-2.4/configure.in Python-2.4.new/configure.in
+--- Python-2.4/configure.in 2004-11-07 01:24:11.000000000 +0000
++++ Python-2.4.new/configure.in 2005-04-20 17:35:27.295317599 +0100
+@@ -2822,10 +2822,18 @@ then
+ [Define this if you have flockfile(), getc_unlocked(), and funlockfile()])
+ fi
+
++# what library does readline need to be linked with
++READLINE_SHARED_LIBADD=""
++AC_CHECK_LIB(ncurses, tgetent, [READLINE_SHARED_LIBADD="-lncurses"],
++ AC_CHECK_LIB(curses, tgetent, [READLINE_SHARED_LIBADD="-lcurses"],
++ AC_CHECK_LIB(termcap, tgetent, [READLINE_SHARED_LIBADD="-ltermcap"])
++ )
++ )
++
+ # check for readline 2.1
+ AC_CHECK_LIB(readline, rl_callback_handler_install,
+ AC_DEFINE(HAVE_RL_CALLBACK, 1,
+- [Define if you have readline 2.1]), , -ltermcap)
++ [Define if you have readline 2.1]), , $READLINE_SHARED_LIBADD)
+
+ # check for readline 2.2
+ AC_TRY_CPP([#include <readline/readline.h>],
+@@ -2841,12 +2849,12 @@ fi
+ # check for readline 4.0
+ AC_CHECK_LIB(readline, rl_pre_input_hook,
+ AC_DEFINE(HAVE_RL_PRE_INPUT_HOOK, 1,
+- [Define if you have readline 4.0]), , -ltermcap)
++ [Define if you have readline 4.0]), , $READLINE_SHARED_LIBADD)
+
+ # check for readline 4.2
+ AC_CHECK_LIB(readline, rl_completion_matches,
+ AC_DEFINE(HAVE_RL_COMPLETION_MATCHES, 1,
+- [Define if you have readline 4.2]), , -ltermcap)
++ [Define if you have readline 4.2]), , $READLINE_SHARED_LIBADD)
+
+ # also in readline 4.2
+ AC_TRY_CPP([#include <readline/readline.h>],
diff --git a/dev-lang/python/python-2.3.5.ebuild b/dev-lang/python/python-2.3.5.ebuild
index a8c686ab1b30..f44987945686 100644
--- a/dev-lang/python/python-2.3.5.ebuild
+++ b/dev-lang/python/python-2.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.5.ebuild,v 1.3 2005/03/15 12:17:58 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.5.ebuild,v 1.4 2005/04/20 17:10:29 liquidx Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -23,7 +23,8 @@ SLOT="2.3"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~s390 ~sh ~sparc ~x86"
IUSE="ncurses gdbm ssl readline tcltk berkdb bootstrap ipv6 build ucs2 doc X"
-DEPEND="virtual/libc
+RDEPEND="virtual/libc
+ dev-python/python-fchksum
>=sys-libs/zlib-1.1.3
!build? (
X? ( tcltk? ( >=dev-lang/tk-8.0 ) )
@@ -35,7 +36,7 @@ DEPEND="virtual/libc
dev-libs/expat
)"
-RDEPEND="${DEPEND} dev-python/python-fchksum"
+DEPEND="${RDEPEND}"
# The dev-python/python-fchksum RDEPEND is needed to that this python provides
# the functionality expected from previous pythons.
@@ -45,6 +46,10 @@ PROVIDE="virtual/python"
src_unpack() {
unpack ${A}
cd ${S}
+
+ # fix readline detection problems due to missing termcap (#79013)
+ epatch ${FILESDIR}/${PN}-2.3-readline.patch
+
sed -ie 's/OpenBSD\/3.\[01234/OpenBSD\/3.\[012345/' configure || die "OpenBSD sed failed"
# adds /usr/lib/portage/pym to sys.path - liquidx (08 Oct 03)
# prepends /usr/lib/portage/pym to sys.path - liquidx (12 Apr 04)
@@ -55,6 +60,7 @@ src_unpack() {
epatch ${FILESDIR}/${PN}-2.3.2-disable_modules_and_ssl.patch
epatch ${FILESDIR}/${PN}-2.3-mimetypes_apache.patch
epatch ${FILESDIR}/${PN}-2.3-db4.2.patch
+
# installs to lib64
[ "$(get_libdir)" == "lib64" ] && epatch ${FILESDIR}/python-2.3.4-lib64.patch
# fix os.utime() on hppa. utimes it not supported but unfortunately reported as working - gmsoft (22 May 04)
diff --git a/dev-lang/python/python-2.4-r3.ebuild b/dev-lang/python/python-2.4-r3.ebuild
index be1a9539cc6f..f7d66778900d 100644
--- a/dev-lang/python/python-2.4-r3.ebuild
+++ b/dev-lang/python/python-2.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4-r3.ebuild,v 1.1 2005/03/19 17:51:20 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4-r3.ebuild,v 1.2 2005/04/20 17:10:29 liquidx Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -24,8 +24,9 @@ SLOT="2.4"
KEYWORDS="~x86 ~ppc ~sparc ~arm ~hppa ~amd64 ~s390 ~alpha ~ia64 ~mips"
-DEPEND="virtual/libc
+RDEPEND="virtual/libc
>=sys-libs/zlib-1.1.3
+ dev-python/python-fchksum
!build? (
X? ( tcltk? ( >=dev-lang/tk-8.0 ) )
ncurses? ( >=sys-libs/ncurses-5.2 readline? ( >=sys-libs/readline-4.1 ) )
@@ -36,7 +37,7 @@ DEPEND="virtual/libc
dev-libs/expat
)"
-RDEPEND="${DEPEND} dev-python/python-fchksum"
+DEPEND="${RDEPEND}"
# The dev-python/python-fchksum RDEPEND is needed to that this python provides
# the functionality expected from previous pythons.
@@ -46,6 +47,10 @@ PROVIDE="virtual/python"
src_unpack() {
unpack ${A}
cd ${S}
+
+ # unnecessary termcap dep in readline (#79013)
+ epatch ${FILESDIR}/${PN}-2.4-readline.patch
+
#Fixes security vulnerability in XML-RPC server - pythonhead (06 Feb 05)
#http://www.python.org/security/PSF-2005-001/
epatch ${FILESDIR}/${PN}-2.4-xmlrpc.patch