summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/leo/ChangeLog5
-rw-r--r--app-editors/leo/Manifest6
-rw-r--r--app-editors/leo/leo-4.2.ebuild24
3 files changed, 20 insertions, 15 deletions
diff --git a/app-editors/leo/ChangeLog b/app-editors/leo/ChangeLog
index 6a6c038be79e..6970c1647738 100644
--- a/app-editors/leo/ChangeLog
+++ b/app-editors/leo/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-editors/leo
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/ChangeLog,v 1.5 2005/06/05 11:31:42 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/ChangeLog,v 1.6 2005/09/16 03:06:41 mr_bones_ Exp $
+
+ 16 Sep 2005; Michael Sterrett <mr_bones_@gentoo.org> leo-4.2.ebuild:
+ needs app-arch/unzip; tidy
05 Jun 2005; Michael Hanselmann <hansmi@gentoo.org> leo-4.2.ebuild:
Stable on ppc.
diff --git a/app-editors/leo/Manifest b/app-editors/leo/Manifest
index 81d6d68b64de..03ca2b21a5f7 100644
--- a/app-editors/leo/Manifest
+++ b/app-editors/leo/Manifest
@@ -1,5 +1,5 @@
-MD5 c42580c5d8b3725562e4038a2429d9b0 leo-4.2.ebuild 1047
+MD5 f85472fdc863ffa6bd48e360fe6a135f leo-4.2.ebuild 1040
MD5 9ac4199ebe7cd3e7e311274994767f82 metadata.xml 160
-MD5 c0bcb92ab84901c1dfaf1240242ee001 ChangeLog 679
-MD5 786b8586255990e3d34ad8d5bee99fe3 files/digest-leo-4.2 63
+MD5 808e6f1222fe382a1e9a7e59b44e0c3f ChangeLog 783
MD5 dcdd115f9803c5e4040bf247775f760e files/leoConfig.py.patch 904
+MD5 786b8586255990e3d34ad8d5bee99fe3 files/digest-leo-4.2 63
diff --git a/app-editors/leo/leo-4.2.ebuild b/app-editors/leo/leo-4.2.ebuild
index 4a1dd05ba38c..450d8e4239a6 100644
--- a/app-editors/leo/leo-4.2.ebuild
+++ b/app-editors/leo/leo-4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/leo-4.2.ebuild,v 1.5 2005/06/05 11:31:42 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/leo-4.2.ebuild,v 1.6 2005/09/16 03:06:41 mr_bones_ Exp $
inherit eutils python
@@ -8,32 +8,34 @@ MY_P=${P}-final
DESCRIPTION="Leo is an outlining editor and literate programming tool."
HOMEPAGE="http://leo.sourceforge.net/"
SRC_URI="mirror://sourceforge/leo/${MY_P}.zip"
+
LICENSE="PYTHON"
SLOT="0"
KEYWORDS="ppc x86"
IUSE=""
-DEPEND="virtual/python
+
+RDEPEND="virtual/python
dev-lang/tk"
-S=${WORKDIR}/${MY_P}
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+S=${WORKDIR}/${MY_P}
src_unpack() {
- unpack ${A} || die "Failed to unpack ${A}"
- cd ${S} || die "Failed to cd ${S}"
- epatch ${FILESDIR}/leoConfig.py.patch || \
- die "epatch failed on leoConfig.py.patch"
+ unpack ${A}
+ cd "${S}" || die "Failed to cd ${S}"
+ epatch "${FILESDIR}"/leoConfig.py.patch
}
src_install() {
python_version
INST_DIR=/usr/lib/python${PYVER}/site-packages/leo
- dodir ${INST_DIR}
- dodir /usr/bin
dodoc ${S}/PKG-INFO MANIFEST doc/*
rm -rf PKG-INFO MANIFEST doc/*
- cp -r * ${D}/${INST_DIR}/
+ dodir ${INST_DIR}
+ cp -r * "${D}"/${INST_DIR}/ || die "cp failed"
echo "#!/bin/bash" > leo
echo "exec /usr/bin/python ${INST_DIR}/src/leo.py \"\$1\"" >> leo
exeinto /usr/bin
- doexe leo
+ doexe leo || die "doexe failed"
}