summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2003-07-15 03:10:27 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2003-07-15 03:10:27 +0000
commit5b87dd0ab1a0ac0365af0e3c38f80ce012def658 (patch)
treedd68265b9045f798eac8074d40ce144f75b2cd7c /xfce-base/xfdesktop
parentNew version and portage directory layout. (diff)
downloadhistorical-5b87dd0ab1a0ac0365af0e3c38f80ce012def658.tar.gz
historical-5b87dd0ab1a0ac0365af0e3c38f80ce012def658.tar.bz2
historical-5b87dd0ab1a0ac0365af0e3c38f80ce012def658.zip
New version and portage directory layout.
Diffstat (limited to 'xfce-base/xfdesktop')
-rw-r--r--xfce-base/xfdesktop/Manifest4
-rw-r--r--xfce-base/xfdesktop/files/digest-xfdesktop-3.99.11
-rw-r--r--xfce-base/xfdesktop/xfdesktop-3.99.1.ebuild38
3 files changed, 41 insertions, 2 deletions
diff --git a/xfce-base/xfdesktop/Manifest b/xfce-base/xfdesktop/Manifest
index 3c1127fdeb41..792f00c5bd95 100644
--- a/xfce-base/xfdesktop/Manifest
+++ b/xfce-base/xfdesktop/Manifest
@@ -1,3 +1,3 @@
-MD5 804dc8d5bd6870029e41f62dbaf65f5e xfdesktop-3.99.1.ebuild 949
-MD5 41598269b83ca8fe3c4e79e2358276ad ChangeLog 341
+MD5 6be16c1645022d87797d5c143d1345a7 xfdesktop-3.99.1.ebuild 1055
+MD5 087a31480af5bb3f9725d46b722696c0 ChangeLog 494
MD5 928e09351eaa8730aa1f88081c262e10 files/digest-xfdesktop-3.99.1 69
diff --git a/xfce-base/xfdesktop/files/digest-xfdesktop-3.99.1 b/xfce-base/xfdesktop/files/digest-xfdesktop-3.99.1
new file mode 100644
index 000000000000..ccc5e0192a74
--- /dev/null
+++ b/xfce-base/xfdesktop/files/digest-xfdesktop-3.99.1
@@ -0,0 +1 @@
+MD5 f7bad244ace48eaa519e9a444a5c922a xfdesktop-3.99.1.tar.gz 1839648
diff --git a/xfce-base/xfdesktop/xfdesktop-3.99.1.ebuild b/xfce-base/xfdesktop/xfdesktop-3.99.1.ebuild
new file mode 100644
index 000000000000..6e2119bf1a1f
--- /dev/null
+++ b/xfce-base/xfdesktop/xfdesktop-3.99.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/xfdesktop-3.99.1.ebuild,v 1.1 2003/07/15 03:10:09 bcowan Exp $
+
+IUSE="X"
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Xfce4 desktop"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="http://www.xfce.org/archive/xfce4-rc1/src/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+
+DEPEND=">=x11-libs/gtk+-2.0.6
+ dev-util/pkgconfig
+ dev-libs/libxml2
+ =xfce-base/libxfce4util-${PV}
+ =xfce-base/libxfcegui4-${PV}
+ =xfce-base/libxfce4mcs-${PV}
+ =xfce-base/xfce-mcs-manager-${PV}"
+
+src_compile() {
+ local myconf
+ myconf=""
+
+ use X && myconf="${myconf} --with-x"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS INSTALL NEWS COPYING README ChangeLog TODO
+}