summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-05-26 00:38:16 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-05-26 00:38:16 +0000
commit9dec06c6c95b6d7445f8cb3a4e53b73730b269d1 (patch)
tree6c4d4c21622c13da285a41c1e6dec0e300e79f6c /x11-wm
parentadd missing library (diff)
downloadhistorical-9dec06c6c95b6d7445f8cb3a4e53b73730b269d1.tar.gz
historical-9dec06c6c95b6d7445f8cb3a4e53b73730b269d1.tar.bz2
historical-9dec06c6c95b6d7445f8cb3a4e53b73730b269d1.zip
version bump
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/openbox/ChangeLog9
-rw-r--r--x11-wm/openbox/files/digest-openbox-0.99.31
-rw-r--r--x11-wm/openbox/openbox-0.99.3.ebuild61
3 files changed, 70 insertions, 1 deletions
diff --git a/x11-wm/openbox/ChangeLog b/x11-wm/openbox/ChangeLog
index a44093f8bc34..e3a0f3c9f0fe 100644
--- a/x11-wm/openbox/ChangeLog
+++ b/x11-wm/openbox/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-wm/openbox
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/ChangeLog,v 1.1 2002/04/29 11:16:22 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/ChangeLog,v 1.2 2002/05/26 00:38:16 seemant Exp $
+
+*openbox-0.99.3 (25 May 2002)
+
+ 25 May 2002; Seemant Kulleen <seemant@gentoo.org> openbox-0.99.3.ebuild
+ files/digest-openbox-0.99.3 :
+
+ Version bump.
*openbox-0.99.1 (29 Apr 2002)
diff --git a/x11-wm/openbox/files/digest-openbox-0.99.3 b/x11-wm/openbox/files/digest-openbox-0.99.3
new file mode 100644
index 000000000000..45637229bf46
--- /dev/null
+++ b/x11-wm/openbox/files/digest-openbox-0.99.3
@@ -0,0 +1 @@
+MD5 68aa9c3d7bfb86b46eb628b7c3e62a97 openbox-0.99.3.tar.gz 302644
diff --git a/x11-wm/openbox/openbox-0.99.3.ebuild b/x11-wm/openbox/openbox-0.99.3.ebuild
new file mode 100644
index 000000000000..0543d7d897d5
--- /dev/null
+++ b/x11-wm/openbox/openbox-0.99.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Seemant Kulleen <seemant@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-0.99.3.ebuild,v 1.1 2002/05/26 00:38:16 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Window manager based on BlackBox"
+SRC_URI="ftp://sunsite.dk/projects/openbox/${P}.tar.gz"
+HOMEPAGE="http://openbox.sunsite.dk"
+
+DEPEND="virtual/x11"
+
+RDEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )"
+
+PROVIDE="virtual/blackbox"
+
+SLOT="0"
+LICENSE="Artistic"
+
+src_compile() {
+ local myconf
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ use kde \
+ && myconf="${myconf} --enable-kde" \
+ && export KDEDIR=/usr/kde/2 \
+ || myconf="${myconf} --disable-kde"
+
+ use gnome \
+ && myconf="${myconf} --enable-gnome" \
+ || myconf="${myconf} --disable-gnome"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ $myconf || die
+
+ emake || die
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ sysconfdir=${D}/etc/X11/openbox \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dodoc ChangeLog AUTHORS INSTALL README* TODO LICENSE BUGS
+ docinto data
+ dodoc data/README*
+
+ dodir /etc/X11/Sessions
+ echo "/usr/bin/openbox" > ${D}/etc/X11/Sessions/openbox
+ chmod +x ${D}/etc/X11/Sessions/openbox
+}