summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-06-20 00:47:29 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-06-20 00:47:29 +0000
commit80c376d38dad40a54de0ff57e665e318ed09cdf2 (patch)
treee0a6fd6ca53d67c1591fba7e5fe680bd883d2e34 /x11-wm
parentnew stable version (diff)
downloadhistorical-80c376d38dad40a54de0ff57e665e318ed09cdf2.tar.gz
historical-80c376d38dad40a54de0ff57e665e318ed09cdf2.tar.bz2
historical-80c376d38dad40a54de0ff57e665e318ed09cdf2.zip
fix lisp not building
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/sawfish/ChangeLog7
-rw-r--r--x11-wm/sawfish/files/digest-sawfish-20020611-r11
-rw-r--r--x11-wm/sawfish/sawfish-20020611-r1.ebuild62
3 files changed, 69 insertions, 1 deletions
diff --git a/x11-wm/sawfish/ChangeLog b/x11-wm/sawfish/ChangeLog
index 90c7eb3556f0..d5f66d7efdad 100644
--- a/x11-wm/sawfish/ChangeLog
+++ b/x11-wm/sawfish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/sawfish
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.9 2002/06/12 02:17:37 stroke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.10 2002/06/20 00:47:29 azarah Exp $
+
+*sawfish-20020612-r1 (19 Jun 2002)
+ 19 Jun 2002; Martin Schlemmer <azarah@gentoo.org>
+ Do not create the .libs directory, even if the build complain it do not
+ exist, as it causes the lisp stuff to fail building.
*sawfish-20020524 (12 Jun 2002)
12 Jun 2002; Gabriele Giorgetti <stroke@gentoo.org> sawfish-20020612.ebuild :
diff --git a/x11-wm/sawfish/files/digest-sawfish-20020611-r1 b/x11-wm/sawfish/files/digest-sawfish-20020611-r1
new file mode 100644
index 000000000000..fb633f76581e
--- /dev/null
+++ b/x11-wm/sawfish/files/digest-sawfish-20020611-r1
@@ -0,0 +1 @@
+MD5 6217c3810620dab57e84203b19783aa0 sawfish-2002-06-11.tar.bz2 1115431
diff --git a/x11-wm/sawfish/sawfish-20020611-r1.ebuild b/x11-wm/sawfish/sawfish-20020611-r1.ebuild
new file mode 100644
index 000000000000..e278ce522217
--- /dev/null
+++ b/x11-wm/sawfish/sawfish-20020611-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-20020611-r1.ebuild,v 1.1 2002/06/20 00:47:29 azarah Exp $
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+MY_P=${PN}-2002-06-11
+
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Extensible window manager using a Lisp-based scripting language"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/pre-gnome2/sources/${PN}/${MY_P}.tar.bz2"
+HOMEPAGE="http://sawmill.sourceforge.net/"
+
+DEPEND=">=dev-util/pkgconfig-0.12.0
+ >=x11-libs/rep-gtk-20020611
+ >=dev-libs/librep-20020611
+ >=media-libs/imlib-1.9.10-r1
+ media-libs/audiofile
+ esd? ( >=media-sound/esound-0.2.22 )
+ readline? ( >=sys-libs/readline-4.1 )
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf=""
+ myconf="${myconf} --with-gnome-prefix=/usr"
+ myconf="${myconf} --enable-gnome-widgets "
+ myconf="${myconf} --enable-capplet"
+ myconf="${myconf} --enable-themer"
+ myconf="${myconf} --with-audiofile"
+ myconf="${myconf} --with-x"
+ myconf="${myconf} --with-gdk-pixbuf"
+
+ use esd && myconf="${myconf} --with-esd" ||myconf="${myconf} --without-esd"
+ use readline && myconf="${myconf} --with-readline" || myconf="${myconf} --without-readline"
+ use nls || myconf="${myconf} --disable-linguas"
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --libexecdir=/usr/lib \
+ --with-audiofile ${myconf} || die
+# This breaks this version for some reason.
+# mkdir ${S}/src/.libs
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS COPYING ChangeLog DOC FAQ NEWS README THANKS TODO
+
+ # Add to Gnome CC's Window Manager list
+ insinto /usr/share/gnome/wm-properties
+ doins ${FILESDIR}/Sawfish.desktop
+
+}
+
+
+