summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-09-04 12:18:43 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-09-04 12:18:43 +0000
commit5b01bdbf4c80cc023dfb8ced35a9a16e5226c653 (patch)
treedac49890b7c592a5e395dd84d1be03016b800e5f /x11-wm
parentnew commonbox class to correct openbox errors, version bump on fluxbox, and v... (diff)
downloadhistorical-5b01bdbf4c80cc023dfb8ced35a9a16e5226c653.tar.gz
historical-5b01bdbf4c80cc023dfb8ced35a9a16e5226c653.tar.bz2
historical-5b01bdbf4c80cc023dfb8ced35a9a16e5226c653.zip
new commonbox class to correct openbox errors, version bump on fluxbox, and version bumpo on commonbox-styles
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/fluxbox/ChangeLog10
-rw-r--r--x11-wm/fluxbox/files/digest-fluxbox-0.1.111
-rw-r--r--x11-wm/fluxbox/files/digest-fluxbox-0.1.9-r53
-rw-r--r--x11-wm/fluxbox/fluxbox-0.1.11.ebuild47
-rw-r--r--x11-wm/fluxbox/fluxbox-0.1.9-r5.ebuild85
-rw-r--r--x11-wm/openbox/ChangeLog11
-rw-r--r--x11-wm/openbox/files/digest-openbox-1.2.5_beta20020714-r11
-rw-r--r--x11-wm/openbox/files/digest-openbox-2.0.0-r1 (renamed from x11-wm/openbox/files/digest-openbox-2.0.0)0
-rw-r--r--x11-wm/openbox/openbox-2.0.0-r1.ebuild (renamed from x11-wm/openbox/openbox-1.2.5_beta20020714-r1.ebuild)17
-rw-r--r--x11-wm/openbox/openbox-2.0.0.ebuild52
10 files changed, 79 insertions, 148 deletions
diff --git a/x11-wm/fluxbox/ChangeLog b/x11-wm/fluxbox/ChangeLog
index 0e77359f2452..ac0067f0ec2f 100644
--- a/x11-wm/fluxbox/ChangeLog
+++ b/x11-wm/fluxbox/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-wm/fluxbox
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/ChangeLog,v 1.23 2002/08/28 04:49:18 naz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/ChangeLog,v 1.24 2002/09/04 12:18:42 seemant Exp $
+
+*fluxbox-0.1.11 (04 Sep 2002)
+
+ 04 Sep 2002; Seemant Kulleen <seemant@gentoo.org> fluxbox-0.1.11.ebuild
+ files/digest-fluxbox-0.1.11 :
+
+ Version bump. Thanks to: cycloon@linux-de.org (christian gut) in bug
+ #7422.
*fluxbox-0.1.10 (14 Jul 2002)
diff --git a/x11-wm/fluxbox/files/digest-fluxbox-0.1.11 b/x11-wm/fluxbox/files/digest-fluxbox-0.1.11
new file mode 100644
index 000000000000..9116d391f209
--- /dev/null
+++ b/x11-wm/fluxbox/files/digest-fluxbox-0.1.11
@@ -0,0 +1 @@
+MD5 41f10c899ff47f2f5eb9e34a9302fd89 fluxbox-0.1.11.tar.gz 416820
diff --git a/x11-wm/fluxbox/files/digest-fluxbox-0.1.9-r5 b/x11-wm/fluxbox/files/digest-fluxbox-0.1.9-r5
deleted file mode 100644
index 077e6e656071..000000000000
--- a/x11-wm/fluxbox/files/digest-fluxbox-0.1.9-r5
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 adfecad6a050572e4cb1fcc079dc491d fluxbox-0.1.9.tar.gz 440638
-MD5 51bb4dca071958d7ffcc5d90c3a26eca fluxbox-0.1.9-bugfix2.patch 1377
-MD5 3c1043fbcc87a8241dcca0c36f037423 fluxbox-0.1.9-oly-allinone.patch.bz2 110919
diff --git a/x11-wm/fluxbox/fluxbox-0.1.11.ebuild b/x11-wm/fluxbox/fluxbox-0.1.11.ebuild
new file mode 100644
index 000000000000..e5bd106ceb33
--- /dev/null
+++ b/x11-wm/fluxbox/fluxbox-0.1.11.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-0.1.11.ebuild,v 1.1 2002/09/04 12:18:42 seemant Exp $
+
+inherit commonbox flag-o-matic
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Window manager based on Blackbox and pwm -- has tabs."
+SRC_URI="http://download.sourceforge.net/${PN}/${P}.tar.gz"
+HOMEPAGE="http://fluxbox.sf.net"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc sparc64"
+
+mydoc="ChangeLog COPYING NEWS"
+myconf="--enable-xinerama"
+filter-flags -fno-exceptions
+export WANT_AUTOMAKE_1_6=1
+export WANT_AUTOCONF_2_5=1
+
+src_unpack() {
+
+ commonbox_src_unpack
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${PN}-vano-gentoo.patch
+}
+
+src_compile() {
+
+ commonbox_src_compile
+
+ cd data
+ make init
+}
+
+
+src_install() {
+
+ commonbox_src_install
+ cd data
+ insinto /usr/share/commonbox
+ doins init
+ insinto /usr/share/commonbox/fluxbox
+ doins keys
+}
diff --git a/x11-wm/fluxbox/fluxbox-0.1.9-r5.ebuild b/x11-wm/fluxbox/fluxbox-0.1.9-r5.ebuild
deleted file mode 100644
index c4070cd84136..000000000000
--- a/x11-wm/fluxbox/fluxbox-0.1.9-r5.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-0.1.9-r5.ebuild,v 1.3 2002/08/14 15:45:39 murphy Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Window manager based on BlackBox"
-SRC_URI="http://download.sourceforge.net/${PN}/${P}.tar.gz
- http://fluxbox.sourceforge.net/download/patches/${P}-bugfix2.patch
- truetype? ( http://www.oberdorf.org/oly/Computers/OlyWare/FluxBoxAA/${P}-oly-allinone.patch.bz2 )"
-
-HOMEPAGE="http://fluxbox.sf.net"
-
-DEPEND="virtual/x11"
-
-RDEPEND="${DEPEND}
- nls? ( sys-devel/gettext )"
-
-PROVIDE="virtual/blackbox"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ppc sparc sparc64"
-
-src_unpack() {
- unpack ${P}.tar.gz
- cd ${S}
- patch -p1 < ${DISTDIR}/${P}-bugfix2.patch || die
-
- use truetype && \
- bzcat ${DISTDIR}/${P}-oly-allinone.patch.bz2 | patch -p1 || die
-
- cd src
- patch < ${FILESDIR}/${P}-gentoo.diff || die
-}
-
-src_compile() {
- local myconf
- use nls \
- && myconf="${myconf} --enable-nls" \
- || myconf="${myconf} --disable-nls"
-
- use kde \
- && myconf="${myconf} --enable-kde" \
- && export KDEDIR=/usr/kde/2 \
- || myconf="${myconf} --disable-kde"
-
- use gnome \
- && myconf="${myconf} --enable-gnome" \
- || myconf="${myconf} --disable-gnome"
-
- use truetype \
- && myconf="${myconf} --enable-antialiasing" \
- || myconf="${myconf} --disable-antialiasing"
-
- econf ${myconf} --enable-xinerama || die
-
- emake || die
-}
-
-src_install () {
- make \
- prefix=${D}/usr \
- sysconfdir=${D}/etc/X11/fluxbox \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- datadir=${D}/usr/share \
- install || die
-
- dodoc ChangeLog AUTHORS COPYING INSTALL README TODO NEWS
- docinto data
- dodoc data/README*
-
- dodir /etc/X11/Sessions
- echo "/usr/bin/fluxbox" > ${D}/etc/X11/Sessions/fluxbox
- fperm +x /etc/X11/Sessions/fluxbox
-}
-
-
-pkg_postinst() {
-
- if [ "`use truetype`" ]
- then
- einfo "To actually enable anti-aliasing in fluxbox, you must call"
- einfo "it using: fluxbox -antialias"
- fi
-}
diff --git a/x11-wm/openbox/ChangeLog b/x11-wm/openbox/ChangeLog
index 16622385765f..c04ed6043865 100644
--- a/x11-wm/openbox/ChangeLog
+++ b/x11-wm/openbox/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-wm/openbox
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/ChangeLog,v 1.7 2002/08/17 05:29:09 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/ChangeLog,v 1.8 2002/09/04 12:18:42 seemant Exp $
+
+*openbox-2.0.0 (04 Sep 2002)
+
+ 04 Sep 2002; Seemant Kulleen <seemant@gentoo.org> openbox-2.0.0-r1.ebuild
+ files/digest-openbox-2.0.0-r1 :
+
+ epist and xftlsfonts were not being installed. This corrects that.
+ Thanks to xOr and gentoo users reporting to him about him (hint:
+ bugs.gentoo.org people!).
*openbox-2.0.0 (16 Aug 2002)
diff --git a/x11-wm/openbox/files/digest-openbox-1.2.5_beta20020714-r1 b/x11-wm/openbox/files/digest-openbox-1.2.5_beta20020714-r1
deleted file mode 100644
index ada795a5a6b0..000000000000
--- a/x11-wm/openbox/files/digest-openbox-1.2.5_beta20020714-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 dbb75618367de9d6808546932491d064 openbox-1.2.5_beta20020714.tar.gz 253492
diff --git a/x11-wm/openbox/files/digest-openbox-2.0.0 b/x11-wm/openbox/files/digest-openbox-2.0.0-r1
index 58aeeaa5b884..58aeeaa5b884 100644
--- a/x11-wm/openbox/files/digest-openbox-2.0.0
+++ b/x11-wm/openbox/files/digest-openbox-2.0.0-r1
diff --git a/x11-wm/openbox/openbox-1.2.5_beta20020714-r1.ebuild b/x11-wm/openbox/openbox-2.0.0-r1.ebuild
index 829da1ce9d1b..463f79c0d464 100644
--- a/x11-wm/openbox/openbox-1.2.5_beta20020714-r1.ebuild
+++ b/x11-wm/openbox/openbox-2.0.0-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-1.2.5_beta20020714-r1.ebuild,v 1.2 2002/08/14 15:45:39 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-2.0.0-r1.ebuild,v 1.1 2002/09/04 12:18:43 seemant Exp $
inherit commonbox
-S=${WORKDIR}/${PN}-14072002
+S=${WORKDIR}/${P}
DESCRIPTION="Window manager based on BlackBox"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
+SRC_URI="ftp://sunsite.dk/projects/openbox/${P}.tar.gz"
HOMEPAGE="http://openbox.sunsite.dk"
SLOT="2"
@@ -14,11 +14,18 @@ LICENSE="BSD"
KEYWORDS="x86 sparc sparc64"
MYBIN="${PN}-dev"
-mydoc="CHANGE* TODO LICENSE BUGS CodingStyle data/README*"
-myconf="--program-suffix=-dev --enable-xft"
+mydoc="CHANGE* TODO LICENSE data/README*"
+myconf="--enable-xinerama"
src_compile() {
./bootstrap
+
+ BOOTSTRAP="1"
commonbox_src_compile
}
+
+src_install() {
+
+ commonbox_src_install
+}
diff --git a/x11-wm/openbox/openbox-2.0.0.ebuild b/x11-wm/openbox/openbox-2.0.0.ebuild
deleted file mode 100644
index 2ab9839a39ac..000000000000
--- a/x11-wm/openbox/openbox-2.0.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-2.0.0.ebuild,v 1.2 2002/09/03 10:48:03 seemant Exp $
-
-inherit commonbox
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Window manager based on BlackBox"
-SRC_URI="ftp://sunsite.dk/projects/openbox/${P}.tar.gz"
-HOMEPAGE="http://openbox.sunsite.dk"
-
-SLOT="2"
-LICENSE="BSD"
-KEYWORDS="x86 sparc sparc64"
-
-MYBIN="${PN}"
-mydoc="CHANGE* TODO LICENSE data/README*"
-myconf="--enable-xinerama"
-
-src_unpack() {
-
- unpack ${A}
- cd ${S}
-
- cp Makefile.am Makefile.am.orig
- sed 's/data //' Makefile.am.orig > Makefile.am
-
- cd ${S}/util
- cp Makefile.am Makefile.am.orig
- sed -e 's/bsetbg//' \
- -e 's/bsetroot//' \
- Makefile.am.orig > Makefile.am
-}
-
-
-
-src_compile() {
-
- ${S}/bootstrap
-
- commonise=""
- commonbox_src_compile
-}
-
-src_install() {
-
- commonbox_src_install
- mv ${D}/usr/bin/openbox ${D}/usr/bin/openbox-dev
- mv ${D}/usr/share/man/man1/openbox.1.gz \
- {D}/usr/share/man/man1/openbox-dev.1.gz
-
-}