summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-07-22 10:51:21 +0000
committerJeroen Roovers <jer@gentoo.org>2013-07-22 10:51:21 +0000
commitb4a2fe9df705e3ef21dc8bc157b860ea43134817 (patch)
tree9df142f1e73c7dfca75027a163649afbfcf32f2a /x11-wm/lwm/lwm-1.2.3.ebuild
parentDrop the old version using long-deprecated python-distutils-ng.eclass. (diff)
downloadhistorical-b4a2fe9df705e3ef21dc8bc157b860ea43134817.tar.gz
historical-b4a2fe9df705e3ef21dc8bc157b860ea43134817.tar.bz2
historical-b4a2fe9df705e3ef21dc8bc157b860ea43134817.zip
Version bump.
Package-Manager: portage-2.2.0_alpha188/cvs/Linux x86_64 Manifest-Sign-Key: 0xA792A613
Diffstat (limited to 'x11-wm/lwm/lwm-1.2.3.ebuild')
-rw-r--r--x11-wm/lwm/lwm-1.2.3.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-wm/lwm/lwm-1.2.3.ebuild b/x11-wm/lwm/lwm-1.2.3.ebuild
new file mode 100644
index 000000000000..23dfede3b78a
--- /dev/null
+++ b/x11-wm/lwm/lwm-1.2.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/lwm/lwm-1.2.3.ebuild,v 1.1 2013/07/22 10:51:20 jer Exp $
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="The ultimate lightweight window manager"
+SRC_URI="http://www.jfc.org.uk/files/lwm/${P}.tar.gz"
+HOMEPAGE="http://www.jfc.org.uk/software/lwm.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+"
+DEPEND="
+ ${RDEPEND}
+ x11-misc/imake
+ x11-proto/xextproto
+ x11-proto/xproto
+"
+
+src_prepare() {
+ sed -i -e "s/(SMLIB)/& -lICE/g" Imakefile || die #370127
+ xmkmf || die
+}
+
+src_compile() {
+ emake \
+ EXTRA_LDOPTIONS="${CFLAGS} ${LDFLAGS}" \
+ CFLAGS="${CFLAGS}" \
+ CC="$(tc-getCC)" \
+ lwm || die
+}
+
+src_install() {
+ dobin lwm
+
+ newman lwm.man lwm.1
+ dodoc AUTHORS BUGS ChangeLog
+}