summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-07-17 11:12:35 +0000
committerMamoru Komachi <usata@gentoo.org>2004-07-17 11:12:35 +0000
commitd0bca01900d2b262d07fa41cfcb3759aae557ff3 (patch)
treeea8978765f9169b75e7b32901e2a5d7ee67e738a /x11-wm/larswm/larswm-7.5.3.ebuild
parentRemoved old ebuilds and marked 0.56 stable on x86. (diff)
downloadhistorical-d0bca01900d2b262d07fa41cfcb3759aae557ff3.tar.gz
historical-d0bca01900d2b262d07fa41cfcb3759aae557ff3.tar.bz2
historical-d0bca01900d2b262d07fa41cfcb3759aae557ff3.zip
Version bumped, closing bug #57216
Diffstat (limited to 'x11-wm/larswm/larswm-7.5.3.ebuild')
-rw-r--r--x11-wm/larswm/larswm-7.5.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-wm/larswm/larswm-7.5.3.ebuild b/x11-wm/larswm/larswm-7.5.3.ebuild
new file mode 100644
index 000000000000..8a0cbf2e4a59
--- /dev/null
+++ b/x11-wm/larswm/larswm-7.5.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/larswm/larswm-7.5.3.ebuild,v 1.1 2004/07/17 11:12:35 usata Exp $
+
+DESCRIPTION="Tiling window manager for X11, based on 9wm by David Hogan."
+HOMEPAGE="http://larswm.fnurt.net/"
+SRC_URI="http://larswm.fnurt.net/${P}.tar.gz"
+LICENSE="9wm"
+
+SLOT="0"
+KEYWORDS="~x86 ~alpha"
+IUSE=""
+DEPEND="virtual/x11"
+
+src_compile() {
+ xmkmf -a || die
+ emake || die
+}
+
+src_install() {
+ dobin larsclock larsmenu larsremote larswm
+ newbin sample.xsession larswm-session
+ for x in *.man ; do
+ newman $x ${x/man/1}
+ done
+ dodoc ChangeLog README* sample.*
+
+ insinto /etc/X11
+ newins sample.larswmrc larswmrc || die
+ exeinto /etc/X11/Sessions
+ newexe sample.xsession larswm
+ insinto /usr/share/xsessions
+ doins ${FILESDIR}/larswm.desktop || die
+}