summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2004-12-19 17:26:29 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2004-12-19 17:26:29 +0000
commit29fb30bdab5815b5f58c4c0716174dd40c23329b (patch)
treed24e2d8f45ee6cbd157c1fb79d1fc8a8be51cce9 /x11-wm/fluxbox/fluxbox-0.9.11.ebuild
parent~alpha keyword, bug 74784. (diff)
downloadhistorical-29fb30bdab5815b5f58c4c0716174dd40c23329b.tar.gz
historical-29fb30bdab5815b5f58c4c0716174dd40c23329b.tar.bz2
historical-29fb30bdab5815b5f58c4c0716174dd40c23329b.zip
change the version suffix code a bit
Diffstat (limited to 'x11-wm/fluxbox/fluxbox-0.9.11.ebuild')
-rw-r--r--x11-wm/fluxbox/fluxbox-0.9.11.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/x11-wm/fluxbox/fluxbox-0.9.11.ebuild b/x11-wm/fluxbox/fluxbox-0.9.11.ebuild
index 9922b0dc1bc8..a6c7810fe0d2 100644
--- a/x11-wm/fluxbox/fluxbox-0.9.11.ebuild
+++ b/x11-wm/fluxbox/fluxbox-0.9.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-0.9.11.ebuild,v 1.4 2004/12/08 21:22:17 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-0.9.11.ebuild,v 1.5 2004/12/19 17:26:29 ciaranm Exp $
inherit eutils
@@ -43,8 +43,13 @@ src_unpack() {
epatch ${FILESDIR}/0.9.10/${PN}-0.9.10-fancy-gentoo-styledirs.patch
# Add in the Gentoo -r number to fluxbox -version output.
+ if [[ "${PR}" == "r0" ]] ; then
+ suffix="gentoo"
+ else
+ suffix="gentoo-${PR}"
+ fi
sed -i \
- -e "s~\(__fluxbox_version .@VERSION@\)~\1-gentoo${PR:+-${PR}}~" \
+ -e "s~\(__fluxbox_version .@VERSION@\)~\1-${suffix}~" \
version.h.in || die "version sed failed"
# Use a less fugly default theme