summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Dack <tad@gentoo.org>2003-06-19 02:43:52 +0000
committerTroy Dack <tad@gentoo.org>2003-06-19 02:43:52 +0000
commit81d9ba79382dbf8828a2d3f2b8af1ed34b1cab18 (patch)
tree878b6358c67f18743ffa4547541a7f8f3da8f8e6 /x11-themes
parentFixes path errors due to renaming ebuild (diff)
downloadhistorical-81d9ba79382dbf8828a2d3f2b8af1ed34b1cab18.tar.gz
historical-81d9ba79382dbf8828a2d3f2b8af1ed34b1cab18.tar.bz2
historical-81d9ba79382dbf8828a2d3f2b8af1ed34b1cab18.zip
Fixes path errors due to renaming ebuild
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/golden-xcursors/Manifest4
-rw-r--r--x11-themes/golden-xcursors/files/digest-golden-xcursors-0.7-r11
-rw-r--r--x11-themes/golden-xcursors/golden-xcursors-0.7-r1.ebuild42
3 files changed, 45 insertions, 2 deletions
diff --git a/x11-themes/golden-xcursors/Manifest b/x11-themes/golden-xcursors/Manifest
index 012d3378c0dd..7f80c232489b 100644
--- a/x11-themes/golden-xcursors/Manifest
+++ b/x11-themes/golden-xcursors/Manifest
@@ -1,5 +1,5 @@
-MD5 7a37eaa2dfe76ac314b3a8adc86c0f7b golden-xcursors-0.7-r1.ebuild 1529
+MD5 2199de52e290c37f8234ab03ff15b6e8 golden-xcursors-0.7-r1.ebuild 1532
MD5 863df2351d09a5de6c360ed7936ee3d3 golden-xcursors-0.7.ebuild 1485
-MD5 c664fa4dd2f2d608971f60676d952f98 ChangeLog 449
+MD5 7f2fa4b45ee91f9aa93569cba2adfd2b ChangeLog 607
MD5 f06d3720f520f9e9c913ca56e134d440 files/digest-golden-xcursors-0.7-r1 80
MD5 f06d3720f520f9e9c913ca56e134d440 files/digest-golden-xcursors-0.7 80
diff --git a/x11-themes/golden-xcursors/files/digest-golden-xcursors-0.7-r1 b/x11-themes/golden-xcursors/files/digest-golden-xcursors-0.7-r1
new file mode 100644
index 000000000000..20fa613b647b
--- /dev/null
+++ b/x11-themes/golden-xcursors/files/digest-golden-xcursors-0.7-r1
@@ -0,0 +1 @@
+MD5 060260169c82c71cf7d237fc257e095f 5507-Golden-XCursors-3D-0.7.tar.bz2 661105
diff --git a/x11-themes/golden-xcursors/golden-xcursors-0.7-r1.ebuild b/x11-themes/golden-xcursors/golden-xcursors-0.7-r1.ebuild
new file mode 100644
index 000000000000..881b864bf416
--- /dev/null
+++ b/x11-themes/golden-xcursors/golden-xcursors-0.7-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/golden-xcursors/golden-xcursors-0.7-r1.ebuild,v 1.1 2003/06/19 02:43:43 tad Exp $
+
+MY_P="5507-Golden-XCursors-3D-${PV}"
+DESCRIPTION="A high quality set of Xfree 4.3.0 animated mouse cursors"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=5507"
+SRC_URI="http://www.kde-look.org/content/files/$MY_P.tar.bz2"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+DEPEND=""
+RDEPEND=">=x11-base/xfree-4.3.0-r2"
+
+src_install() {
+ mkdir -p ${D}/usr/share/cursors/xfree/gold/cursors/
+ cp -d ${WORKDIR}/${MY_P:5}/gold/cursors/* ${D}/usr/share/cursors/xfree/gold/cursors/ || die
+ dodoc ${WORKDIR}/${MY_P:5}/{COPYING,README}
+}
+
+pkg_postinst() {
+ einfo "To use this set of cursors, edit or create the file ~/.Xdefaults"
+ einfo "and add the following line:"
+ einfo "Xcursor.theme: gold"
+ einfo ""
+ einfo "Also, you can change the size by adding a line like:"
+ einfo "Xcursor.size: 48"
+ einfo ""
+ einfo ""
+ einfo "To globally use this set of mouse cursors edit the file:"
+ einfo " /usr/share/cursors/xfree/default/index.theme
+ einfo "and change the line:"
+ einfo " Inherits=[current setting]
+ einfo "to"
+ einfo " Inherits=gold"
+ einfo "Note this will be overruled by a user's ~/.Xdefaults file"
+ einfo ""
+ ewarn "If you experience flickering, try setting the following line in"
+ ewarn "the Device section of your XF86Config:"
+ ewarn "Option \"HWCursor\" \"false\""
+}