summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-08-31 22:40:32 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-08-31 22:40:32 +0000
commit2b3fd829aff617cb17c219e8b2f0d3692a212a0a (patch)
treef556944ef2449fef791a5c9ad1718a431791f8c0 /x11-themes
parentadded 1.4 profiles (diff)
downloadhistorical-2b3fd829aff617cb17c219e8b2f0d3692a212a0a.tar.gz
historical-2b3fd829aff617cb17c219e8b2f0d3692a212a0a.tar.bz2
historical-2b3fd829aff617cb17c219e8b2f0d3692a212a0a.zip
inital version... ebuild by wigren@home.se (Per Wigren) and blocke@shivan.org (Bruce A. Locke)
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/redhat-artwork/ChangeLog12
-rw-r--r--x11-themes/redhat-artwork/files/digest-redhat-artwork-0.391
-rw-r--r--x11-themes/redhat-artwork/redhat-artwork-0.39.ebuild115
3 files changed, 128 insertions, 0 deletions
diff --git a/x11-themes/redhat-artwork/ChangeLog b/x11-themes/redhat-artwork/ChangeLog
new file mode 100644
index 000000000000..74c5a3141949
--- /dev/null
+++ b/x11-themes/redhat-artwork/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for x11-themes/redhat-artwork
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/ChangeLog,v 1.1 2002/08/31 22:40:32 blocke Exp $
+
+*redhat-artwork-0.39 (31 Aug 2002)
+
+ 31 Aug 2002; Bruce A. Locke <blocke@shivan.org> redhat-artwork-0.39.ebuild:
+
+ Original ebuild contributed by wigren@home.se (Per Wigren) with
+ heavy modifications (making kde optional) by me.
+
+
diff --git a/x11-themes/redhat-artwork/files/digest-redhat-artwork-0.39 b/x11-themes/redhat-artwork/files/digest-redhat-artwork-0.39
new file mode 100644
index 000000000000..68704e42c1df
--- /dev/null
+++ b/x11-themes/redhat-artwork/files/digest-redhat-artwork-0.39
@@ -0,0 +1 @@
+MD5 13111462cee77d7bc68cd5793e444371 redhat-artwork-0.39-1.src.rpm 5269178
diff --git a/x11-themes/redhat-artwork/redhat-artwork-0.39.ebuild b/x11-themes/redhat-artwork/redhat-artwork-0.39.ebuild
new file mode 100644
index 000000000000..0d02ce3e6719
--- /dev/null
+++ b/x11-themes/redhat-artwork/redhat-artwork-0.39.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/redhat-artwork-0.39.ebuild,v 1.1 2002/08/31 22:40:32 blocke Exp $
+
+DESCRIPTION="RedHat's Bluecurve theme for GTK1, GTK2, KDE3, GDM, Metacity and Nautilus"
+HOMEPAGE="http://www.redhat.com"
+SRC_URI="ftp://ftp.sunet.se/pub/Linux/distributions/redhat/redhat/linux/rawhide/SRPMS/SRPMS/${P}-1.src.rpm"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+# Needed to build...
+DEPEND="sys-devel/autoconf
+ sys-devel/automake
+ app-arch/rpm2targz
+ >=media-libs/gdk-pixbuf-0.2.5
+ =x11-libs/gtk+-1.2*
+ >=x11-libs/gtk+-2.0"
+ kde? ( >=x11-libs/qt-3.0.5
+ >=kde-base/kdebase-3.0.2 )"
+
+# Because one may only want to use the theme with kde OR gtk OR Metacity
+# OR gdm, we don't want any run-time dependencies...
+RDEPEND=""
+
+S="${WORKDIR}/${P}"
+
+# We need to change som RedHat-specific stuff to Gentoo-style...
+_replace() {
+ FROM=$1
+ TO=$2
+
+ for FILE in $(fgrep -r -l "${FROM}" *); do
+ echo -n Changing \"${FROM}\" to \"${TO}\" in ${FILE}...
+ sed "s:${FROM}:${TO}:g" < "${FILE}" > "${FILE}.$$"
+ mv "${FILE}.$$" "${FILE}"
+ echo Done.
+ done
+}
+
+src_unpack() {
+ cd ${WORKDIR}
+ rpm2targz ${DISTDIR}/${A}
+ tar xvzf ${P}*.src.tar.gz
+ tar xvzf ${P}.tar.gz
+}
+
+src_compile() {
+
+ # disable qt and kde support if kde use keyword is not set
+ # note: qt and kde support seem to be tied together... maybe someone with
+ # autoconf experience can seperate the two
+ use kde || (
+
+ rm configure
+ mv configure.in configure.in.old
+ sed -e "s|dnl KDE_USE_QT||" \
+ -e "s|KDE_||g" \
+ -e "s|AC_PATH_KDE||" \
+ -e "s|art/kde/Makefile||" \
+ -e "s|art/kde/kwin/Makefile||" \
+ -e "s|art/kde/kwin/Bluecurve/Makefile||" \
+ configure.in.old > configure.in
+
+ mv art/Makefile.am art/Makefile.am.old
+ sed -e "s|kde||" \
+ -e "s|qt||" \
+ art/Makefile.am.old > art/Makefile.am
+
+ mv art/Makefile.in art/Makefile.in.old
+ sed -e "s|kde||" \
+ -e "s|qt||" \
+ art/Makefile.in.old > art/Makefile.in
+
+ autoconf
+ automake
+
+ )
+
+ # paths have to be fixed for kde
+ use kde && (
+
+ # Fix paths...
+ _replace "/usr/lib/qt3" "${QTDIR}"
+ _replace '${libdir}/qt3' "${QTDIR}"
+ _replace '$(libdir)/qt3' "${QTDIR}"
+ _replace "/usr/lib/kde3" "${KDEDIR}/lib"
+ _replace '${libdir}/kde3' "${KDEDIR}/lib"
+ _replace "/usr/lib/kwin.la" "${KDEDIR}/lib/kwin.la"
+
+ chmod +x configure
+
+ )
+
+ econf || die
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ use kde && (
+ mkdir -p ${D}/${KDEDIR}/share
+ mv ${D}/usr/share/apps ${D}/${KDEDIR}/share/apps
+ mv ${D}/usr/share/icons ${D}/${KDEDIR}/share/icons
+
+ # Until someone makes a nice Gentoo-replacement for the
+ # RedHat-logo in the splash, we don't install the splash
+ # at all... :)
+ rm -rf ${D}/${KDEDIR}/share/apps/ksplash
+
+ )
+
+ dodoc AUTHORS NEWS README
+}