summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-08-05 01:53:09 +0000
committerBen de Groot <yngwin@gentoo.org>2008-08-05 01:53:09 +0000
commit53a19da2e83bc6c028cc0279bf040ffa36245cc0 (patch)
tree6ca8a6b1627ab761f245c537382c5855a2cb7161 /x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.59.7.ebuild
parentsecurity mask openttd bug 233929 (diff)
downloadhistorical-53a19da2e83bc6c028cc0279bf040ffa36245cc0.tar.gz
historical-53a19da2e83bc6c028cc0279bf040ffa36245cc0.tar.bz2
historical-53a19da2e83bc6c028cc0279bf040ffa36245cc0.zip
Version bump
Package-Manager: portage-2.2_rc6/cvs/Linux 2.6.26-hg1 i686
Diffstat (limited to 'x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.59.7.ebuild')
-rw-r--r--x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.59.7.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.59.7.ebuild b/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.59.7.ebuild
new file mode 100644
index 000000000000..19e1e39ebd10
--- /dev/null
+++ b/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.59.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.59.7.ebuild,v 1.1 2008/08/05 01:48:38 yngwin Exp $
+
+inherit eutils cmake-utils
+
+MY_P=${P/gtk-engines-qtcurve/QtCurve-Gtk2}
+
+DESCRIPTION="A set of widget styles for GTK2 based apps, also available for KDE3 and Qt4"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=40492"
+SRC_URI="http://home.freeuk.com/cpdrummond/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc64 ~sparc ~x86"
+IUSE="mozilla"
+
+RDEPEND=">=x11-libs/gtk+-2
+ x11-libs/cairo"
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.4"
+
+S=${WORKDIR}/${MY_P}
+DOCS="ChangeLog README TODO"
+
+src_compile() {
+ local mycmakeargs=""
+ use mozilla && mycmakeargs="-DQTC_MODIFY_MOZILLA=true -DQTC_MODIFY_MOZILLA_USER_JS=true"
+ cmake-utils_src_compile
+}
+