summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-08-05 17:30:17 +0000
committerBen de Groot <yngwin@gentoo.org>2008-08-05 17:30:17 +0000
commit92522df50842be3b4a078a3eb35eafccdbef0279 (patch)
tree52029f99d0614c7c1dfab953e92b8a0189e8513f /x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.59.7-r1.ebuild
parentalpha stable wrt #233817 (diff)
downloadhistorical-92522df50842be3b4a078a3eb35eafccdbef0279.tar.gz
historical-92522df50842be3b4a078a3eb35eafccdbef0279.tar.bz2
historical-92522df50842be3b4a078a3eb35eafccdbef0279.zip
Adding firefox3 useflag and dep, updating metadata with longdescription and useflags.
Package-Manager: portage-2.2_rc6/cvs/Linux 2.6.26-hg1 i686
Diffstat (limited to 'x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.59.7-r1.ebuild')
-rw-r--r--x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.59.7-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.59.7-r1.ebuild b/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.59.7-r1.ebuild
new file mode 100644
index 000000000000..3bf7f44ea650
--- /dev/null
+++ b/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.59.7-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.59.7-r1.ebuild,v 1.1 2008/08/05 17:30:17 yngwin Exp $
+
+EAPI=1
+inherit eutils cmake-utils
+
+MY_P=${P/gtk-engines-qtcurve/QtCurve-Gtk2}
+
+DESCRIPTION="A set of widget styles for GTK2 based apps, also available for KDE3 and Qt4"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=40492"
+SRC_URI="http://home.freeuk.com/cpdrummond/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc64 ~sparc ~x86"
+IUSE="mozilla firefox3"
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/cairo
+ firefox3? ( || ( >=www-client/mozilla-firefox-3.0
+ >=www-client/mozilla-firefox-bin-3.0 ) )"
+DEPEND="x11-libs/gtk+:2
+ x11-libs/cairo
+ >=dev-util/cmake-2.4"
+
+S=${WORKDIR}/${MY_P}
+DOCS="ChangeLog README TODO"
+
+src_compile() {
+ local mycmakeargs=""
+ use mozilla && mycmakeargs="-DQTC_MODIFY_MOZILLA=true -DQTC_MODIFY_MOZILLA_USER_JS=true"
+ use firefox3 && mycmakeargs="-DQTC_NEW_MOZILLA=true -DQTC_MODIFY_MOZILLA=true -DQTC_MODIFY_MOZILLA_USER_JS=true"
+ cmake-utils_src_compile
+}