summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-03-03 10:21:49 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-03-03 10:21:49 +0000
commit8feab6e96dd4b91a22a92c9cd26ea237d51fa2ae (patch)
treec85cb36530c96cffb2e081945435689c9f147bd3 /x11-terms
parentmissing patch (diff)
downloadhistorical-8feab6e96dd4b91a22a92c9cd26ea237d51fa2ae.tar.gz
historical-8feab6e96dd4b91a22a92c9cd26ea237d51fa2ae.tar.bz2
historical-8feab6e96dd4b91a22a92c9cd26ea237d51fa2ae.zip
Version bump
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/rxvt/ChangeLog7
-rw-r--r--x11-terms/rxvt/files/digest-rxvt-2.7.91
-rw-r--r--x11-terms/rxvt/files/rxvt-2.7.9-azz4.diff126
-rw-r--r--x11-terms/rxvt/rxvt-2.7.9.ebuild61
4 files changed, 194 insertions, 1 deletions
diff --git a/x11-terms/rxvt/ChangeLog b/x11-terms/rxvt/ChangeLog
index c3719a15261d..0627751170b5 100644
--- a/x11-terms/rxvt/ChangeLog
+++ b/x11-terms/rxvt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-terms/rxvt
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt/ChangeLog,v 1.11 2003/02/12 09:45:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt/ChangeLog,v 1.12 2003/03/03 10:21:49 aliz Exp $
+
+*rxvt-2.7.9 (03 Mar 2003)
+
+ 03 Mar 2003; Daniel Ahlberg <aliz@gentoo.org> :
+ Version bump.
04 Feb 2003; Jason Wever <weeve@gentoo.org> rxvt-2.7.8-r5.ebuild :
Added sparc to keywords.
diff --git a/x11-terms/rxvt/files/digest-rxvt-2.7.9 b/x11-terms/rxvt/files/digest-rxvt-2.7.9
new file mode 100644
index 000000000000..4697c1b65dce
--- /dev/null
+++ b/x11-terms/rxvt/files/digest-rxvt-2.7.9
@@ -0,0 +1 @@
+MD5 5ccfeb67133c5f2997ffc2ac014962a5 rxvt-2.7.9.tar.gz 495170
diff --git a/x11-terms/rxvt/files/rxvt-2.7.9-azz4.diff b/x11-terms/rxvt/files/rxvt-2.7.9-azz4.diff
new file mode 100644
index 000000000000..c6b34dfce60f
--- /dev/null
+++ b/x11-terms/rxvt/files/rxvt-2.7.9-azz4.diff
@@ -0,0 +1,126 @@
+diff -Naur rxvt-2.7.8/AZZ-ChangeLog rxvt-2.7.8-azz4/AZZ-ChangeLog
+--- rxvt-2.7.8/AZZ-ChangeLog Thu Jan 1 01:00:00 1970
++++ rxvt-2.7.8-azz4/AZZ-ChangeLog Mon May 20 23:10:36 2002
+@@ -0,0 +1,7 @@
++- Modified to support borderlessness with -nb and override-redirect with
++ -or (or resources borderless and overrideRedirect).
++- Modified to allow an arbitrary command to be run instead of the bell
++ with -bc.
++- Fixed buffer overflow in command.c (not that you should install this suid
++ root anyway)
++
+diff -Naur rxvt-2.7.8/src/command.c rxvt-2.7.8-azz4/src/command.c
+--- rxvt-2.7.8/src/command.c Thu Nov 29 06:53:58 2001
++++ rxvt-2.7.8-azz4/src/command.c Mon May 20 23:11:21 2002
+@@ -2930,7 +2930,7 @@
+ unsigned char buf[256];
+
+ va_start(arg_ptr, fmt);
+- vsprintf((char *)buf, fmt, arg_ptr);
++ vsnprintf((char *)buf, sizeof buf, fmt, arg_ptr);
+ va_end(arg_ptr);
+ rxvt_tt_write(r, buf, (unsigned int)STRLEN(buf));
+ }
+diff -Naur rxvt-2.7.8/src/init.c rxvt-2.7.8-azz4/src/init.c
+--- rxvt-2.7.8/src/init.c Thu Nov 29 06:38:07 2001
++++ rxvt-2.7.8-azz4/src/init.c Mon May 20 23:22:45 2002
+@@ -34,6 +34,7 @@
+ #include "../config.h" /* NECESSARY */
+ #include "rxvt.h" /* NECESSARY */
+ #include "init.h"
++#include <Xm/MwmUtil.h>
+
+ #include <signal.h>
+
+@@ -917,6 +918,24 @@
+ r->PixColors[Color_border],
+ r->PixColors[Color_fg]);
+ #endif
++ if (r->Options & Opt_borderless) {
++ Atom mwmatom;
++ MotifWmHints hints;
++
++ mwmatom = XInternAtom(r->Xdisplay, _XA_MOTIF_WM_HINTS, FALSE);
++ hints.flags = MWM_HINTS_DECORATIONS;
++ hints.decorations = 0;
++ XChangeProperty(r->Xdisplay, r->TermWin.parent[0], mwmatom, mwmatom,
++ 32, PropModeReplace, (unsigned char *)&hints,
++ sizeof(MotifWmHints)/sizeof(long));
++ }
++ if (r->Options & Opt_overrideredirect) {
++ XSetWindowAttributes attrib;
++
++ attrib.override_redirect = True;
++ XChangeWindowAttributes(r->Xdisplay, r->TermWin.parent[0],
++ CWOverrideRedirect, &attrib);
++ }
+ rxvt_xterm_seq(r, XTerm_title, r->h->rs[Rs_title], CHAR_ST);
+ rxvt_xterm_seq(r, XTerm_iconName, r->h->rs[Rs_iconName], CHAR_ST);
+
+diff -Naur rxvt-2.7.8/src/rxvt.h rxvt-2.7.8-azz4/src/rxvt.h
+--- rxvt-2.7.8/src/rxvt.h Thu Nov 29 06:38:07 2001
++++ rxvt-2.7.8-azz4/src/rxvt.h Mon May 20 23:30:20 2002
+@@ -556,6 +556,9 @@
+ Rs_modifier,
+ Rs_answerbackstring,
+ Rs_tripleclickwords,
++ Rs_borderless,
++ Rs_overrideRedirect,
++ Rs_bellCommand,
+ NUM_RESOURCES
+ } ;
+
+diff -Naur rxvt-2.7.8/src/rxvtlib.h.in rxvt-2.7.8-azz4/src/rxvtlib.h.in
+--- rxvt-2.7.8/src/rxvtlib.h.in Tue Nov 27 12:51:15 2001
++++ rxvt-2.7.8-azz4/src/rxvtlib.h.in Mon May 20 23:15:31 2002
+@@ -189,6 +189,8 @@
+ #define Opt_tripleclickwords (1LU<<16)
+ #define Opt_scrollWithBuffer (1LU<<17)
+ #define Opt_jumpScroll (1LU<<18)
++#define Opt_borderless (1LU<<19)
++#define Opt_overrideredirect (1LU<<20)
+ /* place holder used for parsing command-line options */
+ #define Opt_Reverse (1LU<<30)
+ #define Opt_Boolean (1LU<<31)
+diff -Naur rxvt-2.7.8/src/screen.c rxvt-2.7.8-azz4/src/screen.c
+--- rxvt-2.7.8/src/screen.c Wed Nov 28 11:58:12 2001
++++ rxvt-2.7.8-azz4/src/screen.c Mon May 20 23:28:19 2002
+@@ -29,6 +29,7 @@
+ #include "screen.intpro" /* PROTOS for internal routines */
+
+ #include <X11/Xmd.h> /* get the typedef for CARD32 */
++#include <stdlib.h>
+
+ /* ------------------------------------------------------------------------- */
+ #ifdef MULTICHAR_SET
+@@ -1829,6 +1830,9 @@
+ void
+ rxvt_scr_bell(rxvt_t *r)
+ {
++ if (r->h->rs[Rs_bellCommand]) {
++ system(r->h->rs[Rs_bellCommand]);
++ } else {
+ #ifndef NO_BELL
+ # ifndef NO_MAPALERT
+ # ifdef MAPALERT_OPTION
+@@ -1842,6 +1846,7 @@
+ } else
+ XBell(r->Xdisplay, 0);
+ #endif
++ }
+ }
+
+ /* ------------------------------------------------------------------------- */
+diff -Naur rxvt-2.7.8/src/xdefaults.c rxvt-2.7.8-azz4/src/xdefaults.c
+--- rxvt-2.7.8/src/xdefaults.c Thu Nov 29 07:22:51 2001
++++ rxvt-2.7.8-azz4/src/xdefaults.c Mon May 20 23:29:42 2002
+@@ -108,6 +108,9 @@
+ "scroll-on-tty-output inhibit"),
+ BOOL(Rs_scrollTtyKeypress, "scrollTtyKeypress", "sk", Opt_scrollTtyKeypress,
+ "scroll-on-keypress"),
++ BOOL(Rs_borderless, "borderless", "nb", Opt_borderless, "use MWM hints to remove the window border"),
++ BOOL(Rs_overrideRedirect, "overrideRedirect", "or", Opt_overrideredirect, "set the override_redirect flag"),
++ STRG(Rs_bellCommand, "bellCommand", "bc", "string", "command to execute instead of beeping"),
+ BOOL(Rs_scrollWithBuffer, "scrollWithBuffer", "sw", Opt_scrollWithBuffer,
+ "scroll-with-buffer"),
+ #ifdef TRANSPARENT
diff --git a/x11-terms/rxvt/rxvt-2.7.9.ebuild b/x11-terms/rxvt/rxvt-2.7.9.ebuild
new file mode 100644
index 000000000000..e487132e6858
--- /dev/null
+++ b/x11-terms/rxvt/rxvt-2.7.9.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt/rxvt-2.7.9.ebuild,v 1.1 2003/03/03 10:21:49 aliz Exp $
+
+inherit eutils
+
+IUSE="motif"
+S=${WORKDIR}/${P}
+DESCRIPTION="rxvt -- nice small x11 terminal"
+SRC_URI="ftp://ftp.rxvt.org/pub/rxvt/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+
+HOMEPAGE="http://www.rxvt.org"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ motif? ( x11-libs/openmotif )"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ use motif && epatch ${FILESDIR}/${P}-azz4.diff
+}
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --enable-rxvt-scroll \
+ --enable-transparency \
+ --enable-xpm-background \
+ --enable-utmp \
+ --enable-wtmp \
+ --enable-mousewheel \
+ --enable-slipwheeling \
+ --enable-smart-resize \
+ --enable-menubar \
+ --enable-languages \
+ --enable-xim \
+ --enable-shared \
+ --enable-keepscrolling || die
+
+ emake || die
+}
+
+src_install() {
+
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man/man1 \
+ install || die
+
+ cd ${S}/doc
+ dodoc README* *.txt BUGS FAQ
+ dohtml *.html
+}