summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2006-09-05 17:29:44 +0000
committerSeemant Kulleen <seemant@gentoo.org>2006-09-05 17:29:44 +0000
commit708f0742805c2191673159618b1de73b29cb756f (patch)
tree2f72d1341aafb4c15b12f4d76e36340721dd4316 /x11-terms/xterm
parentAdded ~alpha wrt Bug #146369. (diff)
downloadhistorical-708f0742805c2191673159618b1de73b29cb756f.tar.gz
historical-708f0742805c2191673159618b1de73b29cb756f.tar.bz2
historical-708f0742805c2191673159618b1de73b29cb756f.zip
version bump to 219, and cruft removal of some of the older versions -- 216, for example, is gone without ever hitting stable. 217 or 218 should be stabled soon
Package-Manager: portage-2.1.1_rc1-r4
Diffstat (limited to 'x11-terms/xterm')
-rw-r--r--x11-terms/xterm/ChangeLog10
-rw-r--r--x11-terms/xterm/files/digest-xterm-2193
-rw-r--r--x11-terms/xterm/xterm-219.ebuild103
3 files changed, 115 insertions, 1 deletions
diff --git a/x11-terms/xterm/ChangeLog b/x11-terms/xterm/ChangeLog
index e74b51c96d96..b9353048c323 100644
--- a/x11-terms/xterm/ChangeLog
+++ b/x11-terms/xterm/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-terms/xterm
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/xterm/ChangeLog,v 1.157 2006/08/28 00:38:52 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/xterm/ChangeLog,v 1.158 2006/09/05 17:29:44 seemant Exp $
+
+*xterm-219 (05 Sep 2006)
+
+ 05 Sep 2006; Seemant Kulleen <seemant@gentoo.org> -xterm-207-r1.ebuild,
+ -xterm-215-r1.ebuild, -xterm-216.ebuild, +xterm-219.ebuild:
+ version bump to 219, and cruft removal of some of the older versions -- 216,
+ for example, is gone without ever hitting stable. 217 or 218 should be
+ stabled soon
*xterm-218 (28 Aug 2006)
diff --git a/x11-terms/xterm/files/digest-xterm-219 b/x11-terms/xterm/files/digest-xterm-219
new file mode 100644
index 000000000000..d2220605ee5e
--- /dev/null
+++ b/x11-terms/xterm/files/digest-xterm-219
@@ -0,0 +1,3 @@
+MD5 ab2cea9330beeaa4f538da5a85999e17 xterm-219.tgz 801134
+RMD160 ac139cff951039d24a407ee9cedec16183262795 xterm-219.tgz 801134
+SHA256 8038301ef54d327070ee55984957389d027e8806441f0bf9e63d2103c76806b7 xterm-219.tgz 801134
diff --git a/x11-terms/xterm/xterm-219.ebuild b/x11-terms/xterm/xterm-219.ebuild
new file mode 100644
index 000000000000..5e2f476d24ae
--- /dev/null
+++ b/x11-terms/xterm/xterm-219.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/xterm/xterm-219.ebuild,v 1.1 2006/09/05 17:29:44 seemant Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Terminal Emulator for X Windows"
+HOMEPAGE="http://dickey.his.com/xterm/"
+SRC_URI="ftp://invisible-island.net/${PN}/${P}.tgz"
+
+LICENSE="X11"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="truetype Xaw3d unicode toolbar paste64"
+
+RDEPEND="|| ( ( x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXmu
+ x11-libs/libxkbfile
+ x11-libs/libXft
+ x11-libs/libXaw
+ unicode? ( x11-apps/luit ) )
+ virtual/x11 )
+ Xaw3d? ( x11-libs/Xaw3d )
+ sys-libs/libutempter"
+
+DEPEND="${RDEPEND}
+ || ( x11-proto/xproto virtual/x11 )"
+
+pkg_setup() {
+ if has_version "x11-libs/libX11"; then
+ DEFAULTS_DIR="/usr/share/X11/app-defaults"
+ else
+ DEFAULTS_DIR="/etc/X11/app-defaults"
+ fi
+}
+
+src_compile() {
+ filter-flags "-fstack-protector"
+
+ local myconf=""
+
+ if has_version "x11-libs/libX11"; then
+ myconf="--disable-narrowproto"
+ fi
+
+ econf \
+ --libdir=/etc \
+ --with-x \
+ --with-utempter \
+ --disable-setuid \
+ --disable-full-tgetent \
+ --disable-imake \
+ --enable-ansi-color \
+ --enable-256-color \
+ --enable-broken-osc \
+ --enable-broken-st \
+ --enable-load-vt-fonts \
+ --enable-i18n \
+ --enable-wide-chars \
+ --enable-doublechars \
+ --enable-warnings \
+ --enable-tcap-query \
+ --enable-logging \
+ --enable-dabbrev \
+ --with-app-defaults=${DEFAULTS_DIR} \
+ $(use_enable toolbar) \
+ $(use_enable truetype freetype) \
+ $(use_enable unicode luit) $(use_enable unicode mini-luit) \
+ $(use_with Xaw3d) \
+ $(use_enable paste64) \
+ ${myconf} \
+ || die
+
+ emake || die "failed to compile xterm"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README{,.i18n} ctlseqs.txt xterm.log.html
+
+ # Fix permissions -- it grabs them from live system, and they can
+ # be suid or sgid like they were in pre-unix98 pty or pre-utempter days,
+ # respectively (#69510).
+ # (info from Thomas Dickey) - Donnie Berkholz <spyderous@gentoo.org>
+ fperms 0755 /usr/bin/xterm
+
+ # restore the navy blue
+ sed -i "s:blue2$:blue:" ${D}${DEFAULTS_DIR}/XTerm-color
+
+ # Fix for bug #91453 at Thomas Dickey's suggestion:
+ echo "*allowWindowOps: false" >> ${D}/${DEFAULTS_DIR}/XTerm
+ echo "*allowWindowOps: false" >> ${D}/${DEFAULTS_DIR}/UXTerm
+}
+
+pkg_postinst() {
+ if use paste64 ; then
+ elog "bracketed paste mode requires the allowWindowOps resource to be true"
+ elog "which is false by default for security reasons (see bug #91453)."
+ elog "To be able to use it add 'allowWindowOps: true' to your resources"
+ fi
+}