summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2005-02-18 18:30:21 +0000
committerDon Seiler <rizzo@gentoo.org>2005-02-18 18:30:21 +0000
commit52ce182944c9f036af205e14c982dbe80c98e5f9 (patch)
treee671c7be45062b65000395e6b8a237c9f5667155 /x11-plugins
parentx86, sparc stable (diff)
downloadhistorical-52ce182944c9f036af205e14c982dbe80c98e5f9.tar.gz
historical-52ce182944c9f036af205e14c982dbe80c98e5f9.tar.bz2
historical-52ce182944c9f036af205e14c982dbe80c98e5f9.zip
Patch to remove some extraneous printf() lines. Closes bug #82118, thanks Manuel Sabban.
Package-Manager: portage-2.0.51.16
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/gaimosd/ChangeLog8
-rw-r--r--x11-plugins/gaimosd/Manifest15
-rw-r--r--x11-plugins/gaimosd/files/gaimosd-quiet.diff31
-rw-r--r--x11-plugins/gaimosd/gaimosd-1.0.0.ebuild10
4 files changed, 48 insertions, 16 deletions
diff --git a/x11-plugins/gaimosd/ChangeLog b/x11-plugins/gaimosd/ChangeLog
index 0839183fddae..70f0ca72443b 100644
--- a/x11-plugins/gaimosd/ChangeLog
+++ b/x11-plugins/gaimosd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/gaimosd
-# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaimosd/ChangeLog,v 1.3 2004/12/14 03:53:34 eradicator Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaimosd/ChangeLog,v 1.4 2005/02/18 18:30:21 rizzo Exp $
+
+ 18 Feb 2005; Don Seiler <rizzo@gentoo.org> gaimosd-1.0.0.ebuild:
+ Patch to remove some extraneous printf() lines. Closes bug #82118, thanks
+ Manuel Sabban.
13 Dec 2004; Jeremy Huddleston <eradicator@gentoo.org>
gaimosd-1.0.0.ebuild:
diff --git a/x11-plugins/gaimosd/Manifest b/x11-plugins/gaimosd/Manifest
index 2e73f36ca77a..dd5b1d02e50b 100644
--- a/x11-plugins/gaimosd/Manifest
+++ b/x11-plugins/gaimosd/Manifest
@@ -1,14 +1,5 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 7c58be4f63467925b06771c50049ac68 ChangeLog 563
-MD5 850f28ae3c86034af0639dd2a5c84a84 gaimosd-1.0.0.ebuild 761
+MD5 b6fb2e82692d7e2481111eaf2a714d8e ChangeLog 719
+MD5 d8b416b880ea46d5bb83fcaf537612a8 gaimosd-1.0.0.ebuild 835
MD5 c0faf0b1810affab2e94a1a23f8533ab metadata.xml 370
MD5 e562a7f08384757d72348e1590ae7ba6 files/digest-gaimosd-1.0.0 65
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFBvmPHArHZZzCEUG0RAlvwAJ9Y/n4483QMVNFu78AbY4ggmj7OrwCfSBQl
-rACxvnGfBd9/J2JfNoAjNKg=
-=oIjm
------END PGP SIGNATURE-----
+MD5 bf766281a9286c3ad2c0fc74ec0c3e45 files/gaimosd-quiet.diff 718
diff --git a/x11-plugins/gaimosd/files/gaimosd-quiet.diff b/x11-plugins/gaimosd/files/gaimosd-quiet.diff
new file mode 100644
index 000000000000..682a3aedbd83
--- /dev/null
+++ b/x11-plugins/gaimosd/files/gaimosd-quiet.diff
@@ -0,0 +1,31 @@
+diff -ruN old/gaimosd-1.0.0/display.c new/gaimosd-1.0.0/display.c
+--- old/gaimosd-1.0.0/display.c 2004-09-20 08:08:44.000000000 +0200
++++ new/gaimosd-1.0.0/display.c 2005-02-15 16:32:25.349400000 +0100
+@@ -65,11 +65,9 @@
+ gboolean
+ osd_display_cb(osd_display_t *disp)
+ {
+- printf("bar 1\n");
+ if (!disp)
+ return FALSE;
+
+- printf("bar 2\n");
+ if (disp->lines > -Osd_lines) {
+ disp->lines--;
+ XOSD_SCROLL(Osd, 1);
+@@ -82,7 +80,6 @@
+ return TRUE;
+ }
+
+- printf("bar 3\n");
+ XOSD_HIDE(Osd);
+ XOSD_SCROLL(Osd, Osd_lines);
+ Osd_current = NULL;
+@@ -328,7 +325,6 @@
+ XOSD_SET_COLOUR(Osd, color);
+ XOSD_SET_TIMEOUT(Osd, -1);
+
+- printf("foo 1\n");
+ for (i = 0; i < Osd_lines; i++) {
+ if (!slist)
+ break;
diff --git a/x11-plugins/gaimosd/gaimosd-1.0.0.ebuild b/x11-plugins/gaimosd/gaimosd-1.0.0.ebuild
index 4f3abba6df4c..7f04016c5cc8 100644
--- a/x11-plugins/gaimosd/gaimosd-1.0.0.ebuild
+++ b/x11-plugins/gaimosd/gaimosd-1.0.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaimosd/gaimosd-1.0.0.ebuild,v 1.4 2004/12/14 03:53:34 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaimosd/gaimosd-1.0.0.ebuild,v 1.5 2005/02/18 18:30:21 rizzo Exp $
inherit eutils
@@ -16,6 +16,12 @@ KEYWORDS="~amd64 ~x86 ~ppc"
DEPEND=">=net-im/gaim-1.0.0
x11-libs/xosd"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/gaimosd-quiet.diff
+}
+
src_compile() {
econf --enable-customized-buddies --enable-customized-conversations || die
emake || die "emake failed"