summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-10-24 19:19:06 +0000
committerNick Hadaway <raker@gentoo.org>2002-10-24 19:19:06 +0000
commitce6fb6060020af9fbc6b0390912d3fa69706259d (patch)
tree74b81636327f75914f08a5eab6617d8f09900fda /x11-plugins/wmfire/wmfire-0.0.3.9_pre4.ebuild
parentInitial add of ebuild to portage. Please see bug #5984 (diff)
downloadhistorical-ce6fb6060020af9fbc6b0390912d3fa69706259d.tar.gz
historical-ce6fb6060020af9fbc6b0390912d3fa69706259d.tar.bz2
historical-ce6fb6060020af9fbc6b0390912d3fa69706259d.zip
Initial add of ebuild to portage. See bug #5986
Diffstat (limited to 'x11-plugins/wmfire/wmfire-0.0.3.9_pre4.ebuild')
-rw-r--r--x11-plugins/wmfire/wmfire-0.0.3.9_pre4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-plugins/wmfire/wmfire-0.0.3.9_pre4.ebuild b/x11-plugins/wmfire/wmfire-0.0.3.9_pre4.ebuild
new file mode 100644
index 000000000000..2be46dfd42d6
--- /dev/null
+++ b/x11-plugins/wmfire/wmfire-0.0.3.9_pre4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfire/wmfire-0.0.3.9_pre4.ebuild,v 1.1 2002/10/24 19:19:06 raker Exp $
+
+MY_P="${P/_/}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="WindowMaker dockapp that displays cpu usage as a dancing flame"
+SRC_URI="http://staff.xmms.org/zinx/misc/${MY_P}.tar.gz"
+HOMEPAGE="http://staff.xmms.org/zinx/misc"
+
+DEPEND="virtual/x11 x11-wm/WindowMaker virtual/glibc"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+IUSE=""
+
+src_compile() {
+
+ local myconf="--with-x";
+ econf ${myconf} || die "configure failed"
+
+ emake CFLAGS="$CFLAGS" || die "parallel make faile"
+}
+
+src_install () {
+
+ make install \
+ prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib || die
+
+ dodoc AUTHORS COPYING CREDITS INSTALL NEWS README
+
+}