summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2004-07-20 11:02:20 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2004-07-20 11:02:20 +0000
commit475e51003bcfbbaf44002f2f6300989bb37deea6 (patch)
tree4507f17b6b32f91426211795887b087e0db5e31e /x11-plugins/wmcliphist/wmcliphist-0.5.ebuild
parentadded sparc fix for glibc PIC building (diff)
downloadhistorical-475e51003bcfbbaf44002f2f6300989bb37deea6.tar.gz
historical-475e51003bcfbbaf44002f2f6300989bb37deea6.tar.bz2
historical-475e51003bcfbbaf44002f2f6300989bb37deea6.zip
Fix x11-plugins/wmcliphist-0.5 ebuild to produce a working binary. Closes #56782. Wipe out old ebuilds.
Diffstat (limited to 'x11-plugins/wmcliphist/wmcliphist-0.5.ebuild')
-rw-r--r--x11-plugins/wmcliphist/wmcliphist-0.5.ebuild21
1 files changed, 19 insertions, 2 deletions
diff --git a/x11-plugins/wmcliphist/wmcliphist-0.5.ebuild b/x11-plugins/wmcliphist/wmcliphist-0.5.ebuild
index d47ec9e05da7..b591c5f64cfc 100644
--- a/x11-plugins/wmcliphist/wmcliphist-0.5.ebuild
+++ b/x11-plugins/wmcliphist/wmcliphist-0.5.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmcliphist/wmcliphist-0.5.ebuild,v 1.7 2004/06/24 23:06:28 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmcliphist/wmcliphist-0.5.ebuild,v 1.8 2004/07/20 11:02:20 s4t4n Exp $
+
+inherit eutils
IUSE=""
DESCRIPTION="Dockable clipboard history application for Window Maker"
@@ -12,7 +14,22 @@ SLOT="0"
DEPEND="=x11-libs/gtk+-1.2*"
-src_install() {
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+
+ # We patch the Makefile as the original doesn't honour Gentoo CFLAGS
+ epatch ${FILESDIR}/wmcliphist-cflags.patch || die "Source patch failed."
+}
+
+src_compile()
+{
+ emake GENTOO_CFLAGS="${CFLAGS}" || die "Compilation failed."
+}
+
+src_install()
+{
dobin wmcliphist
dodoc ChangeLog README
newdoc .wmcliphistrc wmcliphistrc.sample