summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-01-06 21:22:12 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-01-06 21:22:12 +0000
commita90674ac2d7b2272ab3cd0f415c9800044fbb900 (patch)
tree550e237670da3096f786b86f41f99246262eb77f /x11-plugins/wmbiff/wmbiff-0.4.27.ebuild
parentAdded a check for app-crypt/pinentry having been built with either the gtk or... (diff)
downloadhistorical-a90674ac2d7b2272ab3cd0f415c9800044fbb900.tar.gz
historical-a90674ac2d7b2272ab3cd0f415c9800044fbb900.tar.bz2
historical-a90674ac2d7b2272ab3cd0f415c9800044fbb900.zip
Remove old versions and mark latest stable for amd64 wrt #204554. Sanitize ebuild.
Package-Manager: portage-2.1.4_rc14
Diffstat (limited to 'x11-plugins/wmbiff/wmbiff-0.4.27.ebuild')
-rw-r--r--x11-plugins/wmbiff/wmbiff-0.4.27.ebuild42
1 files changed, 18 insertions, 24 deletions
diff --git a/x11-plugins/wmbiff/wmbiff-0.4.27.ebuild b/x11-plugins/wmbiff/wmbiff-0.4.27.ebuild
index 880f91d9930a..93ba9aec940a 100644
--- a/x11-plugins/wmbiff/wmbiff-0.4.27.ebuild
+++ b/x11-plugins/wmbiff/wmbiff-0.4.27.ebuild
@@ -1,37 +1,31 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbiff/wmbiff-0.4.27.ebuild,v 1.6 2007/07/22 05:24:06 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbiff/wmbiff-0.4.27.ebuild,v 1.7 2008/01/06 21:22:11 drac Exp $
DESCRIPTION="WMBiff is a dock applet for WindowMaker which can monitor up to 5 mailboxes."
-SRC_URI="mirror://sourceforge/wmbiff/${P}.tar.gz"
HOMEPAGE="http://sourceforge.net/projects/wmbiff/"
+SRC_URI="mirror://sourceforge/wmbiff/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="crypt"
RDEPEND="x11-libs/libX11
x11-libs/libXext
- x11-libs/libXpm"
-DEPEND="${RDEPEND}
- x11-proto/xproto
- x11-proto/xextproto
+ x11-libs/libXpm
crypt? ( >=net-libs/gnutls-1.2.3
>=dev-libs/libgcrypt-1.2.1 )"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ppc sparc x86"
-IUSE="crypt"
-
-src_compile()
-{
- local myconf
- if ! use crypt; then
- myconf="--disable-crypto"
- fi
- econf ${myconf} || die
- emake || die
+src_compile() {
+ econf $(use_enable crypt crypto)
+ emake || die "emake failed."
}
-src_install()
-{
- make DESTDIR="${D}" install || die
- dodoc ChangeLog FAQ NEWS README README.licq TODO wmbiff/sample.wmbiffrc
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc ChangeLog FAQ NEWS README README.licq TODO wmbiff/sample.wmbiffrc
}