summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2004-07-03 13:51:05 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2004-07-03 13:51:05 +0000
commitd666f37295482d52c05e4507c11d69f7da643627 (patch)
treeb57026a650d64b1f2ad2e7a5d30db61b1bdedb48 /x11-misc
parentWrong KEYWORDS. (diff)
downloadhistorical-d666f37295482d52c05e4507c11d69f7da643627.tar.gz
historical-d666f37295482d52c05e4507c11d69f7da643627.tar.bz2
historical-d666f37295482d52c05e4507c11d69f7da643627.zip
Patch to fix segmentation fault problem. Closing bug #53998.
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/bblaunch/ChangeLog4
-rw-r--r--x11-misc/bblaunch/Manifest5
-rw-r--r--x11-misc/bblaunch/bblaunch-0.0.3.ebuild3
-rw-r--r--x11-misc/bblaunch/files/bblaunch-0.0.3.patch11
4 files changed, 20 insertions, 3 deletions
diff --git a/x11-misc/bblaunch/ChangeLog b/x11-misc/bblaunch/ChangeLog
index fc01f6bf3994..eb1f6f047760 100644
--- a/x11-misc/bblaunch/ChangeLog
+++ b/x11-misc/bblaunch/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
# $Header
+ 03 Jul 2004; <pyrania@gentoo.org> +files/bblaunch-0.0.3.patch,
+ bblaunch-0.0.3.ebuild:
+ Patch to fix segmentation fault problem. Closing bug #53998.
+
14 Apr 2004; Daniel Ahlberg <aliz@gentoo.org> bblaunch-0.0.3.ebuild:
Removed S=, added IUSE=
diff --git a/x11-misc/bblaunch/Manifest b/x11-misc/bblaunch/Manifest
index 15b1f9f2c654..19efe7aef752 100644
--- a/x11-misc/bblaunch/Manifest
+++ b/x11-misc/bblaunch/Manifest
@@ -1,4 +1,5 @@
-MD5 29bdc5e4ffddce48013b44628e1e710e bblaunch-0.0.3.ebuild 614
-MD5 2eb1e6744e09e1b925804d2ae8e36ce9 ChangeLog 674
+MD5 4f83e190b9c2af709d424bdf8ce04bfb ChangeLog 828
+MD5 1405f9b8c9424e899046e2758c5feb23 bblaunch-0.0.3.ebuild 644
MD5 580d557c1c2b3bd5e562cc2f0c9b89f6 metadata.xml 245
+MD5 416d89e078248831269e2ea45c4b3d73 files/bblaunch-0.0.3.patch 311
MD5 2d5dcbb74f5171cd56a7dfc981d4afe9 files/digest-bblaunch-0.0.3 65
diff --git a/x11-misc/bblaunch/bblaunch-0.0.3.ebuild b/x11-misc/bblaunch/bblaunch-0.0.3.ebuild
index 0c874472bc6f..6371a94a0078 100644
--- a/x11-misc/bblaunch/bblaunch-0.0.3.ebuild
+++ b/x11-misc/bblaunch/bblaunch-0.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/bblaunch/bblaunch-0.0.3.ebuild,v 1.8 2004/06/24 22:12:54 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bblaunch/bblaunch-0.0.3.ebuild,v 1.9 2004/07/03 13:51:05 pyrania Exp $
IUSE=""
DESCRIPTION="An application launcher for Blackbox type window managers"
@@ -13,6 +13,7 @@ KEYWORDS="x86 ppc"
DEPEND="virtual/blackbox"
src_compile () {
+ epatch ${FILESDIR}/${P}.patch
econf || die
emake || die
}
diff --git a/x11-misc/bblaunch/files/bblaunch-0.0.3.patch b/x11-misc/bblaunch/files/bblaunch-0.0.3.patch
new file mode 100644
index 000000000000..3c78fab2ec77
--- /dev/null
+++ b/x11-misc/bblaunch/files/bblaunch-0.0.3.patch
@@ -0,0 +1,11 @@
+--- bblaunch.c.orig 2002-05-06 23:35:57.000000000 -0500
++++ bblaunch.c 2004-06-15 07:21:11.080972712 -0500
+@@ -170,7 +170,7 @@
+ launchargs.iconic = False;
+ launchargs.pause = 1000;
+
+- sprintf(launchargs.call, "%s", (char *)atoi(argv[0]));
++ sprintf(launchargs.call, "%s", argv[0]);
+
+ i = 1;
+ valargs = 1;