summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-02-08 12:21:05 +0000
committerJeroen Roovers <jer@gentoo.org>2010-02-08 12:21:05 +0000
commitb8228fd2dcf5f762dfb60a90922373250e7e9913 (patch)
tree58c8a793197f02463fee9e4c24fe1134368d46b7 /x11-misc/xsnap/xsnap-1.5.6.ebuild
parentAdd the 3.0 beta SDK. (diff)
downloadhistorical-b8228fd2dcf5f762dfb60a90922373250e7e9913.tar.gz
historical-b8228fd2dcf5f762dfb60a90922373250e7e9913.tar.bz2
historical-b8228fd2dcf5f762dfb60a90922373250e7e9913.zip
Version bump thanks to Jean-Pierre Demailly (bug #286053). Respect CC, LDFLAGS, CFLAGS. Use pkg-config.
Package-Manager: portage-2.2_rc62/cvs/Linux i686
Diffstat (limited to 'x11-misc/xsnap/xsnap-1.5.6.ebuild')
-rw-r--r--x11-misc/xsnap/xsnap-1.5.6.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/x11-misc/xsnap/xsnap-1.5.6.ebuild b/x11-misc/xsnap/xsnap-1.5.6.ebuild
new file mode 100644
index 000000000000..a569c01f2564
--- /dev/null
+++ b/x11-misc/xsnap/xsnap-1.5.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsnap/xsnap-1.5.6.ebuild,v 1.1 2010/02/08 12:21:04 jer Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Program to interactively take a 'snapshot' of a region of the screen"
+SRC_URI="ftp://ftp.ac-grenoble.fr/ge/Xutils/${P}.tar.bz2"
+HOMEPAGE="ftp://ftp.ac-grenoble.fr/ge/Xutils/"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ media-libs/libpng
+ media-libs/jpeg"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ app-text/rman
+ x11-misc/imake"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ xmkmf || die "xmkmf failed"
+ sed -i Makefile \
+ -e '/ CC = /d' \
+ -e '/ LD = /d' \
+ -e '/ CDEBUGFLAGS = /d' \
+ -e '/ CCOPTIONS = /d' \
+ -e 's|CPP = cpp|CPP = $(CC)|g' \
+ || die "sed failed"
+}
+
+src_compile() {
+ tc-export CC
+ emake CCOPTIONS="${CFLAGS}" EXTRA_LDOPTIONS="${LDFLAGS}" || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ make DESTDIR="${D}" install.man || die "make install.man failed"
+ dodoc README AUTHORS
+}