summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2005-02-07 09:15:32 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2005-02-07 09:15:32 +0000
commit436a9969b4995b0910df9e76133700ed792a4e36 (patch)
treeb6d43363557ed424e182a44b6cbbe4ee720d7799 /x11-misc/xaos
parentStable on alpha. (diff)
downloadhistorical-436a9969b4995b0910df9e76133700ed792a4e36.tar.gz
historical-436a9969b4995b0910df9e76133700ed792a4e36.tar.bz2
historical-436a9969b4995b0910df9e76133700ed792a4e36.zip
Version bump
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'x11-misc/xaos')
-rw-r--r--x11-misc/xaos/ChangeLog9
-rw-r--r--x11-misc/xaos/Manifest16
-rw-r--r--x11-misc/xaos/files/digest-xaos-3.1.11
-rw-r--r--x11-misc/xaos/xaos-3.1.1.ebuild61
-rw-r--r--x11-misc/xaos/xaos-3.1.ebuild4
5 files changed, 75 insertions, 16 deletions
diff --git a/x11-misc/xaos/ChangeLog b/x11-misc/xaos/ChangeLog
index d0f838239725..69661b7b802f 100644
--- a/x11-misc/xaos/ChangeLog
+++ b/x11-misc/xaos/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xaos
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xaos/ChangeLog,v 1.13 2004/12/03 22:46:57 slarti Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xaos/ChangeLog,v 1.14 2005/02/07 09:15:32 phosphan Exp $
+
+*xaos-3.1.1 (07 Feb 2005)
+
+ 07 Feb 2005; Patrick Kursawe <phosphan@gentoo.org> +xaos-3.1.1.ebuild:
+ Version bump
03 Dec 2004; Tom Martin <slarti@gentoo.org> xaos-3.1.ebuild:
Stable on amd64, resolves bug 72495.
diff --git a/x11-misc/xaos/Manifest b/x11-misc/xaos/Manifest
index 392cd47d3bec..92fd56055843 100644
--- a/x11-misc/xaos/Manifest
+++ b/x11-misc/xaos/Manifest
@@ -1,15 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 fb737f080425132cc8821eeb4012944e xaos-3.1.ebuild 1759
-MD5 0cb09667d3ba5045de0dffa94f829498 ChangeLog 1515
+MD5 dc3ea29a3319b960518790c572768926 xaos-3.1.ebuild 1761
+MD5 58ee5e5d91f650cb39a5061ded45203c xaos-3.1.1.ebuild 1692
+MD5 7a92baa6d385d9ed1cc0843df607bc25 ChangeLog 1633
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
+MD5 a5aa09876dbb6a8b3800c2ddeb749264 files/digest-xaos-3.1.1 63
MD5 f15bb8d89c74bd6168e7e67b16b789d4 files/digest-xaos-3.1 61
MD5 7589bd8d57e0ddebeb3463df943ed3a2 files/gcc3.4.patch 7778
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFBsO0lCHk4+ZoBpvsRAiT/AKCCQGvmEMywq/re25CyZ6uqs3uESACfSBo1
-LrGv2DlQQUh3M6okiJoejQk=
-=bbZb
------END PGP SIGNATURE-----
diff --git a/x11-misc/xaos/files/digest-xaos-3.1.1 b/x11-misc/xaos/files/digest-xaos-3.1.1
new file mode 100644
index 000000000000..2c51f43fa147
--- /dev/null
+++ b/x11-misc/xaos/files/digest-xaos-3.1.1
@@ -0,0 +1 @@
+MD5 e3de1d6e76f729e63678fdec6ddee857 XaoS-3.1.1.tar.gz 1430078
diff --git a/x11-misc/xaos/xaos-3.1.1.ebuild b/x11-misc/xaos/xaos-3.1.1.ebuild
new file mode 100644
index 000000000000..47beb39bb9ff
--- /dev/null
+++ b/x11-misc/xaos/xaos-3.1.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xaos/xaos-3.1.1.ebuild,v 1.1 2005/02/07 09:15:32 phosphan Exp $
+
+inherit eutils
+
+IUSE="X svga aalib nls"
+
+MY_PN=XaoS
+MY_P=${MY_PN}-${PV}
+
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A very fast real-time fractal zoomer"
+HOMEPAGE="http://sourceforge.net/projects/xaos/"
+SRC_URI="mirror://sourceforge/xaos/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~amd64 -sparc"
+
+DEPEND="X? ( virtual/x11 )
+ svga? ( >=media-libs/svgalib-1.4.3 )
+ aalib? ( media-libs/aalib )
+ sys-libs/zlib
+ media-libs/libpng"
+# xaos has ggi support, but it doesn't build
+# ggi? ( media-libs/libggi )
+
+
+src_compile() {
+ local myconf
+ use X || myconf="--with-x11-driver=no"
+# use dga || myconf="${myconf} --with-dga-driver=no"
+# ggi support removed due to upstream bug
+ #use ggi ||
+ myconf="${myconf} --with-ggi-driver=no"
+ use svga || myconf="${myconf} --with-svga-driver=no"
+# use aalib || myconf="${myconf} --with-aa-driver=no"
+
+ #i18n support is quite broken in XaoS, it gets installed
+ #anyway, so we remove it later during install if not desired
+ use nls || myconf="${myconf} --with-i18n=no"
+
+ ./configure --prefix=/usr ${myconf} && make || die
+}
+
+src_install() {
+ # these get installed, assuming that the directories exist!
+ mkdir -p ${D}/usr/share/locale/{hu,es,fr,cs,de}/LC_MESSAGES
+ mkdir -p ${D}/usr/share/{man,info}
+ make \
+ prefix=${D}/usr \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ LOCALEDIR=${D}/usr/share/locale \
+ install || die
+
+ use nls || rm -r ${D}/usr/share/locale
+
+ dodoc ChangeLog* COPYING INSTALL* TODO*
+}
diff --git a/x11-misc/xaos/xaos-3.1.ebuild b/x11-misc/xaos/xaos-3.1.ebuild
index 1666db0e4261..2cdff4e4ca9a 100644
--- a/x11-misc/xaos/xaos-3.1.ebuild
+++ b/x11-misc/xaos/xaos-3.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xaos/xaos-3.1.ebuild,v 1.11 2004/12/03 22:46:57 slarti Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xaos/xaos-3.1.ebuild,v 1.12 2005/02/07 09:15:32 phosphan Exp $
inherit eutils