summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Smith <smithj@gentoo.org>2005-06-14 13:19:48 +0000
committerJonathan Smith <smithj@gentoo.org>2005-06-14 13:19:48 +0000
commit1f79822aac08ca29af0ef92101a7582ece667054 (patch)
tree59fd364ddeaa83eee64e0b09dc5ae3e7581ebf7e /x11-misc/wdm/wdm-1.28.ebuild
parentVersion bump (diff)
downloadhistorical-1f79822aac08ca29af0ef92101a7582ece667054.tar.gz
historical-1f79822aac08ca29af0ef92101a7582ece667054.tar.bz2
historical-1f79822aac08ca29af0ef92101a7582ece667054.zip
version bump for #72198, ebuild cleanup, marked 1.26-r1 stable on x86
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'x11-misc/wdm/wdm-1.28.ebuild')
-rw-r--r--x11-misc/wdm/wdm-1.28.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-misc/wdm/wdm-1.28.ebuild b/x11-misc/wdm/wdm-1.28.ebuild
new file mode 100644
index 000000000000..daf0e5179312
--- /dev/null
+++ b/x11-misc/wdm/wdm-1.28.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wdm/wdm-1.28.ebuild,v 1.1 2005/06/14 13:19:48 smithj Exp $
+
+inherit eutils pam
+
+IUSE="truetype pam selinux"
+
+DESCRIPTION="WINGs Display Manager"
+HOMEPAGE="http://voins.program.ru/wdm/"
+SRC_URI="http://voins.program.ru/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~alpha"
+LICENSE="GPL-2"
+
+RDEPEND=">=x11-wm/windowmaker-0.70.0
+ virtual/x11
+ truetype? ( virtual/xft )
+ pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_compile() {
+ econf \
+ --exec-prefix=/usr \
+ --with-wdmdir=/etc/X11/wdm \
+ $(use_enable pam)\
+ $(use_enable selinux) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ rm -f ${D}/etc/pam.d/wdm
+ newpamd "${FILESDIR}/wdm-include" wdm
+}