summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2004-01-10 17:55:25 +0000
committerTavis Ormandy <taviso@gentoo.org>2004-01-10 17:55:25 +0000
commitecdbdc541e1e90438175f74f05413ae351d20f52 (patch)
tree526537b23e065f76ca36fbeccf88dd9c3f709563 /x11-misc/peksystray
parentinitial import (diff)
downloadhistorical-ecdbdc541e1e90438175f74f05413ae351d20f52.tar.gz
historical-ecdbdc541e1e90438175f74f05413ae351d20f52.tar.bz2
historical-ecdbdc541e1e90438175f74f05413ae351d20f52.zip
initial import
Diffstat (limited to 'x11-misc/peksystray')
-rw-r--r--x11-misc/peksystray/Manifest3
-rw-r--r--x11-misc/peksystray/files/digest-peksystray-0.21
-rw-r--r--x11-misc/peksystray/files/peksystray-gcc3-mlsl.diff40
-rw-r--r--x11-misc/peksystray/peksystray-0.2.ebuild29
4 files changed, 72 insertions, 1 deletions
diff --git a/x11-misc/peksystray/Manifest b/x11-misc/peksystray/Manifest
index 4844d6dc90d2..824d4b9e8640 100644
--- a/x11-misc/peksystray/Manifest
+++ b/x11-misc/peksystray/Manifest
@@ -1,3 +1,4 @@
-MD5 b0b95ad274d8e2d940f05ac49b19af6b peksystray-0.2.ebuild 674
+MD5 d85b770cdc03357d2712eb0394aead34 peksystray-0.2.ebuild 777
+MD5 49026b67817a044a894ea9deefa99064 ChangeLog 377
MD5 235ebfa6792cba5ba808e21cc0ea76b4 files/peksystray-gcc3-mlsl.diff 1323
MD5 65914961157e06b6a6c208934e37e76e files/digest-peksystray-0.2 65
diff --git a/x11-misc/peksystray/files/digest-peksystray-0.2 b/x11-misc/peksystray/files/digest-peksystray-0.2
new file mode 100644
index 000000000000..d0a6e3c44f13
--- /dev/null
+++ b/x11-misc/peksystray/files/digest-peksystray-0.2
@@ -0,0 +1 @@
+MD5 ebc882971dddf4bac5bda77c232e7233 peksystray-0.2.tar.gz 67117
diff --git a/x11-misc/peksystray/files/peksystray-gcc3-mlsl.diff b/x11-misc/peksystray/files/peksystray-gcc3-mlsl.diff
new file mode 100644
index 000000000000..868e9b2fd4da
--- /dev/null
+++ b/x11-misc/peksystray/files/peksystray-gcc3-mlsl.diff
@@ -0,0 +1,40 @@
+diff -ruN peksystray-0.2.orig/src/peksystray.c peksystray-0.2/src/peksystray.c
+--- peksystray-0.2.orig/src/peksystray.c 2003-06-20 12:21:04.000000000 +0100
++++ peksystray-0.2/src/peksystray.c 2004-01-10 17:49:13.000000000 +0000
+@@ -66,21 +66,21 @@
+ void
+ display_help ()
+ {
+- fprintf (stdout, "
+-%s - version %s
+-Copyright 2003, Mohammed Sameer <uniball@linux-egypt.org>
+-
+-Usage: %s [OPTIONS]
+-
+-Options:
+- --help\t Display this help.
+- --version\t Display version number and exit.
+- --display DISPLAY\t The X display to connect to.
+- --icon-size SIZE\t Icon size. Default is 16.
+- --vertical\t Vertical layout. Default is horizontal.
+- --border SIZE\t Border width. Default is 0;
+- --multiple\t Open each icon in a separate window. Default is no.
+-
++ fprintf (stdout, "\n\
++%s - version %s\n\
++Copyright 2003, Mohammed Sameer <uniball@linux-egypt.org>\n\
++\n\
++Usage: %s [OPTIONS]\n\
++\n\
++Options:\n\
++ --help\t Display this help.\n\
++ --version\t Display version number and exit.\n\
++ --display DISPLAY\t The X display to connect to.\n\
++ --icon-size SIZE\t Icon size. Default is 16.\n\
++ --vertical\t Vertical layout. Default is horizontal.\n\
++ --border SIZE\t Border width. Default is 0;\n\
++ --multiple\t Open each icon in a separate window. Default is no.\n\
++\n\
+ ", PACKAGE, VERSION, PACKAGE);
+ exit (0);
+ }
diff --git a/x11-misc/peksystray/peksystray-0.2.ebuild b/x11-misc/peksystray/peksystray-0.2.ebuild
new file mode 100644
index 000000000000..e85abffed3fc
--- /dev/null
+++ b/x11-misc/peksystray/peksystray-0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/peksystray/peksystray-0.2.ebuild,v 1.1 2004/01/10 17:55:15 taviso Exp $
+
+inherit eutils
+
+DESCRIPTION="A system tray dockapp for window managers supporting docking"
+HOMEPAGE="http://freshmeat.net/projects/peksystray"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha"
+DEPEND="virtual/x11"
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+
+ # Quick patch to get rid of the multi-line string literal.
+ # -taviso (10 Jan 2004)
+ cd ${S}; epatch ${FILESDIR}/${PN}-gcc3-mlsl.diff
+}
+
+src_install() {
+ dodoc AUTHORS COPYING NEWS README THANKS TODO
+ dobin src/peksystray
+}