summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-27 21:56:25 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-27 21:56:25 +0000
commit72374658923a9818bc1e81ec9f3e367160853c18 (patch)
tree12c3f3e6757359a99db9520ed7eed709f35b1abf /x11-misc/notify-osd
parentRevision bump: fix udev rules for keys with slashes in serial numbers (bug #3... (diff)
downloadhistorical-72374658923a9818bc1e81ec9f3e367160853c18.tar.gz
historical-72374658923a9818bc1e81ec9f3e367160853c18.tar.bz2
historical-72374658923a9818bc1e81ec9f3e367160853c18.zip
Fix code to be compatible with x11-libs/libnotify >= 0.7 API. Introduce savedconfig.eclass support.
Package-Manager: portage-2.2.0_alpha28/cvs/Linux x86_64
Diffstat (limited to 'x11-misc/notify-osd')
-rw-r--r--x11-misc/notify-osd/ChangeLog7
-rw-r--r--x11-misc/notify-osd/Manifest5
-rw-r--r--x11-misc/notify-osd/files/notify-osd-0.9.30-libnotify-0.7.patch257
-rw-r--r--x11-misc/notify-osd/notify-osd-0.9.30.ebuild21
4 files changed, 279 insertions, 11 deletions
diff --git a/x11-misc/notify-osd/ChangeLog b/x11-misc/notify-osd/ChangeLog
index 2e9bbf71d623..05f1af63685e 100644
--- a/x11-misc/notify-osd/ChangeLog
+++ b/x11-misc/notify-osd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/notify-osd
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/notify-osd/ChangeLog,v 1.2 2011/03/21 22:37:03 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/notify-osd/ChangeLog,v 1.3 2011/03/27 21:56:25 ssuominen Exp $
+
+ 27 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> notify-osd-0.9.30.ebuild,
+ +files/notify-osd-0.9.30-libnotify-0.7.patch:
+ Fix code to be compatible with x11-libs/libnotify >= 0.7 API. Introduce
+ savedconfig.eclass support.
21 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
notify-osd-0.9.30.ebuild:
diff --git a/x11-misc/notify-osd/Manifest b/x11-misc/notify-osd/Manifest
index 951944d8507a..74226e650e5d 100644
--- a/x11-misc/notify-osd/Manifest
+++ b/x11-misc/notify-osd/Manifest
@@ -1,4 +1,5 @@
+AUX notify-osd-0.9.30-libnotify-0.7.patch 7912 RMD160 267681859436762380c18cf75bd6c8973ca8f785 SHA1 94c2b76d7419e477727a0db0e0eb6a6412fb50a6 SHA256 9e6751f33cd5c0738308a791bd3ff7b0f7b2e630d408ce3794153b383e695e8b
DIST notify-osd-0.9.30.tar.gz 608796 RMD160 e8c1810385a31c5b0fd7ad2b741e901b99c6c390 SHA1 10f47457971d41e0f412672d86f19a0878136493 SHA256 5dbe49d46b6d7be703cd1f015b78bdfe8346dd409d020aa8b10fe023e25eb078
-EBUILD notify-osd-0.9.30.ebuild 1194 RMD160 20e0b18c56a38d6eba7190174a3bdb939184dcc0 SHA1 e0c13a4c23ad7b8a4bf3b9d3f349fdb389a733be SHA256 9848a1346ae0ba45ea5dc8974abc492e35bfb7da8c4ec41dd782452e33a20b85
-MISC ChangeLog 494 RMD160 606b5f21c4b906172841d89eb0821634ff3ef389 SHA1 0e467636380aa50eed4ea4b9a210ecec5baed067 SHA256 d2a4803dc696818b55e24376dc62ce6f9ca5e5edf5a66faefad7641b93a1a29b
+EBUILD notify-osd-0.9.30.ebuild 1448 RMD160 c84cb42589af2ba24ca6b45dfc9a8f42004a000a SHA1 b58e24e045d79203480fb81046fb6723f25da90b SHA256 63f87f1653bd8c69b9f1302b368af78145477f400373a76f85934d5e6f53d135
+MISC ChangeLog 728 RMD160 6dfbfaaa66f078f1a8767bba560e495ac93e90f0 SHA1 d14504efa0c7bb0ba8354504055dd65952019d77 SHA256 bbbc495c52449897e9e7b891d476accb5c28c883004e1be53d97932d60c03560
MISC metadata.xml 271 RMD160 f5550f51d7c9f7bb15177eeb66d3de3f6511f45a SHA1 13cd5d11fbd7f0dfd5967b8757efd71d4d273e23 SHA256 b0ab8f8a76df2649ab818da3d391589e88d0befc9607eb6c3be7f1746b2d4392
diff --git a/x11-misc/notify-osd/files/notify-osd-0.9.30-libnotify-0.7.patch b/x11-misc/notify-osd/files/notify-osd-0.9.30-libnotify-0.7.patch
new file mode 100644
index 000000000000..7f70d99f9e9e
--- /dev/null
+++ b/x11-misc/notify-osd/files/notify-osd-0.9.30-libnotify-0.7.patch
@@ -0,0 +1,257 @@
+--- examples/append-hint-example.c
++++ examples/append-hint-example.c
+@@ -41,7 +41,7 @@
+ GError* error = NULL;
+
+ /* initial notification */
+- notification = notify_notification_new (title, body, icon, NULL);
++ notification = notify_notification_new (title, body, icon);
+ notify_notification_set_hint_string (notification,
+ "x-canonical-append",
+ "");
+--- examples/icon-only.c
++++ examples/icon-only.c
+@@ -54,8 +54,7 @@
+ notification = notify_notification_new (
+ "Eject", /* for a11y-reasons put something meaningfull here */
+ NULL,
+- "notification-device-eject",
+- NULL);
++ "notification-device-eject");
+ notify_notification_set_hint_string (notification,
+ "x-canonical-private-icon-only",
+ "");
+--- examples/icon-summary-body.c
++++ examples/icon-summary-body.c
+@@ -54,8 +54,7 @@
+ "Hey pal, what's up with the party "
+ "next weekend? Will you join me "
+ "and Anna?",
+- "notification-message-im",
+- NULL);
++ "notification-message-im");
+ error = NULL;
+ success = notify_notification_show (notification, &error);
+ if (!success)
+--- examples/icon-summary.c
++++ examples/icon-summary.c
+@@ -52,8 +52,7 @@
+ notification = notify_notification_new (
+ "WiFi connection lost",
+ NULL,
+- "notification-network-wireless-disconnected",
+- NULL);
++ "notification-network-wireless-disconnected");
+ error = NULL;
+ success = notify_notification_show (notification, &error);
+ if (!success)
+--- examples/icon-updating.c
++++ examples/icon-updating.c
+@@ -53,7 +53,6 @@
+ notification = notify_notification_new (
+ "Test 1/3",
+ "Set icon via hint \"image_path\" to logo-icon.",
+- NULL,
+ NULL);
+ notify_notification_set_hint_string (
+ notification,
+--- examples/icon-value.c
++++ examples/icon-value.c
+@@ -42,8 +42,7 @@
+ notification = notify_notification_new (
+ "Brightness", /* for a11y-reasons put something meaningfull here */
+ NULL,
+- icon,
+- NULL);
++ icon);
+ notify_notification_set_hint_int32 (notification,
+ "value",
+ value);
+--- examples/summary-body.c
++++ examples/summary-body.c
+@@ -52,7 +52,6 @@
+ notification = notify_notification_new (
+ "Totem",
+ "This is a superfluous notification",
+- NULL,
+ NULL);
+ error = NULL;
+ success = notify_notification_show (notification, &error);
+--- examples/summary-only.c
++++ examples/summary-only.c
+@@ -52,7 +52,6 @@
+ notification = notify_notification_new (
+ "Summary-only",
+ NULL,
+- NULL,
+ NULL);
+ error = NULL;
+ success = notify_notification_show (notification, &error);
+--- examples/sync-icon-only.c
++++ examples/sync-icon-only.c
+@@ -55,8 +55,7 @@
+ notification = notify_notification_new (
+ "Eject", /* for a11y-reasons put something meaningfull here */
+ NULL,
+- "notification-device-eject",
+- NULL);
++ "notification-device-eject");
+ notify_notification_set_hint_string (notification,
+ "x-canonical-private-icon-only",
+ "");
+--- examples/update-notifications.c
++++ examples/update-notifications.c
+@@ -53,8 +53,7 @@
+ "Inital notification",
+ "This is the original content of "
+ "this notification-bubble.",
+- "notification-message-im",
+- NULL);
++ "notification-message-im");
+ error = NULL;
+ success = notify_notification_show (notification, &error);
+ if (!success)
+@@ -97,8 +96,7 @@
+ "Initial layout",
+ "This bubble uses the icon-title-body "
+ "layout.",
+- "notification-message-im",
+- NULL);
++ "notification-message-im");
+ error = NULL;
+ success = notify_notification_show (notification, &error);
+ if (!success)
+--- tests/test-synchronous.c
++++ tests/test-synchronous.c
+@@ -38,7 +38,7 @@
+ NotifyNotification *n;
+ n = notify_notification_new ("Test notification",
+ g_strdup (message),
+- "", NULL);
++ "");
+ notify_notification_show (n, NULL);
+ g_object_unref(G_OBJECT(n));
+ }
+@@ -53,8 +53,7 @@
+ if (n == NULL)
+ n = notify_notification_new (" ",
+ "",
+- g_strdup (icon),
+- NULL);
++ g_strdup (icon));
+ else
+ notify_notification_update (n,
+ " ",
+--- tests/test-withlib.c
++++ tests/test-withlib.c
+@@ -94,7 +94,7 @@
+
+ n = notify_notification_new ("Test",
+ "You should see a normal notification",
+- "", NULL);
++ "");
+ notify_notification_show (n, NULL);
+ sleep (3);
+
+@@ -109,7 +109,7 @@
+
+ n = notify_notification_new ("Test",
+ "New notification",
+- "", NULL);
++ "");
+ res = notify_notification_show (n, NULL);
+ g_assert (res);
+ sleep (1);
+@@ -135,7 +135,7 @@
+
+ n = notify_notification_new ("Image Test",
+ "You should see an image",
+- "", NULL);
++ "");
+ g_print ("iconpath: %s\n", SRCDIR"/icons/avatar.png");
+ pixbuf = gdk_pixbuf_new_from_file_at_scale (SRCDIR"/icons/avatar.png",
+ 64, 64, TRUE, NULL);
+@@ -157,22 +157,22 @@
+
+ n1 = notify_notification_new ("Dummy Notification",
+ "This is a test notification",
+- "", NULL);
++ "");
+ notify_notification_show (n1, NULL);
+ n2 = notify_notification_new ("Normal Notification",
+ "You should see this *after* the urgent notification.",
+- "", NULL);
++ "");
+ notify_notification_set_urgency (n2, NOTIFY_URGENCY_LOW);
+ notify_notification_show (n2, NULL);
+ n3 = notify_notification_new ("Synchronous Notification",
+ "You should immediately see this notification.",
+- "", NULL);
++ "");
+ notify_notification_set_hint_string (n3, "synchronous", "test");
+ notify_notification_set_urgency (n3, NOTIFY_URGENCY_NORMAL);
+ notify_notification_show (n3, NULL);
+ n4 = notify_notification_new ("Urgent Notification",
+ "You should see a dialog box, and after, a normal notification.",
+- "", NULL);
++ "");
+ notify_notification_set_urgency (n4, NOTIFY_URGENCY_CRITICAL);
+ notify_notification_show (n4, NULL);
+
+@@ -207,7 +207,7 @@
+
+ n1 = notify_notification_new ("Notification with an action",
+ "You should see that in a dialog box. Click the 'Action' button for the test to succeed.",
+- "", NULL);
++ "");
+ notify_notification_add_action (n1,
+ "action",
+ "Action",
+@@ -231,7 +231,7 @@
+
+ n = notify_notification_new ("Test Title",
+ "This notification will be closed prematurely...",
+- "", NULL);
++ "");
+ notify_notification_show (n, NULL);
+
+ loop = g_main_loop_new(NULL, FALSE);
+@@ -256,8 +256,7 @@
+ /* init notification, supply first line of body-text */
+ n = notify_notification_new ("Test (append-hint)",
+ "The quick brown fox jumps over the lazy dog.",
+- SRCDIR"/icons/avatar.png",
+- NULL);
++ SRCDIR"/icons/avatar.png");
+ res = notify_notification_show (n, NULL);
+ g_assert (res);
+ sleep (1);
+@@ -296,8 +295,7 @@
+ /* init notification, supply first line of body-text */
+ n = notify_notification_new (" ", /* needs this to be non-NULL */
+ NULL,
+- "notification-audio-play",
+- NULL);
++ "notification-audio-play");
+ notify_notification_set_hint_string (n, "icon-only", "allowed");
+ res = notify_notification_show (n, NULL);
+ g_assert (res);
+@@ -314,8 +312,7 @@
+
+ n = notify_notification_new ("Swallow markup test",
+ "This text is hopefully neither <b>bold</b>, <i>italic</i> nor <u>underlined</u>.\n\nA little math-notation:\n\n\ta &gt; b &lt; c = 0",
+- SRCDIR"/icons/avatar.png",
+- NULL);
++ SRCDIR"/icons/avatar.png");
+ res = notify_notification_show (n, NULL);
+ g_assert (res);
+ sleep (2);
+@@ -341,7 +338,7 @@
+
+ // create dummy notification
+ snprintf (buf, 19, "Test #%.2d", i);
+- n = notify_notification_new (buf, buf, "", NULL);
++ n = notify_notification_new (buf, buf, "");
+
+ // inject it into the queue
+ res = notify_notification_show (n, &error);
diff --git a/x11-misc/notify-osd/notify-osd-0.9.30.ebuild b/x11-misc/notify-osd/notify-osd-0.9.30.ebuild
index c72193c9d7e2..5fde95759de4 100644
--- a/x11-misc/notify-osd/notify-osd-0.9.30.ebuild
+++ b/x11-misc/notify-osd/notify-osd-0.9.30.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/notify-osd/notify-osd-0.9.30.ebuild,v 1.2 2011/03/21 22:37:03 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/notify-osd/notify-osd-0.9.30.ebuild,v 1.3 2011/03/27 21:56:25 ssuominen Exp $
EAPI=2
-inherit autotools gnome2-utils
+inherit autotools eutils gnome2-utils savedconfig
DESCRIPTION="Canonical's on-screen-display notification agent"
HOMEPAGE="http://launchpad.net/notify-osd"
@@ -12,32 +12,37 @@ SRC_URI="http://launchpad.net/${PN}/natty/natty-alpha3/+download/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="minimal"
-RDEPEND=">=dev-libs/dbus-glib-0.88
+COMMON_DEPEND=">=dev-libs/dbus-glib-0.88
>=dev-libs/glib-2.16:2
gnome-base/gconf:2
>=x11-libs/gtk+-2.22:2
- >=x11-libs/libnotify-0.4.5
+ >=x11-libs/libnotify-0.7
x11-libs/libwnck:1
x11-libs/libX11
x11-libs/pixman
!xfce-extra/xfce4-notifyd
!x11-misc/notification-daemon"
-DEPEND="${RDEPEND}
+RDEPEND="${COMMON_DEPEND}
+ !minimal? ( x11-themes/notify-osd-icons )"
+DEPEND="${COMMON_DEPEND}
dev-util/pkgconfig
x11-proto/xproto"
-RESTRICT="test" # Test suite is broken with libnotify-0.7 API
+RESTRICT="test" # virtualx.eclass: 1 of 1: FAIL: test-modules
src_prepare() {
- sed -i -e '/SUBDIRS/s:tests ::' Makefile.am || die # ditto
+ sed -i -e 's:noinst_PROG:check_PROG:' tests/Makefile.am || die
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+ use savedconfig && restore_config src/{bubble,defaults}.c
eautoreconf
}
src_install() {
emake DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog NEWS README TODO
+ save_config src/{bubble,defaults}.c
}
pkg_preinst() { gnome2_icon_savelist; }