summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Shakaryan <omp@gentoo.org>2008-04-24 08:55:04 +0000
committerDavid Shakaryan <omp@gentoo.org>2008-04-24 08:55:04 +0000
commit57f2c12ea88ca90c6913cddde8c7462c8d2e3931 (patch)
tree02baed6582be954fe7c5331b4f02a34673f50b07 /x11-misc/bbkeys
parentCompile with GCC 4.3; patch by Peter Alfredsen. (bug #218336) (diff)
downloadhistorical-57f2c12ea88ca90c6913cddde8c7462c8d2e3931.tar.gz
historical-57f2c12ea88ca90c6913cddde8c7462c8d2e3931.tar.bz2
historical-57f2c12ea88ca90c6913cddde8c7462c8d2e3931.zip
Compile with GCC 4.3; patch from Fedora. (bug #217980)
Package-Manager: portage-2.1.5_rc3
Diffstat (limited to 'x11-misc/bbkeys')
-rw-r--r--x11-misc/bbkeys/ChangeLog8
-rw-r--r--x11-misc/bbkeys/bbkeys-0.9.0-r1.ebuild15
-rw-r--r--x11-misc/bbkeys/files/bbkeys-0.9.0-gcc-4.3.patch59
3 files changed, 77 insertions, 5 deletions
diff --git a/x11-misc/bbkeys/ChangeLog b/x11-misc/bbkeys/ChangeLog
index 5c50dccd2ecd..619e22621bd0 100644
--- a/x11-misc/bbkeys/ChangeLog
+++ b/x11-misc/bbkeys/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/bbkeys
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbkeys/ChangeLog,v 1.23 2007/02/21 23:31:31 jokey Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbkeys/ChangeLog,v 1.24 2008/04/24 08:55:04 omp Exp $
+
+ 24 Apr 2008; David Shakaryan <omp@gentoo.org>
+ +files/bbkeys-0.9.0-gcc-4.3.patch, bbkeys-0.9.0-r1.ebuild:
+ Compile with GCC 4.3; patch from Fedora. (bug #217980)
21 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/x11-misc/bbkeys/bbkeys-0.9.0-r1.ebuild b/x11-misc/bbkeys/bbkeys-0.9.0-r1.ebuild
index 9c7da336204e..300e004c5a0a 100644
--- a/x11-misc/bbkeys/bbkeys-0.9.0-r1.ebuild
+++ b/x11-misc/bbkeys/bbkeys-0.9.0-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbkeys/bbkeys-0.9.0-r1.ebuild,v 1.3 2006/12/07 02:24:16 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbkeys/bbkeys-0.9.0-r1.ebuild,v 1.4 2008/04/24 08:55:04 omp Exp $
+
+inherit eutils
DESCRIPTION="Use keyboard shortcuts in the blackbox wm"
HOMEPAGE="http://bbkeys.sourceforge.net"
@@ -15,7 +17,14 @@ RDEPEND=">=x11-wm/blackbox-0.70.0"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-src_install () {
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-gcc-4.3.patch"
+}
+
+src_install() {
make DESTDIR="${D}" install || die "make install failed"
rm -rf "${D}/usr/share/doc"
dodoc AUTHORS BUGS ChangeLog NEWS README
diff --git a/x11-misc/bbkeys/files/bbkeys-0.9.0-gcc-4.3.patch b/x11-misc/bbkeys/files/bbkeys-0.9.0-gcc-4.3.patch
new file mode 100644
index 000000000000..58b536ff38e2
--- /dev/null
+++ b/x11-misc/bbkeys/files/bbkeys-0.9.0-gcc-4.3.patch
@@ -0,0 +1,59 @@
+diff -Naupr bbkeys-0.9.0.orig/src/actions.cc bbkeys-0.9.0/src/actions.cc
+--- bbkeys-0.9.0.orig/src/actions.cc 2005-02-20 22:03:43.000000000 +0100
++++ bbkeys-0.9.0/src/actions.cc 2008-02-24 09:26:30.000000000 +0100
+@@ -25,7 +25,8 @@
+ #include "actions.hh"
+
+ #include <iostream>
+-#include <string>
++#include <cstring>
++#include <cstdlib>
+ #include <sstream>
+
+ Action::Action(enum ActionType type, Display * display, KeyCode keycode,
+diff -Naupr bbkeys-0.9.0.orig/src/Config.cpp bbkeys-0.9.0/src/Config.cpp
+--- bbkeys-0.9.0.orig/src/Config.cpp 2004-09-03 03:08:00.000000000 +0200
++++ bbkeys-0.9.0/src/Config.cpp 2008-02-24 09:29:55.000000000 +0100
+@@ -24,7 +24,7 @@
+
+
+ #include "Config.h"
+-#include <string>
++#include <cstring>
+
+ #include <iostream>
+ using std::cout;
+diff -Naupr bbkeys-0.9.0.orig/src/KeyClient.cpp bbkeys-0.9.0/src/KeyClient.cpp
+--- bbkeys-0.9.0.orig/src/KeyClient.cpp 2004-09-26 04:27:46.000000000 +0200
++++ bbkeys-0.9.0/src/KeyClient.cpp 2008-02-24 09:26:14.000000000 +0100
+@@ -58,6 +58,7 @@ extern "C" {
+ #include <iostream>
+ #include <algorithm>
+ #include <vector>
++#include <cstring>
+
+ //--------------------------------------------------------
+ // Constructor/Destructor
+diff -Naupr bbkeys-0.9.0.orig/src/main.cpp bbkeys-0.9.0/src/main.cpp
+--- bbkeys-0.9.0.orig/src/main.cpp 2004-09-16 02:53:51.000000000 +0200
++++ bbkeys-0.9.0/src/main.cpp 2008-02-24 09:31:38.000000000 +0100
+@@ -27,6 +27,8 @@
+
+ #include "main.h"
+
++#include <cstring>
++
+ //--------------------------------------------------------
+ // parseOptions
+ //--------------------------------------------------------
+diff -Naupr bbkeys-0.9.0.orig/src/Netclient.cpp bbkeys-0.9.0/src/Netclient.cpp
+--- bbkeys-0.9.0.orig/src/Netclient.cpp 2004-09-26 04:27:46.000000000 +0200
++++ bbkeys-0.9.0/src/Netclient.cpp 2008-02-24 09:30:41.000000000 +0100
+@@ -25,6 +25,7 @@
+ // Methods, ideas, implementations taken from Openbox's XAtom class *sigh*
+
+ #include "Netclient.h"
++#include <cstring>
+
+ Netclient::Netclient (const bt::Display &display)
+ : bt::EWMH(display), _display(display)