summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2005-02-14 19:28:03 +0000
committerHeinrich Wendel <lanius@gentoo.org>2005-02-14 19:28:03 +0000
commitf76789643e1120b7d0ab6fd2ad2298efa393d634 (patch)
tree016921b1db17da30af7f50e3135dd6fdc4cf4c02 /x11-libs
parentprofile stuff (diff)
downloadhistorical-f76789643e1120b7d0ab6fd2ad2298efa393d634.tar.gz
historical-f76789643e1120b7d0ab6fd2ad2298efa393d634.tar.bz2
historical-f76789643e1120b7d0ab6fd2ad2298efa393d634.zip
more virtual stuff
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/openmotif/openmotif-2.1.30-r7.ebuild12
-rw-r--r--x11-libs/openmotif/openmotif-2.2.3-r1.ebuild13
2 files changed, 13 insertions, 12 deletions
diff --git a/x11-libs/openmotif/openmotif-2.1.30-r7.ebuild b/x11-libs/openmotif/openmotif-2.1.30-r7.ebuild
index 9c08e7dc8cc1..46cd449ebc72 100644
--- a/x11-libs/openmotif/openmotif-2.1.30-r7.ebuild
+++ b/x11-libs/openmotif/openmotif-2.1.30-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.1.30-r7.ebuild,v 1.5 2005/02/14 19:15:12 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.1.30-r7.ebuild,v 1.6 2005/02/14 19:28:03 lanius Exp $
inherit eutils flag-o-matic multilib
@@ -153,11 +153,13 @@ src_install() {
dodoc README COPYRIGHT.MOTIF RELEASE RELNOTES
dodoc BUGREPORT OPENBUGS CLOSEDBUGS
-
- # install profile
- echo "$P" > ${D}/usr/lib/motif/openmotif-2.1
}
+# Profile stuff
pkg_postinst() {
- motif-config openmotif-2.1
+ motif-config --install openmotif-2.1
+}
+
+pkg_postrm() {
+ motif-config --uninstall openmotif-2.1
}
diff --git a/x11-libs/openmotif/openmotif-2.2.3-r1.ebuild b/x11-libs/openmotif/openmotif-2.2.3-r1.ebuild
index 8d64184c0665..d1534eca07c4 100644
--- a/x11-libs/openmotif/openmotif-2.2.3-r1.ebuild
+++ b/x11-libs/openmotif/openmotif-2.2.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.2.3-r1.ebuild,v 1.2 2005/02/14 19:15:12 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/openmotif/openmotif-2.2.3-r1.ebuild,v 1.3 2005/02/14 19:28:03 lanius Exp $
inherit eutils libtool flag-o-matic multilib
@@ -129,14 +129,13 @@ src_install() {
dodoc COPYRIGHT.MOTIF LICENSE
dodoc README RELEASE RELNOTES
dodoc BUGREPORT TODO
-
- # install profile
- echo "$P" > ${D}/usr/lib/motif/openmotif-2.2
}
+# Profile stuff
pkg_postinst() {
- motif-config openmotif-2.2
+ motif-config --install openmotif-2.2
+}
- ewarn "This breaks applications linked against libXm.so.2."
- ewarn "You have to rebuild these applications with revdep-rebuild."
+pkg_postrm() {
+ motif-config --uninstall openmotif-2.2
}