summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Fitzpatrick <leahcim@gentoo.org>2003-04-25 14:01:27 +0000
committerMichael Fitzpatrick <leahcim@gentoo.org>2003-04-25 14:01:27 +0000
commitde26a390159de76a4a7c23fceaf77054b95f8723 (patch)
tree2cbab38f24825b98d54800d2db0abca70b25691a /x11-libs
parentBugfixes from upstream, marked unstable on all arches (diff)
downloadhistorical-de26a390159de76a4a7c23fceaf77054b95f8723.tar.gz
historical-de26a390159de76a4a7c23fceaf77054b95f8723.tar.bz2
historical-de26a390159de76a4a7c23fceaf77054b95f8723.zip
Fix bug #19894
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/fltk/ChangeLog6
-rw-r--r--x11-libs/fltk/files/digest-fltk-1.1.2-r21
-rw-r--r--x11-libs/fltk/fltk-1.1.2-r2.ebuild74
3 files changed, 80 insertions, 1 deletions
diff --git a/x11-libs/fltk/ChangeLog b/x11-libs/fltk/ChangeLog
index c23b93acd0e5..5364975cf6b4 100644
--- a/x11-libs/fltk/ChangeLog
+++ b/x11-libs/fltk/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for x11-libs/fltk
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/ChangeLog,v 1.20 2003/03/31 02:45:54 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/ChangeLog,v 1.21 2003/04/25 14:01:27 leahcim Exp $
*fltk-1.1.2-r1 (09 Jan 2003)
+ 25 Apr 2003; Michael Fitzpatrick <leahcim@gentoo.org> fltk-1.1.2-r2.ebuild,
+ files/digest-fltk-1.1.2-r2 :
+ fix freetype2 header problem, bug #19894.
+
31 Mar 2003; Alastair Tse <liquidx@gentoo.org> fltk-1.1.2-r1.ebuild:
fix linking problem with libs. fixes #15572, #17894.
diff --git a/x11-libs/fltk/files/digest-fltk-1.1.2-r2 b/x11-libs/fltk/files/digest-fltk-1.1.2-r2
new file mode 100644
index 000000000000..c400d598c94b
--- /dev/null
+++ b/x11-libs/fltk/files/digest-fltk-1.1.2-r2
@@ -0,0 +1 @@
+MD5 5d3e96f253c737332cb6d45b6d7d9384 fltk-1.1.2-source.tar.bz2 1287828
diff --git a/x11-libs/fltk/fltk-1.1.2-r2.ebuild b/x11-libs/fltk/fltk-1.1.2-r2.ebuild
new file mode 100644
index 000000000000..8eaffab3b88f
--- /dev/null
+++ b/x11-libs/fltk/fltk-1.1.2-r2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-1.1.2-r2.ebuild,v 1.1 2003/04/25 14:01:27 leahcim Exp $
+
+inherit eutils
+
+DESCRIPTION="C++ user interface toolkit for X and OpenGL."
+HOMEPAGE="http://www.fltk.org"
+SRC_URI="ftp://ftp.easysw.com/pub/fltk/${PV}/${P}-source.tar.bz2"
+
+SLOT="1.1"
+KEYWORDS="x86 ppc sparc"
+LICENSE="FLTK | GPL-2"
+IUSE="opengl"
+
+DEPEND="virtual/x11
+ media-libs/libpng
+ media-libs/jpeg
+ opengl? ( virtual/opengl )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/libs.diff || die "patch failed"
+}
+
+src_compile() {
+ local myconf
+ myconf="--enable-shared --enable-static --enable-threads \
+ --enable-xdbe"
+
+ # If you still have problems and you just uninstalled
+ # xft and didn't re-install xfree to get the right headers
+ # back the xft enabled build still wont work. :) I hope to fix
+ # this eventually but for the 1.4 release...
+ if [ -d ${ROOT}var/db/pkg/x11-libs/xft* ]; then
+ myconf="${myconf} --disable-xft"
+ else
+ myconf="${myconf} --enable-xft"
+ # bug #19894
+ export C_INCLUDE_PATH="${C_INCLUDE_PATH}:/usr/include/freetype2"
+ export CPLUS_INCLUDE_PATH="${CPLUS_INCLUDE_PATH}:/usr/include/freetype2"
+ fi
+
+ use opengl || myconf="${myconf} --disable-gl"
+
+ # needed for glibc-2.3.1 (as far as i can test)
+ # otherwise libstdc++ won't be linked. #17894 and #15572
+ # doesn't happen for glibc-2.3.2 - <liquidx@gentoo.org>
+ export CXX="g++"
+ export CC="g++"
+
+ econf \
+ --includedir=/usr/include/fltk-1.1 \
+ --libdir=/usr/lib/fltk-1.1 \
+ ${myconf} || die "Configuration Failed"
+
+ emake || die "Parallel Make Failed"
+}
+
+src_install() {
+ einstall \
+ includedir=${D}/usr/include/fltk-1.1 \
+ libdir=${D}/usr/lib/fltk-1.1 || die "Installation Failed"
+
+ ranlib ${D}/usr/lib/fltk-1.1/*.a
+
+ dodoc CHANGES COPYING README
+
+ echo "LDPATH=/usr/lib/fltk-1.1" > 99fltk-1.1
+
+ insinto /etc/env.d
+ doins 99fltk-1.1
+}