summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2003-04-15 10:52:14 +0000
committerDan Armak <danarmak@gentoo.org>2003-04-15 10:52:14 +0000
commitae106e850b2800beac17a0f8fe0301472c447707 (patch)
treeefa3ff48bce136815e8b205308eaafc8c4271a30 /x11-libs
parentmasked new revision that uses custom CXXFLAGS (diff)
downloadhistorical-ae106e850b2800beac17a0f8fe0301472c447707.tar.gz
historical-ae106e850b2800beac17a0f8fe0301472c447707.tar.bz2
historical-ae106e850b2800beac17a0f8fe0301472c447707.zip
masked new revision that uses custom CXXFLAGS
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt/Manifest4
-rw-r--r--x11-libs/qt/files/digest-qt-3.1.2-r21
-rw-r--r--x11-libs/qt/qt-3.1.2-r2.ebuild205
3 files changed, 208 insertions, 2 deletions
diff --git a/x11-libs/qt/Manifest b/x11-libs/qt/Manifest
index ae81762121f7..25b143fcdba5 100644
--- a/x11-libs/qt/Manifest
+++ b/x11-libs/qt/Manifest
@@ -6,12 +6,12 @@ MD5 a8ec069d250a965a7c5708a2277eba72 qt-2.3.2-r1.ebuild 2289
MD5 3cb12694a0de9edc2f6cd1f029150dc1 qt-3.0.5.ebuild 3547
MD5 314c70433868712299daaf43019bbfbc qt-3.1.0-r1.ebuild 4385
MD5 7574a34ccd181870ea18bf3145310e37 qt-3.0.5-r2.ebuild 3975
-MD5 7684617c798b7c27567b1255a93f8cb1 qt-3.1.2-r2.ebuild 5733
+MD5 19d6f70e784f82a66517bd7feb9e35f7 qt-3.1.2-r2.ebuild 5733
MD5 967214749164332a1f541ec94301c121 qt-3.1.0.ebuild 4155
MD5 3460c684ba5ed6273d81f6c520e204b7 qt-3.1.0-r3.ebuild 4840
MD5 975f7053e5e945e6e509206242c7cfab qt-3.1.2.ebuild 5375
MD5 66b942151418494936c3b73e01e37d68 qt-3.1.1-r2.ebuild 4659
-MD5 4eacd9bf3dddf4200b3eca445bf75ce5 ChangeLog 10069
+MD5 624246a731f6a45ee6c91074690e92f2 ChangeLog 10338
MD5 7d96c0cc105d4d61b811bf8ad9210b65 qt-3.0.5-r1.ebuild 3464
MD5 2d5b68b38185a30a28ffb2b652258cb8 files/45qt3 83
MD5 7a287bc7609ad2420f70af6d4c58302f files/50qt2 63
diff --git a/x11-libs/qt/files/digest-qt-3.1.2-r2 b/x11-libs/qt/files/digest-qt-3.1.2-r2
new file mode 100644
index 000000000000..adcf5a71e37e
--- /dev/null
+++ b/x11-libs/qt/files/digest-qt-3.1.2-r2
@@ -0,0 +1 @@
+MD5 156591717687799c69cf3f8b64a898f2 qt-x11-free-3.1.2.tar.bz2 13358932
diff --git a/x11-libs/qt/qt-3.1.2-r2.ebuild b/x11-libs/qt/qt-3.1.2-r2.ebuild
new file mode 100644
index 000000000000..be48ddfab35f
--- /dev/null
+++ b/x11-libs/qt/qt-3.1.2-r2.ebuild
@@ -0,0 +1,205 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-3.1.2-r2.ebuild,v 1.1 2003/04/15 10:51:51 danarmak Exp $
+
+inherit eutils
+
+IUSE="cups nas postgres opengl mysql odbc gif"
+
+S=${WORKDIR}/qt-x11-free-${PV}
+
+DESCRIPTION="QT version ${PV}"
+SLOT="3"
+LICENSE="QPL-1.0"
+
+# WARNING: do not give this ebuild keywords that >=kdelibs-3.1.1, >=kdebase-3.1.1-r1 don't have
+KEYWORDS="~x86 ~ppc ~sparc" # alpha removed temporarily as I wasn't sure about the special
+ # alpha stuff in src_unpack; alpha ppl please readd. --danarmak
+
+SRC_URI="ftp://ftp.trolltech.com/qt/source/qt-x11-free-${PV}.tar.bz2"
+
+HOMEPAGE="http://www.trolltech.com/"
+
+DEPEND="virtual/x11
+ media-libs/libpng
+ media-libs/lcms
+ media-libs/jpeg
+ >=media-libs/libmng-1.0.0
+ >=media-libs/freetype-2
+ virtual/xft
+ nas? ( >=media-libs/nas-1.4.1 )
+ odbc? ( >=dev-db/unixODBC-2.0 )
+ mysql? ( >=dev-db/mysql-3.2.10 )
+ opengl? ( virtual/opengl virtual/glu )
+ postgres? ( >=dev-db/postgresql-7.2 )
+ !=kde-base/kdelibs-3.1
+ !=kde-base/kdelibs-3.1-r1
+ !=kde-base/kdelibs-3.1-r2
+ !=kde-base/kdelibs-3.1-r3
+ !=kde-base/kdebase-3.1
+ !=kde-base/kdebase-3.1-r1
+ !=kde-base/kdebase-3.1.1"
+# WARNING: the versions blocked above are known to be buggy. DO NOT use them with this qt
+
+RDEPEND="$DEPEND
+ doc? ( ~app-doc/qt-docs-$PV )"
+
+QTBASE=/usr/qt/3
+export QTDIR=${S}
+
+src_unpack() {
+
+ export QTDIR=${S}
+
+ unpack ${A}
+
+ cd ${S}
+
+ epatch ${FILESDIR}/designer.diff
+ epatch ${FILESDIR}/${P}-qmlined.diff
+ epatch ${FILESDIR}/qsocket-3.1.2.diff
+
+ cp configure configure.orig
+ sed -e 's:read acceptance:acceptance=yes:' configure.orig > configure
+
+ cd mkspecs/linux-g++
+ # use env's $CC, $CXX
+ if [ -n "$CXX" ]; then
+ einfo 'Using environment definition of $CXX'
+ cp qmake.conf qmake.conf.orig
+ sed -e "s:= g++:= ${CXX}:" qmake.conf.orig > qmake.conf
+ fi
+ if [ -n "$CC" ]; then
+ einfo 'Using environment definition of $CC'
+ cp qmake.conf qmake.conf.orig
+ sed -e "s:= gcc:= ${CC}:" qmake.conf.orig > qmake.conf
+ fi
+
+ # hppa and alpha people, please review the following
+
+ # hppa need some additional flags
+ if [ "${ARCH}" = "hppa" ]; then
+ echo "QMAKE_CFLAGS += -fPIC -ffunction-sections" >> qmake.conf
+ echo "QMAKE_CXXFLAGS += -fPIC -ffunction-sections" >> qmake.conf
+ echo "QMAKE_LFLAGS += -ffunction-sections -Wl,--stub-group-size=25000" >> qmake.conf
+ fi
+
+ # on alpha we need to compile everything with -fPIC
+ if [ ${ARCH} == "alpha" ]; then
+ cp qmake.conf qmake.conf.orig
+ sed -e "s:= -O2:= -O2 -fPIC:" qmake.conf.orig > qmake.conf
+ cat >> ${S}/tools/designer/editor/editor.pro <<_EOF_
+QMAKE_CFLAGS += -fPIC
+QMAKE_CXXFLAGS += -fPIC
+_EOF_
+ fi
+
+ # use our CFLAGS
+ cp qmake.conf qmake.conf.no-cxxflags
+ sed -e "s:= -O2:= ${CXXFLAGS}:" qmake.conf.orig > qmake.conf
+
+}
+
+src_compile() {
+
+ # fix #11144; qt wants to create lock files etc. in that directory
+ [ -d "$QTBASE/etc/settings" ] && addwrite "$QTBASE/etc/settings"
+
+ export QTDIR=${S}
+
+ export LDFLAGS="-ldl"
+
+ use cups || myconf="${myconf} -no-cups"
+ use nas && myconf="${myconf} -system-nas-sound"
+ use gif && myconf="${myconf} -qt-gif"
+ use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/lib/mysql"
+ use postgres && myconf="${myconf} -plugin-sql-psql -I/usr/include/postgresql/server"
+ use odbc && myconf="${myconf} -plugin-sql-odbc"
+ use opengl && myconf="${myconf} -enable-module=opengl" || myconf="${myconf} -disable-opengl"
+ [ -n "$DEBUG" ] && myconf="${myconf} -debug" || myconf="${myconf} -release -no-g++-exceptions"
+
+ # avoid wasting time building things we won't install
+ rm -rf tutorial examples
+
+ export YACC='byacc -d'
+
+ ./configure -sm -thread -stl -system-zlib -system-libjpeg -verbose \
+ -qt-imgfmt-{jpeg,mng,png} -tablet -system-libmng \
+ -system-libpng -ldl -lpthread -xft -platform linux-g++ -xplatform \
+ linux-g++ -xrender -prefix ${QTBASE} -fast ${myconf} || die
+
+ export QTDIR=${S}
+
+ emake src-qmake src-moc sub-src sub-tools || die
+
+}
+
+src_install() {
+
+ export QTDIR=${S}
+
+ cd ${S}
+
+ # binaries
+ into $QTBASE
+ dobin bin/*
+
+ # libraries
+ dolib lib/libqt-mt.so.3.1.2 lib/libqui.so.1.0.0 lib/lib{editor,qassistantclient,designer}.a
+ cd ${D}$QTBASE/lib
+ for x in libqui.so
+ do
+ ln -s $x.1.0.0 $x.1.0
+ ln -s $x.1.0 $x.1
+ ln -s $x.1 $x
+ done
+
+ # version symlinks - 3.1.2->3.1->3->.so
+ ln -s libqt-mt.so.3.1.2 libqt-mt.so.3.1
+ ln -s libqt-mt.so.3.1 libqt-mt.so.3
+ ln -s libqt-mt.so.3 libqt-mt.so
+
+ # libqt -> libqt-mt symlinks
+ ln -s libqt-mt.so.3.1.2 libqt.so.3.1.2
+ ln -s libqt-mt.so.3.1 libqt.so.3.1
+ ln -s libqt-mt.so.3 libqt.so.3
+ ln -s libqt-mt.so libqt.so
+
+ # includes
+ cd ${S}
+ dodir ${QTBASE}/include/private
+ cp include/* ${D}/${QTBASE}/include/
+ cp include/private/* ${D}/${QTBASE}/include/private/
+
+ # misc
+ insinto /etc/env.d
+ doins ${FILESDIR}/{45qt3,50qtdir3}
+
+ # misc build reqs
+ dodir ${QTBASE}/mkspecs
+ cp -R ${S}/mkspecs/linux-g++ ${D}/${QTBASE}/mkspecs/
+ # we don't want all qt apps to use the CXxFLAGS we had here
+ cd ${D}/${QTBASE}/mkspecs/linux-g++
+ mv -f qmake.conf.no-cxxflags qmake.conf
+
+ sed -e "s:${S}:${QTBASE}:g" \
+ ${S}/.qmake.cache > ${D}${QTBASE}/.qmake.cache
+
+ # plugins
+ cd ${S}
+ plugins=`find plugins -name "lib*.so" -print`
+ for x in $plugins; do
+ insinto ${QTBASE}/`dirname $x`
+ doins $x
+ done
+
+}
+pkg_postinst() {
+
+ ewarn "If you upgraded from QT 3.0.x to 3.1.x, you should remerge any copies"
+ ewarn "of kdelibs you have installed. Otherwise, other kde packages may not"
+ ewarn "compile properly. If you upgraded QT from 3.0.x to 3.1.x in the past"
+ ewarn "but have not remerged kdelib, since then, you should proobably do so now."
+
+}
+