summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Kapusta <ayoy@gentoo.org>2009-10-29 18:30:13 +0000
committerDominik Kapusta <ayoy@gentoo.org>2009-10-29 18:30:13 +0000
commit2874ed6bd25a25e3d8a2686a47bfff8e195df4b6 (patch)
tree27f17d9a1808922ce4685337bacb128612e190c6 /x11-libs
parentProxy commit for chiiph, add him and myself to metadata.xml (diff)
downloadhistorical-2874ed6bd25a25e3d8a2686a47bfff8e195df4b6.tar.gz
historical-2874ed6bd25a25e3d8a2686a47bfff8e195df4b6.tar.bz2
historical-2874ed6bd25a25e3d8a2686a47bfff8e195df4b6.zip
Adding a patch to fix regression in event loop
Package-Manager: portage-2.2_rc46/cvs/Linux x86_64
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-opengl/ChangeLog8
-rw-r--r--x11-libs/qt-opengl/files/qt-4.5.3-glib-event-loop.patch11
-rw-r--r--x11-libs/qt-opengl/qt-opengl-4.5.3-r1.ebuild48
-rw-r--r--x11-libs/qt-script/ChangeLog8
-rw-r--r--x11-libs/qt-script/files/qt-4.5.3-glib-event-loop.patch11
-rw-r--r--x11-libs/qt-script/qt-script-4.5.3-r1.ebuild36
-rw-r--r--x11-libs/qt-svg/ChangeLog8
-rw-r--r--x11-libs/qt-svg/files/qt-4.5.3-glib-event-loop.patch11
-rw-r--r--x11-libs/qt-svg/qt-svg-4.5.3-r1.ebuild47
-rw-r--r--x11-libs/qt-test/ChangeLog8
-rw-r--r--x11-libs/qt-test/files/qt-4.5.3-glib-event-loop.patch11
-rw-r--r--x11-libs/qt-test/qt-test-4.5.3-r1.ebuild35
-rw-r--r--x11-libs/qt-xmlpatterns/ChangeLog8
-rw-r--r--x11-libs/qt-xmlpatterns/files/qt-4.5.3-glib-event-loop.patch11
-rw-r--r--x11-libs/qt-xmlpatterns/qt-xmlpatterns-4.5.3-r1.ebuild35
15 files changed, 291 insertions, 5 deletions
diff --git a/x11-libs/qt-opengl/ChangeLog b/x11-libs/qt-opengl/ChangeLog
index b53b3f31bc89..f12bf5316dfa 100644
--- a/x11-libs/qt-opengl/ChangeLog
+++ b/x11-libs/qt-opengl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-opengl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/ChangeLog,v 1.44 2009/10/29 15:14:26 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/ChangeLog,v 1.45 2009/10/29 18:17:27 ayoy Exp $
+
+*qt-opengl-4.5.3-r1 (29 Oct 2009)
+
+ 29 Oct 2009; Dominik Kapusta <ayoy@gentoo.org> +qt-opengl-4.5.3-r1.ebuild,
+ +files/qt-4.5.3-glib-event-loop.patch:
+ Adding a patch to fix regression in event loop
29 Oct 2009; Tomáš Chvátal <scarabeus@gentoo.org>
qt-opengl-4.5.3.ebuild:
diff --git a/x11-libs/qt-opengl/files/qt-4.5.3-glib-event-loop.patch b/x11-libs/qt-opengl/files/qt-4.5.3-glib-event-loop.patch
new file mode 100644
index 000000000000..580f027a5471
--- /dev/null
+++ b/x11-libs/qt-opengl/files/qt-4.5.3-glib-event-loop.patch
@@ -0,0 +1,11 @@
+diff -up qt-x11-opensource-src-4.5.3/src/corelib/kernel/qeventdispatcher_glib.cpp.than qt-x11-opensource-src-4.5.3/src/corelib/kernel/qeventdispatcher_glib.cpp
+--- qt-x11-opensource-src-4.5.3/src/corelib/kernel/qeventdispatcher_glib.cpp.than 2009-10-29 16:15:58.000000000 +0100
++++ qt-x11-opensource-src-4.5.3/src/corelib/kernel/qeventdispatcher_glib.cpp 2009-10-29 16:16:22.000000000 +0100
+@@ -263,7 +263,6 @@ QEventDispatcherGlibPrivate::QEventDispa
+ (void) new (&timerSource->timerList) QTimerInfoList();
+ timerSource->processEventsFlags = QEventLoop::AllEvents;
+ g_source_set_can_recurse(&timerSource->source, true);
+- g_source_set_priority(&timerSource->source, G_PRIORITY_DEFAULT_IDLE);
+ g_source_attach(&timerSource->source, mainContext);
+ }
+
diff --git a/x11-libs/qt-opengl/qt-opengl-4.5.3-r1.ebuild b/x11-libs/qt-opengl/qt-opengl-4.5.3-r1.ebuild
new file mode 100644
index 000000000000..14818204b4a4
--- /dev/null
+++ b/x11-libs/qt-opengl/qt-opengl-4.5.3-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-opengl/qt-opengl-4.5.3-r1.ebuild,v 1.1 2009/10/29 18:17:27 ayoy Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The OpenGL module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="qt3support"
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=,qt3support=]
+ ~x11-libs/qt-gui-${PV}[debug=,qt3support=]
+ virtual/opengl
+ virtual/glu"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="
+src/opengl
+src/plugins/graphicssystems/opengl"
+
+QT4_EXTRACT_DIRECTORIES="
+include/QtCore
+include/QtGui
+include/QtOpenGL
+src/corelib
+src/gui
+src/opengl
+src/plugins
+src/3rdparty"
+
+QCONFIG_ADD="opengl"
+QCONFIG_DEFINE="QT_OPENGL"
+
+PATCHES=(
+ "${FILESDIR}/qt-${PV}-glib-event-loop.patch"
+)
+
+src_configure() {
+ myconf="${myconf} -opengl
+ $(qt_use qt3support)"
+
+ qt4-build_src_configure
+
+ # Not building tools/designer/src/plugins/tools/view3d as it's
+ # commented out of the build in the source
+}
diff --git a/x11-libs/qt-script/ChangeLog b/x11-libs/qt-script/ChangeLog
index 32418c64f785..fa2161fa8a5a 100644
--- a/x11-libs/qt-script/ChangeLog
+++ b/x11-libs/qt-script/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-script
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.45 2009/10/29 11:25:02 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.46 2009/10/29 18:20:08 ayoy Exp $
+
+*qt-script-4.5.3-r1 (29 Oct 2009)
+
+ 29 Oct 2009; Dominik Kapusta <ayoy@gentoo.org> +qt-script-4.5.3-r1.ebuild,
+ +files/qt-4.5.3-glib-event-loop.patch:
+ Adding a patch to fix regression in event loop
29 Oct 2009; Christian Faulhammer <fauli@gentoo.org>
qt-script-4.5.3.ebuild:
diff --git a/x11-libs/qt-script/files/qt-4.5.3-glib-event-loop.patch b/x11-libs/qt-script/files/qt-4.5.3-glib-event-loop.patch
new file mode 100644
index 000000000000..580f027a5471
--- /dev/null
+++ b/x11-libs/qt-script/files/qt-4.5.3-glib-event-loop.patch
@@ -0,0 +1,11 @@
+diff -up qt-x11-opensource-src-4.5.3/src/corelib/kernel/qeventdispatcher_glib.cpp.than qt-x11-opensource-src-4.5.3/src/corelib/kernel/qeventdispatcher_glib.cpp
+--- qt-x11-opensource-src-4.5.3/src/corelib/kernel/qeventdispatcher_glib.cpp.than 2009-10-29 16:15:58.000000000 +0100
++++ qt-x11-opensource-src-4.5.3/src/corelib/kernel/qeventdispatcher_glib.cpp 2009-10-29 16:16:22.000000000 +0100
+@@ -263,7 +263,6 @@ QEventDispatcherGlibPrivate::QEventDispa
+ (void) new (&timerSource->timerList) QTimerInfoList();
+ timerSource->processEventsFlags = QEventLoop::AllEvents;
+ g_source_set_can_recurse(&timerSource->source, true);
+- g_source_set_priority(&timerSource->source, G_PRIORITY_DEFAULT_IDLE);
+ g_source_attach(&timerSource->source, mainContext);
+ }
+
diff --git a/x11-libs/qt-script/qt-script-4.5.3-r1.ebuild b/x11-libs/qt-script/qt-script-4.5.3-r1.ebuild
new file mode 100644
index 000000000000..733e72aed240
--- /dev/null
+++ b/x11-libs/qt-script/qt-script-4.5.3-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/qt-script-4.5.3-r1.ebuild,v 1.1 2009/10/29 18:20:08 ayoy Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The ECMAScript module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="iconv"
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=]"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/script/"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/Qt/
+include/QtCore/
+include/QtScript/
+src/corelib/"
+
+PATCHES=(
+ "${FILESDIR}/qt-4.5-nolibx11.diff"
+ "${FILESDIR}/qt-${PV}-glib-event-loop.patch"
+)
+
+src_configure() {
+ myconf="${myconf} $(qt_use iconv) -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-glib -no-opengl -no-svg -no-gtkstyle"
+ qt4-build_src_configure
+}
diff --git a/x11-libs/qt-svg/ChangeLog b/x11-libs/qt-svg/ChangeLog
index 0975d6551eb7..be52d33a81ec 100644
--- a/x11-libs/qt-svg/ChangeLog
+++ b/x11-libs/qt-svg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-svg
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.44 2009/10/29 11:44:34 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.45 2009/10/29 18:25:02 ayoy Exp $
+
+*qt-svg-4.5.3-r1 (29 Oct 2009)
+
+ 29 Oct 2009; Dominik Kapusta <ayoy@gentoo.org> +qt-svg-4.5.3-r1.ebuild,
+ +files/qt-4.5.3-glib-event-loop.patch:
+ Adding a patch to fix regression in event loop
29 Oct 2009; Christian Faulhammer <fauli@gentoo.org> qt-svg-4.5.3.ebuild:
stable x86, bug 290922
diff --git a/x11-libs/qt-svg/files/qt-4.5.3-glib-event-loop.patch b/x11-libs/qt-svg/files/qt-4.5.3-glib-event-loop.patch
new file mode 100644
index 000000000000..580f027a5471
--- /dev/null
+++ b/x11-libs/qt-svg/files/qt-4.5.3-glib-event-loop.patch
@@ -0,0 +1,11 @@
+diff -up qt-x11-opensource-src-4.5.3/src/corelib/kernel/qeventdispatcher_glib.cpp.than qt-x11-opensource-src-4.5.3/src/corelib/kernel/qeventdispatcher_glib.cpp
+--- qt-x11-opensource-src-4.5.3/src/corelib/kernel/qeventdispatcher_glib.cpp.than 2009-10-29 16:15:58.000000000 +0100
++++ qt-x11-opensource-src-4.5.3/src/corelib/kernel/qeventdispatcher_glib.cpp 2009-10-29 16:16:22.000000000 +0100
+@@ -263,7 +263,6 @@ QEventDispatcherGlibPrivate::QEventDispa
+ (void) new (&timerSource->timerList) QTimerInfoList();
+ timerSource->processEventsFlags = QEventLoop::AllEvents;
+ g_source_set_can_recurse(&timerSource->source, true);
+- g_source_set_priority(&timerSource->source, G_PRIORITY_DEFAULT_IDLE);
+ g_source_attach(&timerSource->source, mainContext);
+ }
+
diff --git a/x11-libs/qt-svg/qt-svg-4.5.3-r1.ebuild b/x11-libs/qt-svg/qt-svg-4.5.3-r1.ebuild
new file mode 100644
index 000000000000..eb0defd90e6d
--- /dev/null
+++ b/x11-libs/qt-svg/qt-svg-4.5.3-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/qt-svg-4.5.3-r1.ebuild,v 1.1 2009/10/29 18:25:02 ayoy Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The SVG module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="iconv"
+
+DEPEND="~x11-libs/qt-gui-${PV}[debug=]"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="
+src/svg
+src/plugins/imageformats/svg
+src/plugins/iconengines/svgiconengine"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/QtSvg/
+include/Qt/
+include/QtGui/
+include/QtCore/
+include/QtXml/
+src/corelib/
+src/gui/
+src/plugins/
+src/xml
+src/3rdparty"
+
+QCONFIG_ADD="svg"
+QCONFIG_DEFINE="QT_SVG"
+
+PATCHES=(
+ "${FILESDIR}/qt-${PV}-glib-event-loop.patch"
+)
+
+src_configure() {
+ myconf="${myconf} $(qt_use iconv) -svg -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -v -no-fontconfig -no-glib -no-opengl -no-gtkstyle -continue"
+ qt4-build_src_configure
+}
diff --git a/x11-libs/qt-test/ChangeLog b/x11-libs/qt-test/ChangeLog
index 37312e92c535..c2b1a7c753c0 100644
--- a/x11-libs/qt-test/ChangeLog
+++ b/x11-libs/qt-test/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-test
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/ChangeLog,v 1.43 2009/10/29 11:27:05 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/ChangeLog,v 1.44 2009/10/29 18:27:23 ayoy Exp $
+
+*qt-test-4.5.3-r1 (29 Oct 2009)
+
+ 29 Oct 2009; Dominik Kapusta <ayoy@gentoo.org> +qt-test-4.5.3-r1.ebuild,
+ +files/qt-4.5.3-glib-event-loop.patch:
+ Adding a patch to fix regression in event loop
29 Oct 2009; Christian Faulhammer <fauli@gentoo.org> qt-test-4.5.3.ebuild:
stable x86, bug 290922
diff --git a/x11-libs/qt-test/files/qt-4.5.3-glib-event-loop.patch b/x11-libs/qt-test/files/qt-4.5.3-glib-event-loop.patch
new file mode 100644
index 000000000000..580f027a5471
--- /dev/null
+++ b/x11-libs/qt-test/files/qt-4.5.3-glib-event-loop.patch
@@ -0,0 +1,11 @@
+diff -up qt-x11-opensource-src-4.5.3/src/corelib/kernel/qeventdispatcher_glib.cpp.than qt-x11-opensource-src-4.5.3/src/corelib/kernel/qeventdispatcher_glib.cpp
+--- qt-x11-opensource-src-4.5.3/src/corelib/kernel/qeventdispatcher_glib.cpp.than 2009-10-29 16:15:58.000000000 +0100
++++ qt-x11-opensource-src-4.5.3/src/corelib/kernel/qeventdispatcher_glib.cpp 2009-10-29 16:16:22.000000000 +0100
+@@ -263,7 +263,6 @@ QEventDispatcherGlibPrivate::QEventDispa
+ (void) new (&timerSource->timerList) QTimerInfoList();
+ timerSource->processEventsFlags = QEventLoop::AllEvents;
+ g_source_set_can_recurse(&timerSource->source, true);
+- g_source_set_priority(&timerSource->source, G_PRIORITY_DEFAULT_IDLE);
+ g_source_attach(&timerSource->source, mainContext);
+ }
+
diff --git a/x11-libs/qt-test/qt-test-4.5.3-r1.ebuild b/x11-libs/qt-test/qt-test-4.5.3-r1.ebuild
new file mode 100644
index 000000000000..f6196dea753e
--- /dev/null
+++ b/x11-libs/qt-test/qt-test-4.5.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-test/qt-test-4.5.3-r1.ebuild,v 1.1 2009/10/29 18:27:23 ayoy Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The testing framework module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="iconv"
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=]"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/testlib"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/QtTest/
+include/QtCore/
+src/corelib/"
+
+PATCHES=(
+ "${FILESDIR}/qt-4.5-nolibx11.diff"
+ "${FILESDIR}/qt-${PV}-glib-event-loop.patch"
+)
+
+src_configure() {
+ myconf="${myconf} $(qt_use iconv) -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-glib -no-opengl -no-svg"
+ qt4-build_src_configure
+}
diff --git a/x11-libs/qt-xmlpatterns/ChangeLog b/x11-libs/qt-xmlpatterns/ChangeLog
index 053e1ca2fcc1..7c65af39bc76 100644
--- a/x11-libs/qt-xmlpatterns/ChangeLog
+++ b/x11-libs/qt-xmlpatterns/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-xmlpatterns
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-xmlpatterns/ChangeLog,v 1.42 2009/10/29 11:29:08 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-xmlpatterns/ChangeLog,v 1.43 2009/10/29 18:30:13 ayoy Exp $
+
+*qt-xmlpatterns-4.5.3-r1 (29 Oct 2009)
+
+ 29 Oct 2009; Dominik Kapusta <ayoy@gentoo.org>
+ +qt-xmlpatterns-4.5.3-r1.ebuild, +files/qt-4.5.3-glib-event-loop.patch:
+ Adding a patch to fix regression in event loop
29 Oct 2009; Christian Faulhammer <fauli@gentoo.org>
qt-xmlpatterns-4.5.3.ebuild:
diff --git a/x11-libs/qt-xmlpatterns/files/qt-4.5.3-glib-event-loop.patch b/x11-libs/qt-xmlpatterns/files/qt-4.5.3-glib-event-loop.patch
new file mode 100644
index 000000000000..580f027a5471
--- /dev/null
+++ b/x11-libs/qt-xmlpatterns/files/qt-4.5.3-glib-event-loop.patch
@@ -0,0 +1,11 @@
+diff -up qt-x11-opensource-src-4.5.3/src/corelib/kernel/qeventdispatcher_glib.cpp.than qt-x11-opensource-src-4.5.3/src/corelib/kernel/qeventdispatcher_glib.cpp
+--- qt-x11-opensource-src-4.5.3/src/corelib/kernel/qeventdispatcher_glib.cpp.than 2009-10-29 16:15:58.000000000 +0100
++++ qt-x11-opensource-src-4.5.3/src/corelib/kernel/qeventdispatcher_glib.cpp 2009-10-29 16:16:22.000000000 +0100
+@@ -263,7 +263,6 @@ QEventDispatcherGlibPrivate::QEventDispa
+ (void) new (&timerSource->timerList) QTimerInfoList();
+ timerSource->processEventsFlags = QEventLoop::AllEvents;
+ g_source_set_can_recurse(&timerSource->source, true);
+- g_source_set_priority(&timerSource->source, G_PRIORITY_DEFAULT_IDLE);
+ g_source_attach(&timerSource->source, mainContext);
+ }
+
diff --git a/x11-libs/qt-xmlpatterns/qt-xmlpatterns-4.5.3-r1.ebuild b/x11-libs/qt-xmlpatterns/qt-xmlpatterns-4.5.3-r1.ebuild
new file mode 100644
index 000000000000..feac4f6924aa
--- /dev/null
+++ b/x11-libs/qt-xmlpatterns/qt-xmlpatterns-4.5.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-xmlpatterns/qt-xmlpatterns-4.5.3-r1.ebuild,v 1.1 2009/10/29 18:30:13 ayoy Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The patternist module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=]"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/xmlpatterns tools/xmlpatterns"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/QtCore
+include/QtNetwork
+include/QtXmlPatterns
+src/network/
+src/corelib/"
+
+QCONFIG_ADD="xmlpatterns"
+QCONFIG_DEFINE="QT_XMLPATTERNS"
+
+PATCHES=(
+ "${FILESDIR}/qt-4.5-nolibx11.diff"
+ "${FILESDIR}/qt-${PV}-glib-event-loop.patch"
+)
+
+src_configure() {
+ myconf="${myconf} -xmlpatterns"
+ qt4-build_src_configure
+}