summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-05-13 21:15:26 +0000
committerMarinus Schraal <foser@gentoo.org>2003-05-13 21:15:26 +0000
commit01076b326404f9012f1233e85cbee21def604109 (patch)
treecbc822bfc921bb0a2352d6faf94dfcf80191e722 /x11-libs
parentmissing patch (diff)
downloadhistorical-01076b326404f9012f1233e85cbee21def604109.tar.gz
historical-01076b326404f9012f1233e85cbee21def604109.tar.bz2
historical-01076b326404f9012f1233e85cbee21def604109.zip
new version
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/vte/ChangeLog7
-rw-r--r--x11-libs/vte/files/digest-vte-0.10.281
-rw-r--r--x11-libs/vte/vte-0.10.27.ebuild4
-rw-r--r--x11-libs/vte/vte-0.10.28.ebuild34
4 files changed, 43 insertions, 3 deletions
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index b85a7ab94404..5d55b85596b5 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/vte
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.22 2003/04/29 15:00:01 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.23 2003/05/13 21:15:26 foser Exp $
+
+*vte-0.10.28 (13 May 2003)
+
+ 13 May 2003; foser <foser@gentoo.org> vte-0.10.28.ebuild :
+ New version, added python USE flag for pygtk
*vte-0.10.27 (29 Apr 2003)
diff --git a/x11-libs/vte/files/digest-vte-0.10.28 b/x11-libs/vte/files/digest-vte-0.10.28
new file mode 100644
index 000000000000..88309365045f
--- /dev/null
+++ b/x11-libs/vte/files/digest-vte-0.10.28
@@ -0,0 +1 @@
+MD5 3985463cab0a2df8763d793b95ebf4ba vte-0.10.28.tar.bz2 754858
diff --git a/x11-libs/vte/vte-0.10.27.ebuild b/x11-libs/vte/vte-0.10.27.ebuild
index aad7016cd80f..b096469676f4 100644
--- a/x11-libs/vte/vte-0.10.27.ebuild
+++ b/x11-libs/vte/vte-0.10.27.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.10.27.ebuild,v 1.1 2003/04/29 15:00:01 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.10.27.ebuild,v 1.2 2003/05/13 21:15:26 foser Exp $
inherit gnome2 flag-o-matic
@@ -14,7 +14,7 @@ DESCRIPTION="Xft powered terminal widget"
HOMEPAGE="http://www.gnome.org/"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+KEYWORDS="x86 ~ppc ~sparc ~alpha"
LICENSE="LGPL-2"
RDEPEND="virtual/glibc
diff --git a/x11-libs/vte/vte-0.10.28.ebuild b/x11-libs/vte/vte-0.10.28.ebuild
new file mode 100644
index 000000000000..f17135f7171c
--- /dev/null
+++ b/x11-libs/vte/vte-0.10.28.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.10.28.ebuild,v 1.1 2003/05/13 21:15:26 foser Exp $
+
+inherit gnome2 flag-o-matic
+
+# -Os takes us down (#16173)
+replace-flags "-Os" "-O2"
+
+IUSE="doc python"
+
+DESCRIPTION="Xft powered terminal widget"
+HOMEPAGE="http://www.gnome.org/"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+LICENSE="LGPL-2"
+
+RDEPEND="virtual/glibc
+ >=dev-libs/glib-2
+ >=x11-libs/gtk+-2
+ >=x11-libs/pango-1.2"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-0.6 )
+ python? ( >=dev-python/pygtk-1.99
+ >=dev-lang/python-2.2 )
+ >=dev-util/pkgconfig-0.12.0"
+
+DOCS="AUTHORS COPY* README HACKING INSTALL NEWS TODO ChangeLog"
+
+use python \
+ && G2CONF="${G2CONF} --enable-python" \
+ || G2CONF="${G2CONF} --disable-python" \