summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-06-13 11:39:00 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-06-13 11:39:00 +0000
commit207a59b6dbd325b26b3a9bf435740d746f8acad5 (patch)
treea697796173055a10c6b91db2d68229f9da46f27f /x11-libs/wxGTK
parentGerk masked xmms and binutils the wrong way around. Fixed this. (diff)
downloadhistorical-207a59b6dbd325b26b3a9bf435740d746f8acad5.tar.gz
historical-207a59b6dbd325b26b3a9bf435740d746f8acad5.tar.bz2
historical-207a59b6dbd325b26b3a9bf435740d746f8acad5.zip
gcc 3.1 patch
Diffstat (limited to 'x11-libs/wxGTK')
-rw-r--r--x11-libs/wxGTK/ChangeLog9
-rw-r--r--x11-libs/wxGTK/files/wxGTK-2.3.2.diff.gzbin0 -> 269 bytes
-rw-r--r--x11-libs/wxGTK/wxGTK-2.3.2-r2.ebuild104
3 files changed, 112 insertions, 1 deletions
diff --git a/x11-libs/wxGTK/ChangeLog b/x11-libs/wxGTK/ChangeLog
index 7a0e870bd3eb..8194bae70fad 100644
--- a/x11-libs/wxGTK/ChangeLog
+++ b/x11-libs/wxGTK/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/wxGTK
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.4 2002/04/14 08:29:15 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/ChangeLog,v 1.5 2002/06/13 11:38:59 verwilst Exp $
+
+*wxGTK-2.3.2-r2 (13 Jun 2002)
+
+ 13 Jun 2002; Bart Verwilst <verwilst@gentoo.org> wxGTK-2.3.2-r2.ebuild :
+
+ Apply a little patch to let GCC-3.1 compile this. ( src/gtk/joystick.cpp ), thanks to Francisco Gimeno <kikov@fco-gimeno.com>.
+ Closes bug # 3660
*wxGTK-2.3.2-r1 (14 Apr 2002)
diff --git a/x11-libs/wxGTK/files/wxGTK-2.3.2.diff.gz b/x11-libs/wxGTK/files/wxGTK-2.3.2.diff.gz
new file mode 100644
index 000000000000..306ecb30ed47
--- /dev/null
+++ b/x11-libs/wxGTK/files/wxGTK-2.3.2.diff.gz
Binary files differ
diff --git a/x11-libs/wxGTK/wxGTK-2.3.2-r2.ebuild b/x11-libs/wxGTK/wxGTK-2.3.2-r2.ebuild
new file mode 100644
index 000000000000..1b3ce47ee278
--- /dev/null
+++ b/x11-libs/wxGTK/wxGTK-2.3.2-r2.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.3.2-r2.ebuild,v 1.1 2002/06/13 11:39:00 verwilst Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="GTK+ version of wxWindows, a cross-platform C++ GUI toolkit."
+
+SRC_URI="mirror://sourceforge/wxwindows/${P}.tar.bz2"
+
+HOMEPAGE="http://www.wxwindows.org/"
+
+DEPEND="dev-libs/libunicode
+ media-libs/netpbm
+ gif? ( media-libs/giflib )
+ png? ( media-libs/libpng )
+ jpeg? ( media-libs/jpeg )
+ tiff? ( media-libs/tiff )
+ odbc? ( dev-db/unixODBC )
+ opengl? ( virtual/opengl )"
+
+use gtk \
+ && DEPEND="${DEPEND} =x11-libs/gtk+-1.2*" \
+ || DEPEND="${DEPEND} x11-libs/openmotif"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+
+src_compile() {
+
+
+ local myconf
+ #--with-gtk enabled by default, if you want to build against motif,
+ #replace --with-gtk with --with-motif and --without-gtk. You will
+ #also need openmotif installed. Unfortunately, the package build tools
+ #only support installation of one currently.
+
+ use gtk \
+ && myconf="--with-gtk" \
+ || myconf="--with-motif --without-gtk"
+
+
+ #Build static library too, shared library is enabled by default.
+ #Enable useful config options that don't have USE flags
+ myconf="${myconf} --enable-static --with-zlib --with-unicode"
+
+ #Note: pcx image support enabled by default if found.
+ #Also, all wxWindows gui features are enabled by default. If you
+ #want to build a smaller library you can disable features by adding
+ #the appropriate flags to myconf (see INSTALL.txt).
+
+ #The build tools include a --with-freetype option, however it doesn't
+ #seem to be implemented in the source yet.
+
+ #confiure options that have corresponding USE variable.
+
+ use odbc \
+ && myconf="${myconf} --with-odbc" \
+ || myconf="${myconf} --without-odbc"
+
+ use opengl \
+ && myconf="${myconf} --with-opengl" \
+ || myconf="${myconf} --without-opengl"
+
+ use gif \
+ && myconf="${myconf} --enable-gif" \
+ || myconf="${myconf} --disable-gif"
+
+ use png \
+ && myconf="${myconf} --with-libpng --enable-pnm" \
+ || myconf="${myconf} --without-libpng --disable-pnm"
+
+ use jpeg \
+ && myconf="${myconf} --with-libjpeg" \
+ || myconf="${myconf} --without-libjpeg"
+
+ use tiff \
+ && myconf="${myconf} --with-libtiff" \
+ || myconf="${myconf} --without-libtiff"
+
+ gunzip < ${FILESDIR}/${P}.diff.gz | patch -p1
+
+ ./configure \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --host=${CHOST} \
+ ${myconf}|| die
+
+ emake || die
+
+}
+
+src_install () {
+
+ make \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ prefix=${D}/usr \
+ install || die
+
+ dodoc *.txt
+}
+