summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2005-12-20 17:23:01 +0000
committerCaleb Tennis <caleb@gentoo.org>2005-12-20 17:23:01 +0000
commit98a962bba9bff738fe4b99a0c7437028f8a4319a (patch)
tree480e9c745aabad8fbc2be28089c866a82e6a5c62 /x11-libs/qt
parentAdding eutils to inherit (diff)
downloadhistorical-98a962bba9bff738fe4b99a0c7437028f8a4319a.tar.gz
historical-98a962bba9bff738fe4b99a0c7437028f8a4319a.tar.bz2
historical-98a962bba9bff738fe4b99a0c7437028f8a4319a.zip
Remove QtAssistant manual installation (it looks to me like it's handled now), and move the pkg-config files into /usr/_libdir_/pkgconfig
Package-Manager: portage-2.0.53
Diffstat (limited to 'x11-libs/qt')
-rw-r--r--x11-libs/qt/ChangeLog6
-rw-r--r--x11-libs/qt/Manifest4
-rw-r--r--x11-libs/qt/qt-4.1.0.ebuild9
3 files changed, 14 insertions, 5 deletions
diff --git a/x11-libs/qt/ChangeLog b/x11-libs/qt/ChangeLog
index 277888bfd421..51be0e245028 100644
--- a/x11-libs/qt/ChangeLog
+++ b/x11-libs/qt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.273 2005/12/20 13:48:29 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/ChangeLog,v 1.274 2005/12/20 17:23:01 caleb Exp $
+
+ 20 Dec 2005; Caleb Tennis <caleb@gentoo.org> qt-4.1.0.ebuild:
+ Remove QtAssistant manual installation (it looks to me like it's handled
+ now), and move the pkg-config files into /usr/_libdir_/pkgconfig
*qt-4.1.0 (20 Dec 2005)
diff --git a/x11-libs/qt/Manifest b/x11-libs/qt/Manifest
index 65b4ea2ec0ea..ad4ce764555c 100644
--- a/x11-libs/qt/Manifest
+++ b/x11-libs/qt/Manifest
@@ -1,4 +1,4 @@
-MD5 3952446d8afdaff41e4002580dd2e0ae ChangeLog 4257
+MD5 29fe42c77e019f49f9870fd4c3d6c061 ChangeLog 4464
MD5 8ffca1b1b7523339af04fd24b4595ce4 files/0001-dnd_optimization.patch 5623
MD5 8b3da5dae8babfcbdee3be465579d6c2 files/0002-dnd_active_window_fix.patch 7289
MD5 0cc401186f490faf55906cd458280db8 files/0037-dnd-timestamp-fix.patch 2138
@@ -23,5 +23,5 @@ MD5 512150b47a904b0240101e319856aab1 metadata.xml 156
MD5 8feb6ab675abfabe03c64990724716cb qt-3.3.4-r8.ebuild 10234
MD5 e9921cdbf779efba80c3877aea9d719a qt-3.3.5.ebuild 10201
MD5 013f53daa2fbe33eec94e47726c9e853 qt-4.0.1.ebuild 5936
-MD5 921eb8ba9c091403f57ba92d3223afa9 qt-4.1.0.ebuild 6052
+MD5 689a9a0dd97c261ec08f68118db4979a qt-4.1.0.ebuild 6199
MD5 6212755080bc0fd437c6e83d2db3ae82 qt-4.1.0_rc1.ebuild 6088
diff --git a/x11-libs/qt/qt-4.1.0.ebuild b/x11-libs/qt/qt-4.1.0.ebuild
index 742cb82e5777..27f015b76a89 100644
--- a/x11-libs/qt/qt-4.1.0.ebuild
+++ b/x11-libs/qt/qt-4.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.1.0.ebuild,v 1.1 2005/12/20 13:48:29 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt/qt-4.1.0.ebuild,v 1.2 2005/12/20 17:23:01 caleb Exp $
inherit eutils flag-o-matic toolchain-funcs multilib
@@ -45,6 +45,7 @@ pkg_setup() {
QTPREFIXDIR=/usr/$(get_libdir)/qt4
QTBINDIR=/usr/bin
QTLIBDIR=/usr/$(get_libdir)/qt4
+ QTPCDIR=/usr/$(get_libdir)/pkgconfig
QTDATADIR=/usr/share/doc/${PF}
QTDOCDIR=${QTDATADIR}/doc
QTHEADERDIR=/usr/include/qt4
@@ -168,7 +169,7 @@ src_install() {
fi
# The QtAssistant header files aren't installed..not sure why
- cp -pPR ${S}/include/QtAssistant ${D}/${QTHEADERDIR}/QtAssistant
+ #cp -pPR ${S}/include/QtAssistant ${D}/${QTHEADERDIR}/QtAssistant
keepdir "${QTSYSCONFDIR}"
@@ -176,6 +177,10 @@ src_install() {
sed -i -e "s:${S}/lib:${QTLIBDIR}:g" ${D}/${QTLIBDIR}/*.prl
sed -i -e "s:${S}/lib:${QTLIBDIR}:g" ${D}/${QTLIBDIR}/*.pc
+ # Move .pc files into the pkgconfig directory
+ dodir ${QTPCDIR}
+ mv ${D}/${QTLIBDIR}/*.pc ${D}/${QTPCDIR}
+
# List all the multilib libdirs
local libdirs
for libdir in $(get_all_libdirs); do