summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-02 08:03:02 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-02 08:03:02 +0000
commitd4d5e1a7a85cc5201ebe587a69c38f39daf0e882 (patch)
tree93fa65088916376f370ec08e1c4c097972366c53 /x11-libs/libast
parentclose #9810 (diff)
downloadhistorical-d4d5e1a7a85cc5201ebe587a69c38f39daf0e882.tar.gz
historical-d4d5e1a7a85cc5201ebe587a69c38f39daf0e882.tar.bz2
historical-d4d5e1a7a85cc5201ebe587a69c38f39daf0e882.zip
Version bump/enhancement #10081
Diffstat (limited to 'x11-libs/libast')
-rw-r--r--x11-libs/libast/ChangeLog10
-rw-r--r--x11-libs/libast/files/digest-libast-0.51
-rw-r--r--x11-libs/libast/libast-0.5.ebuild31
3 files changed, 39 insertions, 3 deletions
diff --git a/x11-libs/libast/ChangeLog b/x11-libs/libast/ChangeLog
index 2eb9997d2de0..613c2f2d0791 100644
--- a/x11-libs/libast/ChangeLog
+++ b/x11-libs/libast/ChangeLog
@@ -1,11 +1,15 @@
# ChangeLog for x11-libs/libast
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/ChangeLog,v 1.1 2002/02/01 21:53:38 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/ChangeLog,v 1.2 2002/11/02 08:03:02 vapier Exp $
+
+*libast-0.5 (02 Nov 2002)
+
+ 02 Nov 2002; Mike Frysinger <vapier@gentoo.org> :
+ Version bump per #10081 and lots of enhancements.
*libast-0.4-r1 (1 Feb 2002)
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
+ 01 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
Added initial ChangeLog which should be updated whenever the package is
updated in any way. This changelog is targetted to users. This means that the
comments should well explained and written in clean English. The details about
diff --git a/x11-libs/libast/files/digest-libast-0.5 b/x11-libs/libast/files/digest-libast-0.5
new file mode 100644
index 000000000000..18efb6adbbc9
--- /dev/null
+++ b/x11-libs/libast/files/digest-libast-0.5
@@ -0,0 +1 @@
+MD5 335ead8e8168bc06284c822f1f655eb8 libast-0.5.tar.gz 276591
diff --git a/x11-libs/libast/libast-0.5.ebuild b/x11-libs/libast/libast-0.5.ebuild
new file mode 100644
index 000000000000..72966162643c
--- /dev/null
+++ b/x11-libs/libast/libast-0.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libast/libast-0.5.ebuild,v 1.1 2002/11/02 08:03:02 vapier Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="LIBrary of Assorted Spiffy Things. Needed for Eterm."
+SRC_URI="http://www.eterm.org/download/${P}.tar.gz"
+HOMEPAGE="http://www.eterm.org/download/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+IUSE="pic imlib"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ >=media-libs/freetype-1.3"
+
+src_compile() {
+ # always disable mmx because binutils-2.11.92+ seems to be broken for this package
+ local myconf="--disable-mmx --with-gnu-ld --with-x"
+ use pic && myconf="${myconf} --with-pic"
+ use imlib && myconf="${myconf} --with-imlib"
+
+ econf ${myconf}
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README
+}