summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2004-06-26 08:28:17 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2004-06-26 08:28:17 +0000
commit6623332783056add7f0c9afe97ebdbb8242e89de (patch)
tree346ddf107856925386aeede780d0e65d0df331b5 /x11-base
parentDEPENDs can NOT be changed to virtual/libc until a virtual/libc is actually i... (diff)
downloadhistorical-6623332783056add7f0c9afe97ebdbb8242e89de.tar.gz
historical-6623332783056add7f0c9afe97ebdbb8242e89de.tar.bz2
historical-6623332783056add7f0c9afe97ebdbb8242e89de.zip
Pushing out a fix for a really annoying hang, resulting from a grep that fails after the first switch (#55120). Thanks to Michael Sterrett <mr_bones_@gentoo.org>.
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/opengl-update/ChangeLog10
-rw-r--r--x11-base/opengl-update/Manifest11
-rw-r--r--x11-base/opengl-update/files/digest-opengl-update-1.7.20
-rw-r--r--x11-base/opengl-update/files/opengl-update-1.7.2209
-rw-r--r--x11-base/opengl-update/opengl-update-1.7.2.ebuild18
5 files changed, 243 insertions, 5 deletions
diff --git a/x11-base/opengl-update/ChangeLog b/x11-base/opengl-update/ChangeLog
index 406f25ac1d54..de0657fcb125 100644
--- a/x11-base/opengl-update/ChangeLog
+++ b/x11-base/opengl-update/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-base/opengl-update
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/ChangeLog,v 1.29 2004/06/24 21:57:04 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/ChangeLog,v 1.30 2004/06/26 08:28:17 spyderous Exp $
+
+*opengl-update-1.7.2 (26 Jun 2004)
+
+ 26 Jun 2004; Donnie Berkholz <spyderous@gentoo.org>;
+ +files/opengl-update-1.7.2, +opengl-update-1.7.2.ebuild:
+ Pushing out a fix for a really annoying hang, resulting from a grep that fails
+ after the first switch (#55120). Thanks to Michael Sterrett
+ <mr_bones_@gentoo.org>.
24 Jun 2004; Donnie Berkholz <spyderous@gentoo.org>;
-files/opengl-update-1.7, -opengl-update-1.7.ebuild:
diff --git a/x11-base/opengl-update/Manifest b/x11-base/opengl-update/Manifest
index d6e4af0c97f4..38b98059f25c 100644
--- a/x11-base/opengl-update/Manifest
+++ b/x11-base/opengl-update/Manifest
@@ -1,8 +1,11 @@
-MD5 aa3408a12c78adbf4a17a0243d7c5e8d ChangeLog 4686
+MD5 94bfbf9e3537ba535e9330e3b0d0473d ChangeLog 5007
MD5 15888db563d723a724ef6cdd2818893d metadata.xml 284
-MD5 1d34cb7488ae9740aad7370642593cb2 opengl-update-1.7.1.ebuild 544
+MD5 3c4ab112193b4a61ae013ef447083e4f opengl-update-1.7.2.ebuild 545
MD5 9a419877f2c312ae37cefb2ee93d3849 opengl-update-1.5.ebuild 521
-MD5 07db4d781825de8448a4988dab1ce6b0 files/opengl-update-1.7.1 4931
-MD5 6412519427e2df005901ca2f1fb05599 files/opengl-update-1.5 3780
+MD5 1d34cb7488ae9740aad7370642593cb2 opengl-update-1.7.1.ebuild 544
+MD5 3201b6def2a67ccd91d4e67fbc6ffe9d files/opengl-update-1.7.2 4984
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-opengl-update-1.7.2 0
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-opengl-update-1.5 0
+MD5 a7b7eafaa3ea0cd277c66b0d13674307 files/opengl-update-1.5 3781
+MD5 07db4d781825de8448a4988dab1ce6b0 files/opengl-update-1.7.1 4931
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-opengl-update-1.7.1 0
diff --git a/x11-base/opengl-update/files/digest-opengl-update-1.7.2 b/x11-base/opengl-update/files/digest-opengl-update-1.7.2
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/x11-base/opengl-update/files/digest-opengl-update-1.7.2
diff --git a/x11-base/opengl-update/files/opengl-update-1.7.2 b/x11-base/opengl-update/files/opengl-update-1.7.2
new file mode 100644
index 000000000000..63d2c07b930a
--- /dev/null
+++ b/x11-base/opengl-update/files/opengl-update-1.7.2
@@ -0,0 +1,209 @@
+#!/bin/bash
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/files/opengl-update-1.7.2,v 1.1 2004/06/26 08:28:17 spyderous Exp $
+# Author: Martin Schlemmer <azarah@gentoo.org>
+# Further modifications by Donnie Berkholz <spyderous@gentoo.org>
+
+. /etc/init.d/functions.sh
+
+if [ `id -u` -ne 0 ]
+then
+ eerror "${0}: must be root."
+ exit 1
+fi
+
+usage() {
+# In addition to the below function, there are two extra uses for this.
+#
+# They aren't in the printed help message because they're intended
+# for developer use.
+# 1) --use-old $NEW_IMPLEM will switch to the new implementation only if
+# no old setup existed (i.e., X has never been installed)
+# 2) --get-implementation will return the implementation
+
+cat << FOO
+usage: ${0##*/} <GL implementation>
+
+note:
+ This utility switches between OpenGL implementations. Currently there
+ are five supported implementations, "xorg-x11" "xfree" "nvidia" "ati"
+ and "mtx", the implementations for X.org, XFree86, nVidia, ATi
+ and Matrox drivers respectively.
+
+examples:
+ ${0##*/} xorg-x11
+ This will setup things to use libGL.so from X.org.
+
+ ${0##*/} nvidia
+ This will setup things to use libGL.so from the nVidia drivers.
+
+FOO
+ exit 1
+}
+
+if [ "$#" -ne 1 -a "$#" -ne 2 ] || \
+ [ "$#" -eq 2 -a "$1" != "--use-old" ]
+then
+ usage
+fi
+
+GL_IMPLEM=""
+
+# Discover GL implementation if it exists
+get_implem() {
+ if [ -f /etc/env.d/09opengl ]
+ then
+ source /etc/env.d/09opengl
+ if [ -n "${LDPATH}" ]
+ then
+ GL_IMPLEM="${LDPATH/\/usr\/lib\/opengl\/}"
+ GL_IMPLEM="${GL_IMPLEM/\/lib}"
+ unset LDPATH
+ fi
+ fi
+}
+
+# Return current GL implementation
+if [ "$1" = "--get-implementation" ]
+then
+ get_implem
+
+ if [ -n "${GL_IMPLEM}" ]
+ then
+ echo "${GL_IMPLEM}"
+ fi
+
+ if [ -z "${GL_IMPLEM}" ]
+ then
+ exit 2
+ fi
+
+ exit 1
+fi
+
+# Only use specified implementation if it is not already selected.
+if [ "$1" = "--use-old" ]
+then
+ shift
+
+ get_implem
+
+ if [ -z "${GL_IMPLEM}" ]
+ then
+ GL_IMPLEM="$1"
+ fi
+else
+ GL_IMPLEM="$1"
+fi
+
+if [ ! -d /usr/lib/opengl/${GL_IMPLEM} ]
+then
+ usage
+else
+ ebegin "Switching to ${GL_IMPLEM} OpenGL interface"
+
+ #setup the $LDPATH
+ echo "LDPATH=/usr/lib/opengl/${GL_IMPLEM}/lib" >/etc/env.d/09opengl
+ /usr/sbin/env-update &>/dev/null
+
+ #setup the /usr/lib/libGL.so symlink
+ if [ -e /usr/lib/libGL.so ]
+ then
+ rm -f /usr/lib/libGL.so
+ fi
+ if [ -e /usr/lib/libGL.so.1 ]
+ then
+ rm -f /usr/lib/libGL.so.1
+ fi
+ realname="$(readlink /usr/lib/opengl/${GL_IMPLEM}/lib/libGL.so)"
+ ln -sf /usr/lib/opengl/${GL_IMPLEM}/lib/${realname} \
+ /usr/lib/libGL.so
+ ln -sf /usr/lib/opengl/${GL_IMPLEM}/lib/${realname} \
+ /usr/lib/libGL.so.1
+
+ #setup the /usr/X11R6/lib/libMesaGL.so symlink
+ if [ -e /usr/X11R6/lib/libMesaGL.so ]
+ then
+ rm -f /usr/X11R6/lib/libMesaGL.so
+ fi
+ realname="$(readlink /usr/lib/opengl/${GL_IMPLEM}/lib/libGL.so)"
+ ln -sf /usr/lib/opengl/${GL_IMPLEM}/lib/${realname} \
+ /usr/X11R6/lib/libMesaGL.so
+
+ #setup the /usr/lib/libGLcore.so symlink
+ if [ -e /usr/lib/libGLcore.so ]
+ then
+ rm -f /usr/lib/libGLcore.so
+ fi
+ if [ -e /usr/lib/libGLcore.so.1 ]
+ then
+ rm -f /usr/lib/libGLcore.so.1
+ fi
+ if [ -e /usr/lib/opengl/${GL_IMPLEM}/lib/libGLcore.so ]
+ then
+ realname="$(readlink /usr/lib/opengl/${GL_IMPLEM}/lib/libGLcore.so)"
+ ln -sf /usr/lib/opengl/${GL_IMPLEM}/lib/${realname} \
+ /usr/lib/libGLcore.so
+ ln -sf /usr/lib/opengl/${GL_IMPLEM}/lib/${realname} \
+ /usr/lib/libGLcore.so.1
+ fi
+
+ #setup the /usr/lib/libGL.la symlink
+ if [ -e /usr/lib/libGL.la ]
+ then
+ rm -f /usr/lib/libGL.la
+ fi
+ if [ -e /usr/lib/opengl/${GL_IMPLEM}/lib/libGL.la ]
+ then
+ ln -sf /usr/lib/opengl/${GL_IMPLEM}/lib/libGL.la \
+ /usr/lib/libGL.la
+ fi
+
+ #fix libtool archives (#48297)
+ CURDIR="$(pwd)"
+ cd /usr/lib
+ if [ "`grep -l /usr/lib/opengl *.la`" ]
+ then
+ sed -i 's:/usr/lib/opengl/[^/]*/lib/libGL.la:/usr/lib/libGL.la:' \
+ `grep -l /usr/lib/opengl *.la`
+ fi
+ cd ${CURDIR}
+
+ #setup the /usr/X11R6/lib/modules/extensions/libglx.so symlink
+ if [ -e /usr/X11R6/lib/modules/extensions/libglx.so ]
+ then
+ rm -f /usr/X11R6/lib/modules/extensions/libglx.so
+ fi
+ if [ -e /usr/lib/opengl/${GL_IMPLEM}/extensions/libglx.so ]
+ then
+ ln -sf /usr/lib/opengl/${GL_IMPLEM}/extensions/libglx.so \
+ /usr/X11R6/lib/modules/extensions/libglx.so
+ fi
+ #setup the /usr/X11R6/lib/modules/extensions/libglx.a symlink
+ if [ -e /usr/X11R6/lib/modules/extensions/libglx.a ]
+ then
+ rm -f /usr/X11R6/lib/modules/extensions/libglx.a
+ fi
+ if [ -e /usr/lib/opengl/${GL_IMPLEM}/extensions/libglx.a ]
+ then
+ ln -sf /usr/lib/opengl/${GL_IMPLEM}/extensions/libglx.a \
+ /usr/X11R6/lib/modules/extensions/libglx.a
+ fi
+
+ #setup the includes
+ for x in gl.h glx.h glxtokens.h
+ do
+ if [ -e /usr/X11R6/include/GL/${x} ]
+ then
+ rm -f /usr/X11R6/include/GL/${x}
+ fi
+ ln -sf /usr/lib/opengl/${GL_IMPLEM}/include/${x} \
+ /usr/X11R6/include/GL/${x}
+ done
+
+ eend 0
+fi
+
+
+# vim:ts=4
diff --git a/x11-base/opengl-update/opengl-update-1.7.2.ebuild b/x11-base/opengl-update/opengl-update-1.7.2.ebuild
new file mode 100644
index 000000000000..b09db711b45a
--- /dev/null
+++ b/x11-base/opengl-update/opengl-update-1.7.2.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/opengl-update-1.7.2.ebuild,v 1.1 2004/06/26 08:28:17 spyderous Exp $
+
+DESCRIPTION="Utility to change the OpenGL interface being used"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64"
+IUSE=""
+
+DEPEND="virtual/glibc"
+
+src_install() {
+ newsbin ${FILESDIR}/opengl-update-${PV} opengl-update || die
+}