summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-03-14 06:54:47 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-03-14 06:54:47 +0000
commit2533fb019c1fd9c8f8609f8450bd352277e33304 (patch)
tree88d626404cdb2b309c82b755a649d9433eb01169 /www-client/firefox/firefox-3.6.15.ebuild
parentRemove old ebuilds and duplicate gnome-use-flag related stuff to allow eclass... (diff)
downloadhistorical-2533fb019c1fd9c8f8609f8450bd352277e33304.tar.gz
historical-2533fb019c1fd9c8f8609f8450bd352277e33304.tar.bz2
historical-2533fb019c1fd9c8f8609f8450bd352277e33304.zip
Remove old ebuilds and duplicate gnome-use-flag related stuff to allow eclass changes from overlay to be merged into tree
Package-Manager: portage-2.1.9.42/cvs/Linux x86_64
Diffstat (limited to 'www-client/firefox/firefox-3.6.15.ebuild')
-rw-r--r--www-client/firefox/firefox-3.6.15.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/www-client/firefox/firefox-3.6.15.ebuild b/www-client/firefox/firefox-3.6.15.ebuild
index bb52c24c4f82..433f7a01046a 100644
--- a/www-client/firefox/firefox-3.6.15.ebuild
+++ b/www-client/firefox/firefox-3.6.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/firefox-3.6.15.ebuild,v 1.6 2011/03/13 20:40:59 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/firefox-3.6.15.ebuild,v 1.7 2011/03/14 06:54:47 nirbheek Exp $
EAPI="3"
WANT_AUTOCONF="2.1"
@@ -25,7 +25,7 @@ HOMEPAGE="http://www.mozilla.com/firefox"
KEYWORDS="~alpha amd64 arm hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~ia64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
SLOT="0"
LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
-IUSE="+alsa bindist +ipc java libnotify system-sqlite wifi"
+IUSE="+alsa bindist gnome +ipc java libnotify system-sqlite wifi"
REL_URI="http://releases.mozilla.org/pub/mozilla.org/firefox/releases"
SRC_URI="${REL_URI}/${MY_PV}/source/firefox-${MY_PV}.source.tar.bz2
@@ -56,6 +56,10 @@ RDEPEND="
alsa? ( media-libs/alsa-lib )
>=x11-libs/cairo-1.8.8[X]
x11-libs/pango[X]
+ gnome? ( >=gnome-base/gnome-vfs-2.16.3
+ >=gnome-base/libgnomeui-2.16.1
+ >=gnome-base/gconf-2.16.0
+ >=gnome-base/libgnome-2.16.0 )
wifi? ( net-wireless/wireless-tools )
libnotify? ( >=x11-libs/libnotify-0.4 )
~net-libs/xulrunner-${XUL_PV}[ipc=,java=,wifi=,libnotify=,system-sqlite=]"
@@ -158,6 +162,7 @@ src_configure() {
# It doesn't compile on alpha without this LDFLAGS
use alpha && append-ldflags "-Wl,--no-relax"
+ mozconfig_annotate '' --enable-crypto
mozconfig_annotate '' --enable-extensions="${MEXTENSIONS}"
mozconfig_annotate '' --enable-application=browser
mozconfig_annotate '' --disable-mailnews
@@ -190,6 +195,8 @@ src_configure() {
mozconfig_annotate '' --with-system-libxul
mozconfig_annotate '' --with-libxul-sdk="${EPREFIX}"/usr/$(get_libdir)/xulrunner-devel-${MAJ_XUL_PV}
+ mozconfig_use_enable gnome gnomevfs
+ mozconfig_use_enable gnome gnomeui
mozconfig_use_enable ipc # +ipc, upstream default
mozconfig_use_enable libnotify
mozconfig_use_enable java javaxpcom