summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2005-08-24 20:16:00 +0000
committerRenat Lumpau <rl03@gentoo.org>2005-08-24 20:16:00 +0000
commit21f64f344616cef467c92fd2dd45366c3be87e9b (patch)
treee939816b174ba3909835e1358706f27995ef4b11 /www-apps
parentstable on ia64 (diff)
downloadhistorical-21f64f344616cef467c92fd2dd45366c3be87e9b.tar.gz
historical-21f64f344616cef467c92fd2dd45366c3be87e9b.tar.bz2
historical-21f64f344616cef467c92fd2dd45366c3be87e9b.zip
Fix dependency checking code wrt bug #103481
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/rt/ChangeLog6
-rw-r--r--www-apps/rt/Manifest14
-rw-r--r--www-apps/rt/rt-3.2.1.ebuild15
-rw-r--r--www-apps/rt/rt-3.4.2-r1.ebuild10
-rw-r--r--www-apps/rt/rt-3.4.3.ebuild6
5 files changed, 35 insertions, 16 deletions
diff --git a/www-apps/rt/ChangeLog b/www-apps/rt/ChangeLog
index 9031b6b71e38..8d03bbde7a6a 100644
--- a/www-apps/rt/ChangeLog
+++ b/www-apps/rt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apps/rt
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/ChangeLog,v 1.19 2005/08/23 19:29:07 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/ChangeLog,v 1.20 2005/08/24 20:16:00 rl03 Exp $
+
+ 24 Aug 2005; Renat Lumpau <rl03@gentoo.org> rt-3.2.1.ebuild,
+ rt-3.4.2-r1.ebuild, rt-3.4.3.ebuild:
+ Fix dependency checking code wrt bug #103481
23 Aug 2005; Renat Lumpau <rl03@gentoo.org> rt-3.4.3.ebuild:
Fix enewuser invocation wrt bug #103421
diff --git a/www-apps/rt/Manifest b/www-apps/rt/Manifest
index 9ac93db26cc2..3b9e733f66dd 100644
--- a/www-apps/rt/Manifest
+++ b/www-apps/rt/Manifest
@@ -1,10 +1,10 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 2d55314d5a0dc44ed84ff04cda740034 rt-3.4.2-r1.ebuild 5438
-MD5 045002e419f3171a81a06cdd7582b098 rt-3.4.3.ebuild 5500
-MD5 e28b5c19f33196d18983e2db57aad44f rt-3.2.1.ebuild 4217
-MD5 783cb55d6cd13c9b2b450180b2f4a7e5 ChangeLog 3480
+MD5 55835f0d62bdbc8c27d8771c5ea4cb41 rt-3.4.2-r1.ebuild 5569
+MD5 12a24021145bca14aec679017884ab88 rt-3.4.3.ebuild 5586
+MD5 f8f70be6ec46133fbf7fe406ccbd86a6 rt-3.2.1.ebuild 4359
+MD5 3d1fce1db532505d1d2d3055e4c600f6 ChangeLog 3630
MD5 224c312cc23d02aa06c26a4da3cc1f90 metadata.xml 221
MD5 af335c7cab7bfc09dbd08feba51d2879 files/digest-rt-3.4.2-r1 61
MD5 5f5c3f76ea4676e743612e38341780fe files/digest-rt-3.2.1 61
@@ -22,7 +22,7 @@ MD5 73c354dd8ba0f64a74e5c6cd01b33834 files/3.4.2/rt_apache2_fcgi.conf 993
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFDC3kdEzitwsaoONoRArzOAJ0VcDUgMpCPDimQa9T0PkdhxSF8zACfbE3n
-xqHg5MX8Yx/2quj5n1qd22o=
-=x1EQ
+iD8DBQFDDNWbEzitwsaoONoRAlG8AJ9WK2Fg7EcNwpSkYKb/7EwP0+9ytACglBGH
+MdGu+iIW65ajSfOvWg5eTSQ=
+=v0qb
-----END PGP SIGNATURE-----
diff --git a/www-apps/rt/rt-3.2.1.ebuild b/www-apps/rt/rt-3.2.1.ebuild
index 4f7bbaa08762..0ec4088c50ba 100644
--- a/www-apps/rt/rt-3.2.1.ebuild
+++ b/www-apps/rt/rt-3.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/rt-3.2.1.ebuild,v 1.6 2005/06/21 02:12:38 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/rt-3.2.1.ebuild,v 1.7 2005/08/24 20:16:00 rl03 Exp $
inherit webapp eutils
@@ -113,10 +113,17 @@ src_compile() {
" ${files}
# check for missing deps and ask to report if something is broken
- if `make testdeps | grep "MISSING"`; then
- ewarn "Missing Perl dependency, please file a bug in the Gentoo Bugzilla with the information above"
+ /usr/bin/perl ./sbin/rt-test-dependencies --verbose \
+ `use_with mysql` \
+ `use_with postgres pg` > ${T}/t
+ if grep -q "MISSING" ${T}/t; then
+ ewarn "Missing Perl dependency!"
+ ewarn
+ cat ${T}/t
+ ewarn
+ ewarn "Please file a bug in the Gentoo Bugzilla with the information above"
ewarn "and assign it to rl03@gentoo.org"
- die "Missing dependencies"
+ die "Missing dependencies."
fi
}
diff --git a/www-apps/rt/rt-3.4.2-r1.ebuild b/www-apps/rt/rt-3.4.2-r1.ebuild
index 1d9d51d25c2e..ac1c3630cccd 100644
--- a/www-apps/rt/rt-3.4.2-r1.ebuild
+++ b/www-apps/rt/rt-3.4.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/rt-3.4.2-r1.ebuild,v 1.6 2005/08/08 22:40:44 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/rt-3.4.2-r1.ebuild,v 1.7 2005/08/24 20:16:00 rl03 Exp $
inherit webapp eutils
@@ -165,8 +165,14 @@ src_compile() {
--with-web-group=${web}
# check for missing deps and ask to report if something is broken
- if `make testdeps | grep "MISSING"`; then
+ /usr/bin/perl ./sbin/rt-test-dependencies --verbose \
+ `use_with mysql` \
+ `use_with postgres pg` > ${T}/t
+ if grep -q "MISSING" ${T}/t; then
ewarn "Missing Perl dependency!"
+ ewarn
+ cat ${T}/t
+ ewarn
ewarn "Please file a bug in the Gentoo Bugzilla with the information above"
ewarn "and assign it to rl03@gentoo.org"
die "Missing dependencies."
diff --git a/www-apps/rt/rt-3.4.3.ebuild b/www-apps/rt/rt-3.4.3.ebuild
index 43fed3b70a73..446d16d18ade 100644
--- a/www-apps/rt/rt-3.4.3.ebuild
+++ b/www-apps/rt/rt-3.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/rt-3.4.3.ebuild,v 1.2 2005/08/23 19:29:07 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/rt-3.4.3.ebuild,v 1.3 2005/08/24 20:16:00 rl03 Exp $
inherit webapp eutils
@@ -166,7 +166,9 @@ src_compile() {
--with-web-group=${web}
# check for missing deps and ask to report if something is broken
- make testdeps > ${T}/t
+ /usr/bin/perl ./sbin/rt-test-dependencies --verbose \
+ `use_with mysql` \
+ `use_with postgres pg` > ${T}/t
if grep -q "MISSING" ${T}/t; then
ewarn "Missing Perl dependency!"
ewarn