summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2005-08-15 09:04:13 +0000
committerMichael Cummings <mcummings@gentoo.org>2005-08-15 09:04:13 +0000
commit8c071dcc2c62bacffdb180d7e27048afa2d3c942 (patch)
tree7416251a2bae740f9534f540afd05d0ddc443e5d /www-apache
parentMarking 2.4.0 stable (x86) (diff)
downloadhistorical-8c071dcc2c62bacffdb180d7e27048afa2d3c942.tar.gz
historical-8c071dcc2c62bacffdb180d7e27048afa2d3c942.tar.bz2
historical-8c071dcc2c62bacffdb180d7e27048afa2d3c942.zip
Bug 88367, courtesy Adrian Lambeck
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_parrot/ChangeLog11
-rw-r--r--www-apache/mod_parrot/Manifest17
-rwxr-xr-xwww-apache/mod_parrot/files/configure.patch11
-rw-r--r--www-apache/mod_parrot/files/digest-mod_parrot-0.31
-rw-r--r--www-apache/mod_parrot/files/hello.imc16
-rw-r--r--www-apache/mod_parrot/files/mod_parrot.conf22
-rw-r--r--www-apache/mod_parrot/metadata.xml10
-rw-r--r--www-apache/mod_parrot/mod_parrot-0.3.ebuild82
8 files changed, 170 insertions, 0 deletions
diff --git a/www-apache/mod_parrot/ChangeLog b/www-apache/mod_parrot/ChangeLog
new file mode 100644
index 000000000000..9021dc45fb3b
--- /dev/null
+++ b/www-apache/mod_parrot/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for www-apache/mod_parrot
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_parrot/ChangeLog,v 1.1 2005/08/15 09:04:12 mcummings Exp $
+
+*mod_parrot-0.3 (15 Aug 2005)
+
+ 15 Aug 2005; Michael Cummings <mcummings@gentoo.org> +metadata.xml,
+ +files/configure.patch, +files/hello.imc, +files/mod_parrot.conf,
+ +mod_parrot-0.3.ebuild:
+ Bug 88367, courtesy Adrian Lambeck
+
diff --git a/www-apache/mod_parrot/Manifest b/www-apache/mod_parrot/Manifest
new file mode 100644
index 000000000000..34cf9dd9e491
--- /dev/null
+++ b/www-apache/mod_parrot/Manifest
@@ -0,0 +1,17 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 09ca60b5df93156965c2803c79a08ad7 mod_parrot-0.3.ebuild 2128
+MD5 e2d8f1bf77722def1dd432e26455c818 metadata.xml 305
+MD5 282d777a8fc366162163a7c5a768d721 ChangeLog 451
+MD5 b93d7db3090fc25e0b2a8d82b13d1db1 files/hello.imc 308
+MD5 a84c1f7a16b3202a5019aa9c4105b8d4 files/mod_parrot.conf 587
+MD5 d32e93eda43971108e048458d4b6badd files/configure.patch 529
+MD5 3891bfb26d033f2d92c14eaa53d7a93c files/digest-mod_parrot-0.3 65
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.0 (GNU/Linux)
+
+iD8DBQFDAFqetG5z4I8BtQoRAssNAKCLc34S3q5gnbyMGxxpGxzkklsIDgCfdCCH
+qkI6qKTGnIE02FPTYtGsq7s=
+=IfFu
+-----END PGP SIGNATURE-----
diff --git a/www-apache/mod_parrot/files/configure.patch b/www-apache/mod_parrot/files/configure.patch
new file mode 100755
index 000000000000..1b0c334a7228
--- /dev/null
+++ b/www-apache/mod_parrot/files/configure.patch
@@ -0,0 +1,11 @@
+--- /var/tmp/portage/mod_parrot-0.3/work/mod_parrot-0.3/Configure.pl 2005-08-02 21:17:22.000000000 +0200
++++ mod_parrot-0.3/Configure.pl 2005-08-12 17:36:01.000000000 +0200
+@@ -76,7 +76,7 @@
+ my $cflags = " -I$parrot_build_dir/include";
+ $cflags .= " -DMPM_IS_THREADED" if (mpm_is_threaded($mpm));
+ my $ldflags = parrot_config('ldflags') . " -L$parrot_build_dir/blib/lib";
+-my $libs = parrot_config('libs') . ' -lparrot';
++my $libs = parrot_config('libs') . ' -lparrot -licuuc';
+
+ print "Generating Makefile...";
+ my $template;
diff --git a/www-apache/mod_parrot/files/digest-mod_parrot-0.3 b/www-apache/mod_parrot/files/digest-mod_parrot-0.3
new file mode 100644
index 000000000000..3e92df618f0b
--- /dev/null
+++ b/www-apache/mod_parrot/files/digest-mod_parrot-0.3
@@ -0,0 +1 @@
+MD5 fde448ed2a8dfb1fafd4a7cc9165ed8a mod_parrot-0.3.tar.gz 33306
diff --git a/www-apache/mod_parrot/files/hello.imc b/www-apache/mod_parrot/files/hello.imc
new file mode 100644
index 000000000000..e49f5b77d381
--- /dev/null
+++ b/www-apache/mod_parrot/files/hello.imc
@@ -0,0 +1,16 @@
+.namespace [ 'HelloWorld' ]
+
+.sub _handler
+ .param pmc r
+ .local pmc ap_const
+ .local int status
+
+ r.'puts'('<H1>Hello World!</H1>')
+
+ ap_const = find_global 'Apache::Constants', 'ap_constants'
+ status = ap_const['OK']
+
+ .pcc_begin_return
+ .return status
+ .pcc_end_return
+.end
diff --git a/www-apache/mod_parrot/files/mod_parrot.conf b/www-apache/mod_parrot/files/mod_parrot.conf
new file mode 100644
index 000000000000..cf7c791c05a9
--- /dev/null
+++ b/www-apache/mod_parrot/files/mod_parrot.conf
@@ -0,0 +1,22 @@
+<IfDefine parrot>
+ <IfModule !mod_parrot.c>
+ LoadModule parrot_module modules/mod_parrot.so
+ </IfModule>
+</IfDefine>
+
+<IfModule mod_parrot.c>
+
+ ParrotInit /usr/lib/mod_parrot-0.3/ModParrot/init.pbc
+
+ ParrotLoad /usr/lib/mod_parrot-0.3/ModParrot/HLL/pir.pbc
+ ParrotLoad /usr/lib/mod_parrot-0.3/Apache/RequestRec.pbc
+ ParrotLoad /usr/lib/mod_parrot-0.3/Apache/Constants.pbc
+ ParrotLoad /usr/lib/mod_parrot-0.3/APR/Table.pbc
+
+ ParrotLoad /usr/lib/mod_parrot-0.3/examples/HelloWorld.pbc
+
+ <Location /hello>
+ SetHandler parrot-code
+ ParrotHandler HelloWorld
+ </Location>
+</IfModule>
diff --git a/www-apache/mod_parrot/metadata.xml b/www-apache/mod_parrot/metadata.xml
new file mode 100644
index 000000000000..86672fe64c10
--- /dev/null
+++ b/www-apache/mod_parrot/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <maintainer>
+ <email>perl@gentoo.org</email>
+ <description>Primary Maintainer</description>
+ </maintainer>
+ <longdescription></longdescription>
+</pkgmetadata>
diff --git a/www-apache/mod_parrot/mod_parrot-0.3.ebuild b/www-apache/mod_parrot/mod_parrot-0.3.ebuild
new file mode 100644
index 000000000000..fa6590bee826
--- /dev/null
+++ b/www-apache/mod_parrot/mod_parrot-0.3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_parrot/mod_parrot-0.3.ebuild,v 1.1 2005/08/15 09:04:12 mcummings Exp $
+inherit eutils apache-module
+
+DESCRIPTION="An embedded Parrot virutal machine for Apache2"
+HOMEPAGE="http://www.smashing.org/mod_parrot/"
+SRC_URI="http://www.smashing.org/mod_parrot/dist/${S}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+MY_PARROT_PN="0.2.3"
+MY_PARROT_PATH_SUFFIX="/usr/lib/parrot"
+MY_PARROT_PATH="${MY_PARROT_PATH_SUFFIX}-${MY_PARROT_PN}"
+
+need_apache2
+APACHE2_MOD_DEFINE="parrot"
+APACHE2_MOD_CONF="mod_parrot"
+MPLIBS_SUFFIX="${S}/"
+DOCFILES="AUTHORS CHANGES LICENSE README ROADMAP"
+
+IUSE=""
+DEPEND="=dev-lang/parrot-${MY_PARROT_PN}
+ >=net-www/apache-2.0.54"
+
+src_unpack () {
+ unpack ${A}
+ cd ${S}
+ #fixes missing lib for icu
+ epatch ${FILESDIR}/configure.patch
+}
+src_compile() {
+
+perl ./Configure.pl \
+ --parrot-build-dir=${MY_PARROT_PATH} \
+ --apxs=/usr/sbin/apxs2 \
+ || die "Perl ./Configure.pl failed"
+
+emake -j1 || die "emake failed"
+
+einfo "makeing libraries"
+emake -j1 libraries || die "emake failed"
+
+#compile the example
+einfo "Compiling example"
+echo "${MPLIBS_SUFFIX}lib/HelloWorld"
+parrot -o ${MPLIBS_SUFFIX}lib/HelloWorld.pbc ${FILESDIR}/hello.imc
+
+}
+
+src_test() {
+ :
+}
+
+src_install() {
+ #emake install || die "install failed"
+ #install the module
+ apache-module_src_install
+
+ #install the libraries + example - this is not yet supported by the Makefile (see Readme)
+ einfo "Installing libraries"
+ dodir /usr/lib/${P}/
+ dodir /usr/lib/${P}/ModParrot
+ dodir /usr/lib/${P}/ModParrot/HLL
+ dodir /usr/lib/${P}/Apache
+ dodir /usr/lib/${P}/examples
+ dodir /usr/lib/${P}/APR
+
+ insinto /usr/lib/${P}/ModParrot
+ doins lib/ModParrot/init.pbc
+ insinto /usr/lib/${P}/ModParrot/HLL
+ doins lib/ModParrot/HLL/pir.pbc
+ doins lib/ModParrot/HLL/pugs.pbc
+ insinto /usr/lib/${P}/Apache
+ doins lib/Apache/RequestRec.pbc
+ doins lib/Apache/Constants.pbc
+ insinto /usr/lib/${P}/APR
+ doins lib/APR/Table.pbc
+ insinto /usr/lib/${P}/examples
+ doins lib/HelloWorld.pbc
+}