summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-11-14 12:29:37 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-11-14 12:29:37 +0000
commit439a8706ce27ba7954bb837377ab713d3c40791c (patch)
tree2957f7f5fcb56b3060be5ea23577f4751ac9b291 /sys-power/iasl/iasl-20060912.ebuild
parentVersion bump, add dependency over tsocks (that upstream ships and builds inli... (diff)
downloadhistorical-439a8706ce27ba7954bb837377ab713d3c40791c.tar.gz
historical-439a8706ce27ba7954bb837377ab713d3c40791c.tar.bz2
historical-439a8706ce27ba7954bb837377ab713d3c40791c.zip
Bug #150511, version bump.
Package-Manager: portage-2.1.2_rc1-r6
Diffstat (limited to 'sys-power/iasl/iasl-20060912.ebuild')
-rw-r--r--sys-power/iasl/iasl-20060912.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-power/iasl/iasl-20060912.ebuild b/sys-power/iasl/iasl-20060912.ebuild
new file mode 100644
index 000000000000..57134f1affc1
--- /dev/null
+++ b/sys-power/iasl/iasl-20060912.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20060912.ebuild,v 1.1 2006/11/14 12:29:37 robbat2 Exp $
+
+inherit toolchain-funcs eutils
+
+MY_PN=acpica-unix
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Intel ACPI Source Language (ASL) compiler"
+HOMEPAGE="http://www.intel.com/technology/iapc/acpi/"
+SRC_URI="http://www.intel.com/technology/iapc/acpi/downloads/${MY_P}.tar.gz"
+
+LICENSE="iASL"
+SLOT="0"
+KEYWORDS="~ppc ~x86 ~amd64"
+
+IUSE=""
+DEPEND="sys-devel/bison
+ sys-devel/flex"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${MY_PN}-20060512-buildfixup.patch
+}
+
+src_compile() {
+ # fix stupid flex 2.5.31 bug
+ emake -C compiler aslcompilerlex.c || die "emake aslcompilerlex.c failed"
+ sed -i.orig -e '/#define unput/s,yytext_ptr,AslCompilertext,' \
+ ${S}/compiler/aslcompilerlex.c || die "sed failed"
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ dobin compiler/iasl tools/acpixtract/acpixtract tools/acpiexec/acpiexec tools/acpisrc/acpisrc
+ dodoc README changes.txt
+}