summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-05-29 18:11:15 +0000
committerAli Polatel <hawking@gentoo.org>2008-05-29 18:11:15 +0000
commitce3d03c20838dfb3b5ba389c32dad7677315a8d7 (patch)
treef2b974c6fcada7ddb9a4e3392a30a98790321c99 /sys-power/cpuspeedy/cpuspeedy-0.4.1.ebuild
parentpython_mod_optimize is ROOT aware. Fixed python_mod_cleanup. (diff)
downloadhistorical-ce3d03c20838dfb3b5ba389c32dad7677315a8d7.tar.gz
historical-ce3d03c20838dfb3b5ba389c32dad7677315a8d7.tar.bz2
historical-ce3d03c20838dfb3b5ba389c32dad7677315a8d7.zip
python_mod_{cleanup,optimize} are ROOT aware. Quoting.
Package-Manager: portage-2.1.5.2
Diffstat (limited to 'sys-power/cpuspeedy/cpuspeedy-0.4.1.ebuild')
-rw-r--r--sys-power/cpuspeedy/cpuspeedy-0.4.1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sys-power/cpuspeedy/cpuspeedy-0.4.1.ebuild b/sys-power/cpuspeedy/cpuspeedy-0.4.1.ebuild
index 39bbb4857860..688884034453 100644
--- a/sys-power/cpuspeedy/cpuspeedy-0.4.1.ebuild
+++ b/sys-power/cpuspeedy/cpuspeedy-0.4.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpuspeedy/cpuspeedy-0.4.1.ebuild,v 1.2 2007/02/01 11:31:14 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpuspeedy/cpuspeedy-0.4.1.ebuild,v 1.3 2008/05/29 18:11:15 hawking Exp $
inherit python multilib
@@ -19,16 +19,16 @@ src_compile() {
src_install() {
emake install PREFIX="${D}"/usr || die "make install failed"
- sed -i -e "s:${D}::" ${D}/usr/sbin/cpuspeedy
+ sed -i -e "s:${D}::" "${D}"/usr/sbin/cpuspeedy
mv "${D}"/usr/share/doc/cpuspeedy "${D}"/usr/share/doc/${PF}
dodir /usr/share
mv "${D}"/usr/man "${D}"/usr/share
}
pkg_postinst() {
- python_mod_optimize "${ROOT}"usr/$(get_libdir)/${PN}
+ python_mod_optimize /usr/$(get_libdir)/${PN}
}
pkg_postrm() {
- python_mod_cleanup "${ROOT}"usr/$(get_libdir)/${PN}
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
}