summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-07-17 19:53:50 +0000
committerMike Frysinger <vapier@gentoo.org>2007-07-17 19:53:50 +0000
commit45abfb27350df328c18912f3fa1f6494c3ba20e0 (patch)
treecec3b532ce53d897783be834b3ad95e13edb4d27 /sys-power/acpid/acpid-1.0.6.ebuild
parentstable x86, security bug 171884 (diff)
downloadhistorical-45abfb27350df328c18912f3fa1f6494c3ba20e0.tar.gz
historical-45abfb27350df328c18912f3fa1f6494c3ba20e0.tar.bz2
historical-45abfb27350df328c18912f3fa1f6494c3ba20e0.zip
Use Gentoo defaults for /etc/acpi again since they are better than the Debian ones and fix bashism #170213 by Roy Marples. Also make sure we respect env CFLAGS.
Package-Manager: portage-2.1.3_rc8
Diffstat (limited to 'sys-power/acpid/acpid-1.0.6.ebuild')
-rw-r--r--sys-power/acpid/acpid-1.0.6.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/sys-power/acpid/acpid-1.0.6.ebuild b/sys-power/acpid/acpid-1.0.6.ebuild
index 2fefc12290b6..ef9c9fd1cab2 100644
--- a/sys-power/acpid/acpid-1.0.6.ebuild
+++ b/sys-power/acpid/acpid-1.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/acpid-1.0.6.ebuild,v 1.1 2007/07/17 19:42:55 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/acpid-1.0.6.ebuild,v 1.2 2007/07/17 19:53:50 vapier Exp $
inherit eutils toolchain-funcs
@@ -18,8 +18,10 @@ RDEPEND=""
src_unpack() {
unpack ${A}
-
- epatch ${FILESDIR}/${P}-examples.diff
+ cd "${S}"
+ sed -i \
+ -e '/^CFLAGS /{s:=:+=:;s:-Werror -g::}' \
+ Makefile
}
src_compile() {
@@ -33,18 +35,17 @@ src_install() {
emake INSTPREFIX="${D}" install || die "emake install failed"
exeinto /etc/acpi
- doexe examples/default.sh
+ newexe "${FILESDIR}"/${P}-default.sh default.sh || die
insinto /etc/acpi/events
- doins examples/default
+ newins "${FILESDIR}"/acpid-1.0.4-default default || die
dodoc README Changelog TODO
- newinitd ${FILESDIR}/${P}-init.d acpid
- newconfd ${FILESDIR}/${P}-conf.d acpid
+ newinitd "${FILESDIR}"/${P}-init.d acpid
+ newconfd "${FILESDIR}"/${P}-conf.d acpid
docinto examples
dodoc samples/{acpi_handler.sh,sample.conf}
- dodoc examples/ac{,.sh}
docinto examples/battery
dodoc samples/battery/*