summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-04-15 21:11:27 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-04-15 21:11:27 +0000
commitaa169beaf155e73ef99a432163c0498030ed9566 (patch)
treea40d8b0fa4345439076e0488e624872f38f3d9fb /sys-libs
parentversion bump, fixes 66853 (diff)
downloadhistorical-aa169beaf155e73ef99a432163c0498030ed9566.tar.gz
historical-aa169beaf155e73ef99a432163c0498030ed9566.tar.bz2
historical-aa169beaf155e73ef99a432163c0498030ed9566.zip
Don't use __thread on sparc32 because it causes a segfault.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/Manifest8
-rw-r--r--sys-libs/glibc/glibc-2.3.5.ebuild17
2 files changed, 14 insertions, 11 deletions
diff --git a/sys-libs/glibc/Manifest b/sys-libs/glibc/Manifest
index 7d50c1c145c7..39efdefa6662 100644
--- a/sys-libs/glibc/Manifest
+++ b/sys-libs/glibc/Manifest
@@ -12,7 +12,7 @@ MD5 567094e03359ffc1c95af7356395228d metadata.xml 162
MD5 b85c16a0e65a32784335e40fb0edac0e glibc-2.2.5-r10.ebuild 4418
MD5 bbaa27a858966f07a584101f1be106a8 glibc-2.3.4.20050125.ebuild 35424
MD5 6a8d1a51a1ca4f96840bff95c45b2ab1 glibc-2.3.4.20050125-r1.ebuild 38164
-MD5 6a56b6491c3d0e639c679793c86797b7 glibc-2.3.5.ebuild 38373
+MD5 9ff2fe4ec57ac6fcdcfa7f16e1d369ad glibc-2.3.5.ebuild 38522
MD5 1ccc533e526eaa771e262db1dbe27ff7 glibc-2.3.4.20041102-r1.ebuild 33599
MD5 9cc1e6b6f749dba7c8759bd07266f7d9 files/digest-glibc-2.2.5-r9 143
MD5 2d5306ef875573750af642a9f93b634a files/digest-glibc-2.3.2-r12 312
@@ -150,7 +150,7 @@ MD5 b80890f83185acef8aeff622a1574e0b files/2.3.4/glibc-2.3.4-fix-_dl_next_tls_mo
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFCXhlSArHZZzCEUG0RAr55AJ9YFUEr1nYFJbLxk+0xsTc1T25srgCfZe5u
-89v72pIo6igmOUxcKP/wXQM=
-=meo2
+iD8DBQFCYC4QArHZZzCEUG0RAuoNAJ9vbmvhGmRQXxyF/cRwVKkAftcJ4ACdGogd
+FF0cIFsDghAd8N/j8fgy9Es=
+=o0Om
-----END PGP SIGNATURE-----
diff --git a/sys-libs/glibc/glibc-2.3.5.ebuild b/sys-libs/glibc/glibc-2.3.5.ebuild
index efc453cbb21f..44728479ffab 100644
--- a/sys-libs/glibc/glibc-2.3.5.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.ebuild,v 1.4 2005/04/14 07:17:58 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.ebuild,v 1.5 2005/04/15 21:11:27 eradicator Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -790,6 +790,9 @@ want_tls() {
want__thread() {
want_tls || return 1
+ # For some reason --with-tls --with__thread is causing segfaults on sparc32.
+ [[ ${PROFILE_ARCH} == "sparc" ]] && return 1
+
[[ -n ${WANT__THREAD} ]] && return ${WANT__THREAD}
$(tc-getCC ${CTARGET}) -c ${FILESDIR}/test-__thread.c -o ${T}/test2.o &> /dev/null
@@ -851,14 +854,14 @@ glibc_do_configure() {
if [ "$1" == "linuxthreads" ] ; then
if want_tls ; then
myconf="${myconf} --with-tls"
- else
- myconf="${myconf} --without-tls"
- fi
- if want__thread ; then
- myconf="${myconf} --with-__thread"
+ if want__thread ; then
+ myconf="${myconf} --with-__thread"
+ else
+ myconf="${myconf} --without-__thread"
+ fi
else
- myconf="${myconf} --without-__thread"
+ myconf="${myconf} --without-tls --without-__thread"
fi
myconf="${myconf} --enable-add-ons=linuxthreads${ADDONS}"