summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul de Vrieze <pauldv@gentoo.org>2003-05-24 12:18:45 +0000
committerPaul de Vrieze <pauldv@gentoo.org>2003-05-24 12:18:45 +0000
commit7852c3499dfb8adf2fb965f91689e23cbdea7a10 (patch)
tree0203692f0877b708d0787d992391343cc384a5cc /sys-libs
parentlittle corrections (diff)
downloadhistorical-7852c3499dfb8adf2fb965f91689e23cbdea7a10.tar.gz
historical-7852c3499dfb8adf2fb965f91689e23cbdea7a10.tar.bz2
historical-7852c3499dfb8adf2fb965f91689e23cbdea7a10.zip
Fix to have /usr/include/db.h link to the most recent db
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/db/Manifest6
-rw-r--r--sys-libs/db/db-3.2.9-r5.ebuild8
-rw-r--r--sys-libs/db/db-4.0.14.ebuild8
-rw-r--r--sys-libs/db/db-4.1.24.ebuild7
4 files changed, 22 insertions, 7 deletions
diff --git a/sys-libs/db/Manifest b/sys-libs/db/Manifest
index a75ec667e4c2..492645618e77 100644
--- a/sys-libs/db/Manifest
+++ b/sys-libs/db/Manifest
@@ -5,9 +5,9 @@ MD5 4be311009c1216a911e76dcf33bb568d db-3.2.9-r1.ebuild 2587
MD5 e03298e927335414c7db1882f24ed8e4 db-3.2.9-r2.ebuild 3221
MD5 af7ea3ee5a3a001d516413c0b9bc52e5 db-3.2.9.ebuild 2464
MD5 2dd3cac46936c5510bf2133977ff5a48 db-3.3.11.ebuild 2408
-MD5 632b7c2f6a5da4d0064202b9644bf05f db-4.1.24.ebuild 1756
-MD5 1f899d49fe0de735847c6c0016174745 db-4.0.14.ebuild 1904
-MD5 bd4838773fc92042828e59d812c59bea db-3.2.9-r5.ebuild 3914
+MD5 4101b40582142f95368a0cd1ae5a23e3 db-4.1.24.ebuild 1900
+MD5 6fa4e401e7d17f138554e9184f719571 db-4.0.14.ebuild 2054
+MD5 448daf2768b4e0cc43882911106068bd db-3.2.9-r5.ebuild 4033
MD5 194200b3295b95b46b4564980af27f1f files/db-3.2.9-fix-dep-link.patch 1005
MD5 ecd81fa9868ec49c61306444144d44a9 files/db.1.85.patch 55584
MD5 3057fcc117c33a02bd4c092586a58e49 files/digest-db-1.85-r1 59
diff --git a/sys-libs/db/db-3.2.9-r5.ebuild b/sys-libs/db/db-3.2.9-r5.ebuild
index 414a3bc42598..007273487245 100644
--- a/sys-libs/db/db-3.2.9-r5.ebuild
+++ b/sys-libs/db/db-3.2.9-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r5.ebuild,v 1.1 2003/05/24 11:48:05 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r5.ebuild,v 1.2 2003/05/24 12:18:37 pauldv Exp $
IUSE=""
@@ -132,7 +132,7 @@ src_install () {
do
mv ${fname} ${fname//\/db_/\/db4_}
done
- rm ${D}/usr/include/db.h
+ ln -sf /usr/include/db4/db.h ${D}/usr/include/db.h
}
fix_so () {
@@ -144,6 +144,10 @@ fix_so () {
target=`find -type f -maxdepth 1 -name "libdb_tcl*.so" |tail -n 1`
[ ${target} ] && ln -sf ${target//.\//} libdb_tcl.so
cd -
+ cd /usr/include
+ target=`ls db? |tail -n 1`
+ [ ${target} ] && ln -sf ${target}/db.h .
+ cd -
}
pkg_postinst () {
diff --git a/sys-libs/db/db-4.0.14.ebuild b/sys-libs/db/db-4.0.14.ebuild
index 28ea7d9c99a9..3b5a8b3d927a 100644
--- a/sys-libs/db/db-4.0.14.ebuild
+++ b/sys-libs/db/db-4.0.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.0.14.ebuild,v 1.15 2003/05/24 11:48:05 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.0.14.ebuild,v 1.16 2003/05/24 12:18:37 pauldv Exp $
IUSE="tcltk java"
@@ -60,6 +60,7 @@ src_install () {
dodir /usr/share/doc/${PF}/html
mv ${D}/usr/docs/* ${D}/usr/share/doc/${PF}/html/
+ ln -s /usr/include/db4/db.h ${D}/usr/include/db.h
}
fix_so () {
@@ -70,6 +71,11 @@ fix_so () {
[ ${target} ] && ln -sf ${target//.\//} libdb_cxx.so
target=`find -type f -maxdepth 1 -name "libdb_tcl*.so" |tail -n 1`
[ ${target} ] && ln -sf ${target//.\//} libdb_tcl.so
+ cd -
+ cd /usr/include
+ target=`ls db? |tail -n 1`
+ [ ${target} ] && ln -sf ${target}/db.h .
+ cd -
}
pkg_postinst () {
diff --git a/sys-libs/db/db-4.1.24.ebuild b/sys-libs/db/db-4.1.24.ebuild
index 93f2e23c556b..bc9fc02ec27d 100644
--- a/sys-libs/db/db-4.1.24.ebuild
+++ b/sys-libs/db/db-4.1.24.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.24.ebuild,v 1.10 2003/05/24 11:48:05 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.24.ebuild,v 1.11 2003/05/24 12:18:37 pauldv Exp $
IUSE="tcltk java"
@@ -55,6 +55,7 @@ src_install () {
dodir /usr/share/doc/${PF}/html
mv ${D}/usr/docs/* ${D}/usr/share/doc/${PF}/html/
+ ln -s /usr/include/db4/db.h ${D}/usr/include/db.h
}
fix_so () {
@@ -66,6 +67,10 @@ fix_so () {
target=`find -type f -maxdepth 1 -name "libdb_tcl*.so" |tail -n 1`
[ ${target} ] && ln -sf ${target//.\//} libdb_tcl.so
cd -
+ cd /usr/include
+ target=`ls db? |tail -n 1`
+ [ ${target} ] && ln -sf ${target}/db.h .
+ cd -
}
pkg_postinst () {