summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-03-05 23:24:04 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-03-05 23:24:04 +0000
commit459c4fb6cc77e300fcc1a3a5bda350f427088cf9 (patch)
treedf6be6ffb56f2a4e78abfcab72f5b58c494bb365 /sys-libs
parentadded grsec support (diff)
downloadhistorical-459c4fb6cc77e300fcc1a3a5bda350f427088cf9.tar.gz
historical-459c4fb6cc77e300fcc1a3a5bda350f427088cf9.tar.bz2
historical-459c4fb6cc77e300fcc1a3a5bda350f427088cf9.zip
Fixed want_linuxthreads logic.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/Manifest8
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild8
2 files changed, 6 insertions, 10 deletions
diff --git a/sys-libs/glibc/Manifest b/sys-libs/glibc/Manifest
index b7774df37acb..b1010ae2b431 100644
--- a/sys-libs/glibc/Manifest
+++ b/sys-libs/glibc/Manifest
@@ -11,7 +11,7 @@ MD5 ab06008394eb7c6aa17a674cae788eef glibc-2.3.4.20041102.ebuild 32888
MD5 567094e03359ffc1c95af7356395228d metadata.xml 162
MD5 b85c16a0e65a32784335e40fb0edac0e glibc-2.2.5-r10.ebuild 4418
MD5 695f1e83d1cb212d83d97f0d2989cb94 glibc-2.3.4.20050125.ebuild 35240
-MD5 74d72f5ec4c23bdab85a311f0c188a8c glibc-2.3.4.20050125-r1.ebuild 37021
+MD5 739bf88a09b6c4617c45cc89f9bfdca2 glibc-2.3.4.20050125-r1.ebuild 36974
MD5 9cc1e6b6f749dba7c8759bd07266f7d9 files/digest-glibc-2.2.5-r9 143
MD5 2d5306ef875573750af642a9f93b634a files/digest-glibc-2.3.2-r12 312
MD5 42af7e35fe2404a49954f91fd1aee891 files/digest-glibc-2.3.3.20040420-r2 312
@@ -145,7 +145,7 @@ MD5 b72e5aca6d834026a6f5fb87623e6fd3 files/2.3.4/host.conf 1302
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)
-iD8DBQFCKjNJArHZZzCEUG0RApqGAKCKNCcgDHyvZbBCrX1GLtwuPQJ7LgCfcMCu
-i8t+XOUzyP3dTdTK2Vva6zw=
-=hIoH
+iD8DBQFCKj+fArHZZzCEUG0RAt5hAJsElPW+TGX+rfPGy1bqSZF5yJl9NQCfcfGB
+hUQtcP5Id9DqPtBx6GhG6yY=
+=WqgD
-----END PGP SIGNATURE-----
diff --git a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
index 543062fd43d8..5d6f14028344 100644
--- a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.11 2005/03/05 22:31:27 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.12 2005/03/05 23:24:04 eradicator Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -732,14 +732,10 @@ want_nptl() {
return 1
}
-
want_linuxthreads() {
- ! use nptlonly && return 0
- want_nptl || return 0
- return 1
+ ! use nptlonly
}
-
want_tls() {
# Archs that can use TLS (Thread Local Storage)
case $(tc-arch) in