summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-27 03:17:50 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-27 03:17:50 +0000
commit2c2085d2786e78381b01859fcbccafe65845f7e0 (patch)
tree5afe17f618366d52feb81e8f1e35d272716fc469 /sys-libs
parentrepoman: whitespace cleanup (diff)
downloadhistorical-2c2085d2786e78381b01859fcbccafe65845f7e0.tar.gz
historical-2c2085d2786e78381b01859fcbccafe65845f7e0.tar.bz2
historical-2c2085d2786e78381b01859fcbccafe65845f7e0.zip
fix the sparc CHOST munging
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.3.2-r10.ebuild7
-rw-r--r--sys-libs/glibc/glibc-2.3.2-r2.ebuild7
-rw-r--r--sys-libs/glibc/glibc-2.3.2-r3.ebuild5
-rw-r--r--sys-libs/glibc/glibc-2.3.2-r9.ebuild7
-rw-r--r--sys-libs/glibc/glibc-2.3.3_pre20031210.ebuild7
-rw-r--r--sys-libs/glibc/glibc-2.3.3_pre20040117-r1.ebuild7
-rw-r--r--sys-libs/glibc/glibc-2.3.3_pre20040117.ebuild7
-rw-r--r--sys-libs/glibc/glibc-2.3.3_pre20040207.ebuild7
-rw-r--r--sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild7
9 files changed, 35 insertions, 26 deletions
diff --git a/sys-libs/glibc/glibc-2.3.2-r10.ebuild b/sys-libs/glibc/glibc-2.3.2-r10.ebuild
index a15247fc4a29..57d8053b6d69 100644
--- a/sys-libs/glibc/glibc-2.3.2-r10.ebuild
+++ b/sys-libs/glibc/glibc-2.3.2-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r10.ebuild,v 1.8 2004/04/27 02:10:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r10.ebuild,v 1.9 2004/04/27 03:17:50 vapier Exp $
IUSE="nls pic build nptl"
@@ -427,7 +427,7 @@ setup_flags() {
use ppc || append-flags "-freorder-blocks"
# Sparc/Sparc64 support
- if [ -n "`use sparc`" ]
+ if use sparc
then
# Both sparc and sparc64 can use -fcall-used-g6. -g7 is bad, though.
@@ -447,7 +447,8 @@ setup_flags() {
# Setup the CHOST properly to insure "sparcv9"
# This passes -mcpu=ultrasparc -Wa,-Av9a to the compiler
- export CHOST="${CHOST/sparc/sparcv9}"
+ [ "${CHOST}" == "sparc-unknown-linux-gnu" ] && \
+ export CHOST="sparcv9-unknown-linux-gnu"
fi
fi
}
diff --git a/sys-libs/glibc/glibc-2.3.2-r2.ebuild b/sys-libs/glibc/glibc-2.3.2-r2.ebuild
index 5b57dce1d846..0aea6754e743 100644
--- a/sys-libs/glibc/glibc-2.3.2-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r2.ebuild,v 1.17 2004/03/25 06:55:50 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r2.ebuild,v 1.18 2004/04/27 03:17:50 vapier Exp $
IUSE="nls pic build nptl"
@@ -400,7 +400,7 @@ setup_flags() {
use ppc || append-flags "-freorder-blocks"
# Sparc/Sparc64 support
- if [ -n "`use sparc`" ]
+ if use sparc
then
# Both sparc and sparc64 can use -fcall-used-g6. -g7 is bad, though.
@@ -420,7 +420,8 @@ setup_flags() {
# Setup the CHOST properly to insure "sparcv9"
# This passes -mcpu=ultrasparc -Wa,-Av9a to the compiler
- export CHOST=${CHOST/sparc/sparcv9}
+ [ "${CHOST}" == "sparc-unknown-linux-gnu" ] && \
+ export CHOST="sparcv9-unknown-linux-gnu"
fi
fi
}
diff --git a/sys-libs/glibc/glibc-2.3.2-r3.ebuild b/sys-libs/glibc/glibc-2.3.2-r3.ebuild
index 749a22305fb0..5ba33054b59f 100644
--- a/sys-libs/glibc/glibc-2.3.2-r3.ebuild
+++ b/sys-libs/glibc/glibc-2.3.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r3.ebuild,v 1.16 2004/04/24 08:21:10 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r3.ebuild,v 1.17 2004/04/27 03:17:50 vapier Exp $
IUSE="nls pic build nptl"
@@ -371,7 +371,8 @@ setup_flags() {
# Setup the CHOST properly to insure "sparcv9"
# This passes -mcpu=ultrasparc -Wa,-Av9a to the compiler
- export CHOST=${CHOST/sparc/sparcv9}
+ [ "${CHOST}" == "sparc-unknown-linux-gnu" ] && \
+ export CHOST="sparcv9-unknown-linux-gnu"
fi
fi
}
diff --git a/sys-libs/glibc/glibc-2.3.2-r9.ebuild b/sys-libs/glibc/glibc-2.3.2-r9.ebuild
index dd855cf71d0f..995fd2068d17 100644
--- a/sys-libs/glibc/glibc-2.3.2-r9.ebuild
+++ b/sys-libs/glibc/glibc-2.3.2-r9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r9.ebuild,v 1.23 2004/03/18 22:08:09 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r9.ebuild,v 1.24 2004/04/27 03:17:50 vapier Exp $
IUSE="nls pic build nptl"
@@ -409,7 +409,7 @@ setup_flags() {
use ppc || append-flags "-freorder-blocks"
# Sparc/Sparc64 support
- if [ -n "`use sparc`" ]
+ if use sparc
then
# Both sparc and sparc64 can use -fcall-used-g6. -g7 is bad, though.
@@ -429,7 +429,8 @@ setup_flags() {
# Setup the CHOST properly to insure "sparcv9"
# This passes -mcpu=ultrasparc -Wa,-Av9a to the compiler
- export CHOST="${CHOST/sparc/sparcv9}"
+ [ "${CHOST}" == "sparc-unknown-linux-gnu" ] && \
+ export CHOST="sparcv9-unknown-linux-gnu"
fi
fi
}
diff --git a/sys-libs/glibc/glibc-2.3.3_pre20031210.ebuild b/sys-libs/glibc/glibc-2.3.3_pre20031210.ebuild
index 233fc0541a76..b5f9012b3233 100644
--- a/sys-libs/glibc/glibc-2.3.3_pre20031210.ebuild
+++ b/sys-libs/glibc/glibc-2.3.3_pre20031210.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20031210.ebuild,v 1.6 2004/04/18 09:22:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20031210.ebuild,v 1.7 2004/04/27 03:17:50 vapier Exp $
IUSE="nls pic build nptl"
@@ -416,7 +416,7 @@ setup_flags() {
use ppc || append-flags "-freorder-blocks"
# Sparc/Sparc64 support
- if [ -n "`use sparc`" ]
+ if use sparc
then
# Both sparc and sparc64 can use -fcall-used-g6. -g7 is bad, though.
@@ -436,7 +436,8 @@ setup_flags() {
# Setup the CHOST properly to insure "sparcv9"
# This passes -mcpu=ultrasparc -Wa,-Av9a to the compiler
- export CHOST="${CHOST/sparc/sparcv9}"
+ [ "${CHOST}" == "sparc-unknown-linux-gnu" ] && \
+ export CHOST="sparcv9-unknown-linux-gnu"
fi
fi
}
diff --git a/sys-libs/glibc/glibc-2.3.3_pre20040117-r1.ebuild b/sys-libs/glibc/glibc-2.3.3_pre20040117-r1.ebuild
index 1e89822c21dd..a80abcd0dbf6 100644
--- a/sys-libs/glibc/glibc-2.3.3_pre20040117-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.3_pre20040117-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20040117-r1.ebuild,v 1.4 2004/04/18 09:22:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20040117-r1.ebuild,v 1.5 2004/04/27 03:17:50 vapier Exp $
IUSE="nls pic build nptl"
@@ -424,7 +424,7 @@ setup_flags() {
use ppc || append-flags "-freorder-blocks"
# Sparc/Sparc64 support
- if [ -n "`use sparc`" ]
+ if use sparc
then
# Both sparc and sparc64 can use -fcall-used-g6. -g7 is bad, though.
@@ -444,7 +444,8 @@ setup_flags() {
# Setup the CHOST properly to insure "sparcv9"
# This passes -mcpu=ultrasparc -Wa,-Av9a to the compiler
- export CHOST="${CHOST/sparc/sparcv9}"
+ [ "${CHOST}" == "sparc-unknown-linux-gnu" ] && \
+ export CHOST="sparcv9-unknown-linux-gnu"
fi
fi
}
diff --git a/sys-libs/glibc/glibc-2.3.3_pre20040117.ebuild b/sys-libs/glibc/glibc-2.3.3_pre20040117.ebuild
index bb489d08c1a9..44adef83321e 100644
--- a/sys-libs/glibc/glibc-2.3.3_pre20040117.ebuild
+++ b/sys-libs/glibc/glibc-2.3.3_pre20040117.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20040117.ebuild,v 1.5 2004/04/18 09:22:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20040117.ebuild,v 1.6 2004/04/27 03:17:50 vapier Exp $
IUSE="nls pic build nptl"
@@ -405,7 +405,7 @@ setup_flags() {
use ppc || append-flags "-freorder-blocks"
# Sparc/Sparc64 support
- if [ -n "`use sparc`" ]
+ if use sparc
then
# Both sparc and sparc64 can use -fcall-used-g6. -g7 is bad, though.
@@ -425,7 +425,8 @@ setup_flags() {
# Setup the CHOST properly to insure "sparcv9"
# This passes -mcpu=ultrasparc -Wa,-Av9a to the compiler
- export CHOST="${CHOST/sparc/sparcv9}"
+ [ "${CHOST}" == "sparc-unknown-linux-gnu" ] && \
+ export CHOST="sparcv9-unknown-linux-gnu"
fi
fi
}
diff --git a/sys-libs/glibc/glibc-2.3.3_pre20040207.ebuild b/sys-libs/glibc/glibc-2.3.3_pre20040207.ebuild
index 85b281f9b026..f9a417634c53 100644
--- a/sys-libs/glibc/glibc-2.3.3_pre20040207.ebuild
+++ b/sys-libs/glibc/glibc-2.3.3_pre20040207.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20040207.ebuild,v 1.8 2004/04/18 09:22:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20040207.ebuild,v 1.9 2004/04/27 03:17:50 vapier Exp $
IUSE="nls pic build nptl"
@@ -438,7 +438,7 @@ setup_flags() {
use ppc || append-flags "-freorder-blocks"
# Sparc/Sparc64 support
- if [ -n "`use sparc`" ]
+ if use sparc
then
# Both sparc and sparc64 can use -fcall-used-g6. -g7 is bad, though.
@@ -458,7 +458,8 @@ setup_flags() {
# Setup the CHOST properly to insure "sparcv9"
# This passes -mcpu=ultrasparc -Wa,-Av9a to the compiler
- export CHOST="${CHOST/sparc/sparcv9}"
+ [ "${CHOST}" == "sparc-unknown-linux-gnu" ] && \
+ export CHOST="sparcv9-unknown-linux-gnu"
fi
fi
}
diff --git a/sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild b/sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild
index cabd3e1d7dbe..05ec35e7c227 100644
--- a/sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild
+++ b/sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild,v 1.1 2004/04/25 21:50:06 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild,v 1.2 2004/04/27 03:17:50 vapier Exp $
IUSE="nls pic build nptl"
@@ -439,7 +439,7 @@ setup_flags() {
use ppc || append-flags "-freorder-blocks"
# Sparc/Sparc64 support
- if [ -n "`use sparc`" ]
+ if use sparc
then
# Both sparc and sparc64 can use -fcall-used-g6. -g7 is bad, though.
@@ -459,7 +459,8 @@ setup_flags() {
# Setup the CHOST properly to insure "sparcv9"
# This passes -mcpu=ultrasparc -Wa,-Av9a to the compiler
- export CHOST="${CHOST/sparc/sparcv9}"
+ [ "${CHOST}" == "sparc-unknown-linux-gnu" ] && \
+ export CHOST="sparcv9-unknown-linux-gnu"
fi
fi
}