summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-01 10:10:12 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-01 10:10:12 +0000
commitdc82d217926b16cc855a22bce173bcacababcdb3 (patch)
treeb5458ebdb3b40d35614f81d66c4808b20b0bb654 /sys-libs/uclibc
parentremoved stale entries for gcl and xfoil (diff)
downloadhistorical-dc82d217926b16cc855a22bce173bcacababcdb3.tar.gz
historical-dc82d217926b16cc855a22bce173bcacababcdb3.tar.bz2
historical-dc82d217926b16cc855a22bce173bcacababcdb3.zip
dont run scanelf when cross-compiling and fix stack_end issues #113343
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'sys-libs/uclibc')
-rw-r--r--sys-libs/uclibc/Manifest10
-rw-r--r--sys-libs/uclibc/files/digest-uclibc-0.9.282
-rw-r--r--sys-libs/uclibc/uclibc-0.9.28.ebuild34
3 files changed, 26 insertions, 20 deletions
diff --git a/sys-libs/uclibc/Manifest b/sys-libs/uclibc/Manifest
index f0c012ff80bb..a2b61a664dd1 100644
--- a/sys-libs/uclibc/Manifest
+++ b/sys-libs/uclibc/Manifest
@@ -4,16 +4,16 @@ Hash: SHA1
MD5 bce3bfbe67f2845926f95b3f385001ae ChangeLog 9930
MD5 e6443710aea7fb2e9056b67be27b68d1 files/digest-uclibc-0.9.27 229
MD5 9a39fb9a2446443aa355070e819107a0 files/digest-uclibc-0.9.27-r1 298
-MD5 851ff3547906842b0d94c848a876be2c files/digest-uclibc-0.9.28 213
+MD5 5e3f364e7e96a163916680b986888c8f files/digest-uclibc-0.9.28 213
MD5 684def72ebc0da73cb8b6d1c53e7e8fb files/getent 1112
MD5 e96b4dfc373a1cdf7735aeae52c4cf7e metadata.xml 999
MD5 a14255e8f1b11819e8e64051861001ce uclibc-0.9.27-r1.ebuild 12125
MD5 81cee933f6981c689db448c06576ec3c uclibc-0.9.27.ebuild 10387
-MD5 7093e6433cbe7672f2551286c869d2ff uclibc-0.9.28.ebuild 13083
+MD5 6bf0209ddd273a6fe688be1d387bc1d3 uclibc-0.9.28.ebuild 13267
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDjq2RgIKl8Uu19MoRAifxAJ9UZymEeShcgcqtc77G1B8OxY5cFQCfQKme
-tnHLdcTcmNb47TLALZCDCZc=
-=UTZz
+iD8DBQFDjsyZgIKl8Uu19MoRAtByAJ4tl7/KEzcmoAsj+nckqVNJMDsgnQCfXsXw
+MwLxWXsx2Xhu7MLv4dfMU9g=
+=TP8d
-----END PGP SIGNATURE-----
diff --git a/sys-libs/uclibc/files/digest-uclibc-0.9.28 b/sys-libs/uclibc/files/digest-uclibc-0.9.28
index 4d5df4c5bbbc..3159c1262a41 100644
--- a/sys-libs/uclibc/files/digest-uclibc-0.9.28
+++ b/sys-libs/uclibc/files/digest-uclibc-0.9.28
@@ -1,3 +1,3 @@
-MD5 7b867551d59399d2fff438aaee08f296 uClibc-0.9.28-patches-1.1.tar.bz2 20041
+MD5 c546948abd2c1e3f8cbb01caae248537 uClibc-0.9.28-patches-1.2.tar.bz2 19862
MD5 1ada58d919a82561061e4741fb6abd29 uClibc-0.9.28.tar.bz2 1763847
MD5 d75b2239b4e27c3c9cbed1c8f6eabba6 uClibc-locale-030818.tgz 236073
diff --git a/sys-libs/uclibc/uclibc-0.9.28.ebuild b/sys-libs/uclibc/uclibc-0.9.28.ebuild
index a39c37b1f806..7ae93cd426f2 100644
--- a/sys-libs/uclibc/uclibc-0.9.28.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.28.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.ebuild,v 1.13 2005/11/25 22:20:41 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.ebuild,v 1.14 2005/12/01 10:10:12 vapier Exp $
#ESVN_REPO_URI="svn://uclibc.org/trunk/uClibc"
#inherit subversion
@@ -21,7 +21,7 @@ fi
MY_P=uClibc-${PV}
SVN_VER=""
-PATCH_VER="1.1"
+PATCH_VER="1.2"
DESCRIPTION="C library for developing embedded Linux systems"
HOMEPAGE="http://www.uclibc.org/"
SRC_URI="http://www.kernel.org/pub/linux/libs/uclibc/${MY_P}.tar.bz2
@@ -213,19 +213,25 @@ src_unpack() {
local moredefs="DL_FINI_CRT_COMPAT"
# We need todo this for a few months. .28 is a major upgrade.
- if ! use uclibc-compat && [[ "$UCLIBC_SCANED_COMPAT" == "" ]]; then
- local fnames=""
- einfo "Doing a scanelf in paths for bins containing the __uClibc_start_main symbol"
- fnames="$(scanelf -pyqs__uClibc_start_main -F%F#s)"
- if [ "$fnames" == "" ]; then
- einfo "This system is clean."
- einfo "To prevent the scanning of files again in the future you can export UCLIBC_SCANED_COMPAT=1"
- moredefs=""
+ # Don't do it from cross-compiling case though
+ if ! use uclibc-compat ; then
+ if [[ -z ${UCLIBC_AND_GLIBC} ]] && [[ -z ${UCLIBC_SCANNED_COMPAT} ]] && \
+ ! just_headers && [[ ${CHOST} == ${CTARGET} ]] ; then
+ local fnames=""
+ einfo "Doing a scanelf in paths for bins containing the __uClibc_start_main symbol"
+ fnames=$(scanelf -pyqs__uClibc_start_main -F%F#s)
+ if [[ -z ${fnames} ]] ; then
+ einfo "This system is clean."
+ einfo "To prevent the scanning of files again in the future you can export UCLIBC_SCANNED_COMPAT=1"
+ moredefs=""
+ else
+ ewarn "You need to remerge the packages that contain the following files before you can remerge ${P} without USE=uclibc-compat enabled."
+ ewarn "qfile ${fnames}"
+ echo
+ ewarn "Leaving on ${moredefs}"
+ fi
else
- ewarn "You need to remerge the packages that contain the following files before you can remerge ${P} without USE=uclibc-compat enabled."
- ewarn "qfile ${fnames}"
- echo
- ewarn "Leaving on ${moredefs}"
+ moredefs=""
fi
fi
for def in ${moredefs} MALLOC_GLIBC_COMPAT DO_C99_MATH UCLIBC_HAS_{RPC,CTYPE_CHECKED,WCHAR,HEXADECIMAL_FLOATS,GLIBC_CUSTOM_PRINTF,FOPEN_EXCLUSIVE_MODE,GLIBC_CUSTOM_STREAMS,PRINTF_M_SPEC,FTW} ; do