summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-03 03:14:01 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-03 03:14:01 +0000
commit198787c26e56e5ae593979168083e9b8c1104cec (patch)
tree747b4769128e8cd9d13f6d99019689aa5f796723 /sys-libs/ss/ss-1.38.ebuild
parentAdd patch from upstream cvs to fix #83287 by Martin Mokrejs / David James. (diff)
downloadhistorical-198787c26e56e5ae593979168083e9b8c1104cec.tar.gz
historical-198787c26e56e5ae593979168083e9b8c1104cec.tar.bz2
historical-198787c26e56e5ae593979168083e9b8c1104cec.zip
Use bsd-shlibs on Darwin but elf-shlibs on all other systems #99728 by Kito.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'sys-libs/ss/ss-1.38.ebuild')
-rw-r--r--sys-libs/ss/ss-1.38.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sys-libs/ss/ss-1.38.ebuild b/sys-libs/ss/ss-1.38.ebuild
index 3272792b9665..955fcc819d36 100644
--- a/sys-libs/ss/ss-1.38.ebuild
+++ b/sys-libs/ss/ss-1.38.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ss/ss-1.38.ebuild,v 1.8 2005/07/25 19:46:48 killerfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ss/ss-1.38.ebuild,v 1.9 2005/08/03 03:14:01 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -32,8 +32,13 @@ src_unpack() {
}
src_compile() {
+ local libtype
+ case ${USERLAND} in
+ Darwin) libtype=bsd;;
+ *) libtype=elf;;
+ esac
econf \
- --enable-elf-shlibs \
+ --enable-${libtype}-shlibs \
--with-ldopts="${LDFLAGS}" \
$(use_enable nls) \
|| die