summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-26 14:48:25 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-26 14:48:25 +0000
commit75d1cd82f19b2fd9b34820e941b0d9285e58a409 (patch)
tree98a210b54644e9f67aad2dce40e55dc2b4086368 /sys-libs/ncurses
parent*** empty log message *** (diff)
downloadhistorical-75d1cd82f19b2fd9b34820e941b0d9285e58a409.tar.gz
historical-75d1cd82f19b2fd9b34820e941b0d9285e58a409.tar.bz2
historical-75d1cd82f19b2fd9b34820e941b0d9285e58a409.zip
*** empty log message ***
Diffstat (limited to 'sys-libs/ncurses')
-rw-r--r--sys-libs/ncurses/files/digest-ncurses-5.21
-rw-r--r--sys-libs/ncurses/ncurses-5.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-libs/ncurses/files/digest-ncurses-5.2 b/sys-libs/ncurses/files/digest-ncurses-5.2
new file mode 100644
index 000000000000..c4e94d20cd91
--- /dev/null
+++ b/sys-libs/ncurses/files/digest-ncurses-5.2
@@ -0,0 +1 @@
+MD5 464d6a49010cf2a6eb9ce59a264d4d47 ncurses-5.2.tar.gz
diff --git a/sys-libs/ncurses/ncurses-5.2.ebuild b/sys-libs/ncurses/ncurses-5.2.ebuild
new file mode 100644
index 000000000000..5716a41bebab
--- /dev/null
+++ b/sys-libs/ncurses/ncurses-5.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.2.ebuild,v 1.1 2000/11/26 14:48:25 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Linux console display libarary"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/ncurses/${A}
+ ftp://ftp.gnu.org/pub/gnu/ncurses/${A}"
+HOMEPAGE="http://www.gnu.org/software/ncurses/ncurses.html"
+
+src_compile() {
+ try ./configure --prefix=/usr --enable-symlinks --disable-termcap \
+ --with-gpm --with-shared --without-debug --with-rcs-ids --host=${CHOST}
+ try make
+}
+
+src_install() {
+ try make prefix=${D}/usr install
+ #move to root so that we can use ncurses on boot
+ cd ${D}/usr/lib
+ dodir /lib
+ mv *.so* ../../lib
+ preplib /
+ cd ${S}
+ dodoc ANNOUNCE MANIFEST NEWS README* TO-DO
+ dodoc doc/*.doc
+ docinto html
+ dodoc doc/html/*.html
+ docinto html/ada
+ dodoc doc/html/ada/*.htm
+ docinto html/ada/files
+ dodoc doc/html/ada/files/*.htm
+ docinto html/ada/funcs
+ dodoc doc/html/ada/funcs/*.htm
+ docinto html/man
+ dodoc doc/html/man/*.html
+ gzip ${D}/usr/man/man1/tack.1
+}
+
+
+