summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2002-04-05 07:27:35 +0000
committerGeert Bevin <gbevin@gentoo.org>2002-04-05 07:27:35 +0000
commit4b55ecd5592507b349fc4ccedbf75d7aeed2313d (patch)
treed2f169fd4682f99c4f52f88015e66465dcf5e47a /sys-libs/ncurses
parentFix for 'use mozilla' symlink. (diff)
downloadhistorical-4b55ecd5592507b349fc4ccedbf75d7aeed2313d.tar.gz
historical-4b55ecd5592507b349fc4ccedbf75d7aeed2313d.tar.bz2
historical-4b55ecd5592507b349fc4ccedbf75d7aeed2313d.zip
gcc3 related header file fix
Diffstat (limited to 'sys-libs/ncurses')
-rw-r--r--sys-libs/ncurses/ChangeLog8
-rw-r--r--sys-libs/ncurses/files/digest-ncurses-5.2.20020112a-r11
-rw-r--r--sys-libs/ncurses/ncurses-5.2.20020112a-r1.ebuild79
3 files changed, 87 insertions, 1 deletions
diff --git a/sys-libs/ncurses/ChangeLog b/sys-libs/ncurses/ChangeLog
index 2981d085bcfd..aaac3ac7d50f 100644
--- a/sys-libs/ncurses/ChangeLog
+++ b/sys-libs/ncurses/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for sys-libs/ncurses
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ChangeLog,v 1.3 2002/03/21 22:10:28 g2boojum Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ChangeLog,v 1.4 2002/04/05 07:27:35 gbevin Exp $
+*ncurses-5.2.20020112a-r1 (205 Apr 2002)
+
+ 05 Apr 2002; Geert Bevin <gbevin@gentoo.org> :
+
+ Small header file fix to make apps that use ncurses compile correctly with gcc3.
+
*ncurses-5.2.20020112a (21 Mar 2002)
21 Mar 2002; Grant Goodyear <g2boojum@gentoo.org> :
diff --git a/sys-libs/ncurses/files/digest-ncurses-5.2.20020112a-r1 b/sys-libs/ncurses/files/digest-ncurses-5.2.20020112a-r1
new file mode 100644
index 000000000000..95eb17b6d237
--- /dev/null
+++ b/sys-libs/ncurses/files/digest-ncurses-5.2.20020112a-r1
@@ -0,0 +1 @@
+MD5 736a02095cd4829f9ed6d644f82cca20 ncurses_5.2.20020112a.orig.tar.gz 1988694
diff --git a/sys-libs/ncurses/ncurses-5.2.20020112a-r1.ebuild b/sys-libs/ncurses/ncurses-5.2.20020112a-r1.ebuild
new file mode 100644
index 000000000000..c5a0e5bf2405
--- /dev/null
+++ b/sys-libs/ncurses/ncurses-5.2.20020112a-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Achim Gottinger <achim@gentoo.org>, Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.2.20020112a-r1.ebuild,v 1.1 2002/04/05 07:27:35 gbevin Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Linux console display library"
+SRC_URI="ftp://ftp.debian.org/debian/pool/main/n/${PN}/${PN}_${PV}.orig.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/ncurses/ncurses.html"
+DEPEND="virtual/glibc"
+
+src_compile() {
+ if [ -z "$DEBUG" ]
+ then
+ myconf="${myconf} --without-debug"
+ fi
+ rm -rf test
+ ./configure --prefix=/usr --libdir=/lib --mandir=/usr/share/man --enable-symlinks --enable-termcap --with-shared --with-rcs-ids --host=${CHOST} ${myconf} || die
+ echo "all:" > test/Makefile
+ # fix to make apps using ncurses compile correctly with gcc3
+ mv include/unctrl.h include/unctrl.h_orig
+ sed -e "s:#include <curses.h>:#include <curses.h>\n#include <ncurses_dll.h>:" \
+ include/unctrl.h_orig > include/unctrl.h
+ # Parallel make fails sometimes so I removed MAKEOPTS
+ make || die
+}
+
+src_install() {
+ dodir /usr/lib
+ echo "install:" >> ${S}/test/Makefile
+ make DESTDIR=${D} install || die
+
+ cd ${D}/lib
+ ln -s libncurses.a libcurses.a
+ chmod 755 ${D}/lib/*.${PV}
+ dodir /usr/lib
+ mv libform* libmenu* libpanel* ../usr/lib
+ mv *.a ../usr/lib
+
+ #with this fix, the default xterm has color as it should
+ cd ${D}/usr/share/terminfo/x
+ mv xterm xterm.orig
+ ln -s xterm-color xterm
+
+ if [ "`use build`" ]
+ then
+ cd ${D}
+ rm -rf usr/share/man
+ cd usr/share/terminfo
+ cp -a l/linux n/nxterm v/vt100 ${T}
+ rm -rf *
+ mkdir l x v
+ cp -a ${T}/linux l
+ cp -a ${T}/nxterm x/xterm
+ cp -a ${T}/vt100 v
+ cd ${D}/usr/lib
+ #bash compilation requires static libncurses libraries, so
+ #this breaks the "build a new build image" system. We now
+ #need to remove libncurses.a from the build image manually.
+ #rm *.a
+ else
+ cd ${S}
+ dodoc ANNOUNCE MANIFEST NEWS README* TO-DO
+ dodoc doc/*.doc
+ dohtml -r doc/html/
+# docinto html/ada
+# dodoc doc/html/ada/*.htm
+# docinto html/ada/files
+# dodoc doc/html/ada/files/*.htm
+# docinto html/ada/funcs
+# dodoc doc/html/ada/funcs/*.htm
+# docinto html/man
+# dodoc doc/html/man/*.html
+ fi
+}
+
+
+