summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-20 04:31:22 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-20 04:31:22 +0000
commit4d4a4c2dd8a92071c8ee81edb21ac43fb670c757 (patch)
tree199cf2b683db8db3e5de9860d58ea73a9d5026f5 /sys-libs/libmath++
parentminor fixes (diff)
downloadhistorical-4d4a4c2dd8a92071c8ee81edb21ac43fb670c757.tar.gz
historical-4d4a4c2dd8a92071c8ee81edb21ac43fb670c757.tar.bz2
historical-4d4a4c2dd8a92071c8ee81edb21ac43fb670c757.zip
ppc support
Diffstat (limited to 'sys-libs/libmath++')
-rw-r--r--sys-libs/libmath++/libmath++-0.0.3.ebuild18
1 files changed, 6 insertions, 12 deletions
diff --git a/sys-libs/libmath++/libmath++-0.0.3.ebuild b/sys-libs/libmath++/libmath++-0.0.3.ebuild
index a900de277515..2861d02a8fc2 100644
--- a/sys-libs/libmath++/libmath++-0.0.3.ebuild
+++ b/sys-libs/libmath++/libmath++-0.0.3.ebuild
@@ -1,28 +1,22 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libmath++/libmath++-0.0.3.ebuild,v 1.6 2003/06/22 05:10:31 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libmath++/libmath++-0.0.3.ebuild,v 1.7 2003/08/20 04:31:22 vapier Exp $
-DESCRIPTION="libmath++ is a template based math library, written in C++, for symbolic and numeric calculus applications"
+DESCRIPTION="template based math library, written in C++, for symbolic and numeric calculus applications"
HOMEPAGE="http://www.surakware.net/projects/libmath%2B%2B/index.xml"
SRC_URI="ftp://ftp.surakware.net/pub/unstable/releases/libmath%2B%2B/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="1"
-KEYWORDS="x86"
+KEYWORDS="x86 ppc"
DEPEND=""
-
-S=${WORKDIR}/${P}
-
src_compile() {
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die "./configure failed"
+ econf || die
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
}